Thread: .net Bluetooth Mobilephone Plugin

  1. #1101
    Newbie
    Join Date
    Feb 2011
    Posts
    2
    Hi guys, I'm having a bit of a problem with the plugin. It connects to my HTC Desire ok, I can answer calls and dial through contacts and hear and talk thru the PC, the only problem is I can't dial with the on screen numbers. All the other buttons work except 0-9 and c(del) but the asterisk and hash work. This is the message I get

    SetErrorScr;Mobilephone.NET;Exception;System.NullR eferenceException:
    Object reference not set to an instance of an object.at MobilePhone.RRExtension.ProcessCommand(String& CMD, Object& frm);5

    I'm running blue soleil 8, Carwings Dynamic Lite skin. Have .net 2.0 and vc runtime installed

    Thanks.

  2. #1102
    Newbie
    Join Date
    Feb 2011
    Posts
    2
    Hi guys, I have a slight problem with the plugin. It connects to my HTC Desire, I can recieve and make calls through contacts, and I can hear and speak through my PC. The only problem is that I can't dial through the on screen keypad. Numbers 0 to 9 and C(del) don't work, but the asterisk, hash and all the other buttons work. This is the popup I get

    SetErrorScr;Mobilephone.NET;Exception;System.NullR eferenceException:
    Object reference not set to an instance of an object.at MobilePhone.RRExtension.ProcessCommand(String& CMD, Object& frm);5

    I'm using Bluesoleil 8 and Carwing dynamic lite skin. I have .net 2.0 and VC runtime installed. Any ideas? I'm pretty sure the first time I ran it the numbers worked, I think there was a security thing use to come up and I had to enter 1234 on the keypad and it worked but now that doesn't come up anymore.

    Thanks.

    Thanks.

  3. #1103
    Newbie
    Join Date
    Jul 2010
    Location
    Bodø¸, Norway, Norway
    Posts
    33
    Tried this some more. I can not get the phone to give up anything other than bluetooth addy and name in bluesoleil (no service list or anything), and I cannot get the plugin to connect to the phone. I had it running for an hour and all the debug file says is
    02.02.2011 03:05:50:Info : Trying to connect to phone.
    02.02.2011 03:06:00:Info : Trying to connect to phone.
    02.02.2011 03:06:10:Info : Trying to connect to phone.
    etcetcetc

  4. #1104
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    Quote Originally Posted by Maidenfan View Post
    Hi guys, I have a slight problem with the plugin. It connects to my HTC Desire, I can recieve and make calls through contacts, and I can hear and speak through my PC. The only problem is that I can't dial through the on screen keypad. Numbers 0 to 9 and C(del) don't work, but the asterisk, hash and all the other buttons work. This is the popup I get

    SetErrorScr;Mobilephone.NET;Exception;System.NullR eferenceException:
    Object reference not set to an instance of an object.at MobilePhone.RRExtension.ProcessCommand(String& CMD, Object& frm);5

    I'm using Bluesoleil 8 and Carwing dynamic lite skin. I have .net 2.0 and VC runtime installed. Any ideas? I'm pretty sure the first time I ran it the numbers worked, I think there was a security thing use to come up and I had to enter 1234 on the keypad and it worked but now that doesn't come up anymore.

    Thanks.

    Thanks.
    what skin are you using or what command are you sending ?

    ---------- Post added at 12:15 AM ---------- Previous post was at 12:14 AM ----------

    Quote Originally Posted by JimL View Post
    Tried this some more. I can not get the phone to give up anything other than bluetooth addy and name in bluesoleil (no service list or anything), and I cannot get the plugin to connect to the phone. I had it running for an hour and all the debug file says is
    02.02.2011 03:05:50:Info : Trying to connect to phone.
    02.02.2011 03:06:00:Info : Trying to connect to phone.
    02.02.2011 03:06:10:Info : Trying to connect to phone.
    etcetcetc
    have you set the mac address. Have you paired your phone through BS.

  5. #1105
    Newbie
    Join Date
    Jul 2010
    Location
    Bodø¸, Norway, Norway
    Posts
    33
    Yes, and yes. But as said even though bluesoleil shows the phone as paired (with the phone name) it's unable to list any services on it. Not sure if that's a problem though, never used bluesoleil. Using BlueSoleil 8.0.338.0 on WinXP so can't really see why it shouldn't work.

  6. #1106
    Low Bitrate
    Join Date
    Dec 2009
    Posts
    73
    Quote Originally Posted by MGD View Post
    Did you set your Phones MAC Address in the ini file ?
    I'm having the same issue with my HTC Evo Shift (Android 2.2), i'm using the ccPhoneTool it pairs with the phone, but then when I try to make a call it tries to connect and it can't. It worked like a charm before with my older phone, a Samsung Instinct. I have the latest version of bluesoleil as well.

  7. #1107
    MGD
    MGD is offline
    FLAC
    Auto Apps:loading...
    MGD's Avatar
    Join Date
    Feb 2005
    Location
    Los Angeles
    Posts
    1,756
    Pairing and Connecting are two differnt things. I have my EVO Shift working perfectly with the plugin. First, make sure you have it paired with BlueSoleil. Tap MENU>>Settings>>WIRELESS & NETWORKS, turn your Phone's Bluetooth off, then turn it back on, now tap BLUETOOTH SETTINGS. Tap SCAN FOR DEVICES and it will detect your CarPC. If it finds your CarPC, it will be listed under Bluetooth Devices with the name of the PC. Under the name it will say Paired but not Connected. Tap and hold where it says Connected but not paired and a popup menu appears. Tap on Options and check both PHONE and MEDIA, then above click Connect. Now go back to Bluetooth settings and you will see under bluetooth devices "CONNECTED TO PHONE AUDIO". If everything went ok, you should be able to use the phone now with the plugin.
    Last edited by MGD; 02-17-2011 at 12:35 PM.

  8. #1108
    Newbie
    Join Date
    Jul 2010
    Location
    Bodø¸, Norway, Norway
    Posts
    33
    Great. A good tip comes along and now I can't get bluesoleil to connect to my usb dongle anymore. Haven't given up on much so far, but this is seriously getting at me.

    Anyone know if bluesoleil has a debug log I can check somewhere?

  9. #1109
    Maximum Bitrate bratnetwork's Avatar
    Join Date
    Oct 2007
    Location
    Haledon, NJ
    Posts
    503
    I am looking to sell my car in the next few weeks so I took some time to clean up my carpc to get all my personal stuff off and make sure it works perfectly for the buyer.

    I formatted the HDD and did a fresh install of everything and only installed the software that is needed to run the apps that are used. Runs much faster and less lag than before (had a few issues)
    Installed not stripped version of XP Pro w/ SP2, latest version of riderunner, latest BlueSoleil, VC++ redist, .net 3.5, mobilephone 1.17 and so on.

    I have used version 1.15 for awhile now with no issues so I know it did work at one time

    The Mobilephone setup says that VC++ is not installed but it is, then it says that i cannot register the dll. I registered manually according to the readme file and it said it was successful, but it still doesn't work. RR plugin manager says that the plugin is there and enabled. Phone is connected to BlueSoleil with no problem. I tried installing version 1.15 again and that didn't make any difference. I don't know where to go from here.

    Code:
    2/19/2011 1:47:05 PM:Info   : Starting MobilePhone version:1.17.4057.35328
    2/19/2011 1:47:05 PM:Info   : Current directory: C:\Program Files\RideRunner\Plugins\Mobilephone.NET
    2/19/2011 1:47:05 PM:Info   : Current directory: C:\Program Files\RideRunner\Plugins\MobilePhone.Net\
    2/19/2011 1:47:05 PM:Info   : Using ATSMS for phone connection.
    2/19/2011 1:47:05 PM:Fatal  : Exception caught while loading ini parameters: 6
    It says using ATSMS, but in the installation I definitely chose bluetooth.

    The error message below in RR occurs when I click any button on the number pad

    My phone book (MobilePhone_PC) is no accessible from RR
    Attached Images Attached Images          

  10. #1110
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    Hi.

    I think the installer has a problem finding newer versions of the vc++ redist. i will ave to look into how to deal with that. If you have it installed though it shouldn't matter.
    Its more worrying that the installer failed to register the dll. Can you check you have a mobilephone.ini and make sure it is set correctly. I may have to rejig the installer to register the dll last so if it fails everything else is still there. The null ref is because it thinks its using atsm. Make sure the ini is set correctly and that you've set you mac address.

    I wonder wether the dll failed to register because of the .net version your using. Do you have the regasm in the folder shown in your picture 6? It may be its only in a 3.5 folder.

Similar Threads

  1. nGhost 2.0.0 Final is out!
    By tripzero in forum LinuxICE
    Replies: 53
    Last Post: 07-16-2009, 09:16 PM
  2. Bluetooth problems their solutions
    By Clintebb in forum Bluetooth Hardware
    Replies: 9
    Last Post: 12-26-2007, 08:03 AM
  3. Hello World plugin
    By paulpv in forum CF Plugins
    Replies: 5
    Last Post: 06-08-2006, 10:07 PM
  4. How do I use the Base plugin sources ?
    By guino in forum RR FAQ
    Replies: 1
    Last Post: 04-24-2006, 03:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •