Thread: .net Bluetooth Mobilephone Plugin

  1. #1121
    Constant Bitrate Jon-G's Avatar
    Join Date
    Jun 2005
    Location
    Chesterfield, UK
    Posts
    153

    other BT stack versions?

    I see you have now broken this out to use a BlueSoleil wrapper dll, did you do this with a view to supporting other BT stacks?

    I have tried three different versions of BlueSoleil (6.2x, 6.4x, and 8.3x) and none of which will play nicely at all. With 6.4 I could pair my phone, but there was no Audio Gateway. Reinstalled with 8.3 and couldnt get it to even pair. Tried downgrading to 6.2 no pairing, and even upon reinstalling 6.4 the option to pair doesnt work from the either the classic view or the places view. I've tried two different BT controllers with each subsequent version. Doing a full uninstall, directory and registry clean so I can only put this down to the BS software being buggy as sin.

    I've spent more time trying to get this working that I have rebuilding the rest of the car-pc software (Skinning, TV, GPS, DVD VAG-Com etc etc)

    It would be good if you could support the widcomm/broadcom stack too as they seem to be much more reliable. In the meantime I have to revert to freefone

  2. #1122
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    The reason I went with Bluesoliel is that they have done all the hard work of figuiring out the AT codes to send to each phone type. This seams to have been whats killed all the other phone apps with everyone asking a few people how "they got it to work with their phone". This way for a small fee it just works. Now that does mean that some phones arent supported and for that theres the ATSM side of the plugin. This doesn't use BS at all and is the code that Lucifer origionally wrote. If you want to have a go at using that I'm open to help allthough I would be learnng myself.

    And the BSWrapper has been a part of this for a long time. Its just I have made it .net compatable now so its easier for others to use.

  3. #1123
    Constant Bitrate Jon-G's Avatar
    Join Date
    Jun 2005
    Location
    Chesterfield, UK
    Posts
    153
    Iv finally got the BS 6.4 pairing issue resolved, for some reason the 'create new pair' form doesn't show up during a remote desktop session!!

    Anyway I now I have Mobilephone.net connecting to my phone, but Im getting the exception (object reference not set to an instance of an object) when I hit any of the keypad number buttons (on any of the supplied skins). If I hit the green dial button, my mobile dials out the last number dialled, so the dll must be registered correctly in order to get this far no?

    I have read through this thread trying to troubleshoot and this is what Ive tried so far, all to no avail:

    Uninstall and reinstall plugin
    Check bswrapper.dll and mobilephone.dll are in the rr\plugins\mobilephone.net folder
    Manually registered the mobilephone.dll file as detailed in solution 2 in this thread
    Disabled the alarm page in the ini file (not that I think this is relevant, but was worth doing while I saw the ini entry)
    Checked all other details in the Mobilephone.ini file which is detailed below.

    If anyone could help out with anything I might have overlooked Id really appreciate it:


    [General]
    #Set PhoneLink to Blue if using BlueSoleil otherwise leave blank
    PhoneLink=Blue
    #Do you want to connect to the phone automatically. If connection is lost it will reconnect.
    AutoConnect=True
    #Do you want to auto answer any incomming calls? Value is number of seconds to wait before answering.
    #Value of 0 switches off feature.
    AutoAnswer=0
    #Debug output: can be set to 6 different values.
    #0 = off, 1=Fatal, 2=Error, 3=Warning, 4=Info, 5=Debug
    DebugLevel=4
    #To restart the log file everytime set to tru. This keeps the log as small as possible.
    #Set to false if you want debug stored over several runs
    Debugrefresh=true
    #Sets the device to use for phone mic
    WaveIn=
    #Sets the device to use for phone speaker
    WaveOut=

    [BLUETOOTH]
    #Not required for ATSM
    #Blue tooth address for allowed phone. Found from BlueSoleil by hovering mouse over correct phone.
    #Multiple addresses can be added seperated by a ; Phones connected in order of list. Only one is connected to.
    Address=00:19:63:97:93:99
    #XX:XX:XX:XX:XX:XX

    #Path to the install directory of BlueSoliel. Only used to find the network operator name. Specifically its looking for the IVTProvider.ini file.
    BSPath=C:\Program Files\IVT Corporation\BlueSoleil

    [CONNECTION]
    #Not required for Bluetooth
    Port=COM7
    BaudRate=9600
    DataBit=8
    StopBit=1
    FlowControl=None

    [PHONESTATUS]
    # How often is battery and signal updated in milli seconds.
    #Also checks for connection or not and whether ringing to auto answer.
    Update=10000
    BatteryWarningLevel=10
    BatteryImageCount=5
    BatteryImageExt=jpg
    SignalImageCount=5
    SignalImageExt=jpg
    #Path to image files for battery and signal strengh
    ImagePath=C:\CARPC\RideRunner\Skins\Simplistque VW

    [PHONEBOOK]
    # When a phonecall is terminated the RC,MC and DC txt files are updated, this specifies the delay in milliseconds between the hangup and the sync call
    SyncDelay=1000
    # Path to where the phonebook files should be stored. Leaving blank will save them to RoadRunner folder.
    PhonebookPath=C:\CarPC\RideRunner\plugins\Mobileph one.NET
    InternationalPrefix=0044
    NationalPrefix=0
    ShortCode=+44
    # Path to where to find photos to display for given caller id.
    PhotoPath=C:\CARPC\RideRunner\Skins\PhoneCallerIdP ics
    PhotoExt=jpg

    [ADVANCED]
    #Mess here if you know what your doing.
    MobileCall=on

    [ALARM]
    AlarmEnabled=False
    AlarmCode=1234
    Last edited by Jon-G; 02-23-2011 at 01:13 PM.

  4. #1124
    Newbie
    Join Date
    Jul 2004
    Location
    Brazil
    Posts
    55
    @Jon-G, that's exactly what I was experiencing. It was a bug on version 1.17. Download the latest version (1.17b, posted by lambosprit yesterday) and reinstall the plugin.

  5. #1125
    Constant Bitrate Jon-G's Avatar
    Join Date
    Jun 2005
    Location
    Chesterfield, UK
    Posts
    153
    Cheers Crisr, got past that!

  6. #1126
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    Quote Originally Posted by crisr View Post
    @Jon-G, that's exactly what I was experiencing. It was a bug on version 1.17. Download the latest version (1.17b, posted by lambosprit yesterday) and reinstall the plugin.
    You beat me too it

    Does it work now Jon-g?

  7. #1127
    Constant Bitrate Jon-G's Avatar
    Join Date
    Jun 2005
    Location
    Chesterfield, UK
    Posts
    153
    Ok after a bit of further testing (Im using Symplistque skin, 6.49 BS Stack, SE K800i) Iv found the following bug where if an call comes in and cuts off before it is either answered or rejected, the mobilecall skin isnt hidden again until the reject button is pressed. Is this something that can be changed in the configuration my end, or does it need to have an event fired from the dll to say the call has ended?

    Is there a bug tracking list for these sort of things anywhere?

  8. #1128
    Constant Bitrate Jon-G's Avatar
    Join Date
    Jun 2005
    Location
    Chesterfield, UK
    Posts
    153
    Quote Originally Posted by lambosprit View Post
    new test version. Only unmutes radio if it was unmuted before the call. If it was muted then it should stay muted.

    Also found a bug in the multi phone code so now it does allow more than one phone mac code to be entered. It still only allows one phone connection only
    Hi Lambospirit,

    been doing some more testing this morning and Im having a problem with the radio with the latest release, the scenario is as follows:

    Start RR and listen to radio, change to music player
    Dial into mobilephone from landline, radio is played to landline phone but not through speakers

    Im using a Silabs USB radio card and winamp 2.9 as my music player

    ---------- Post added at 01:25 PM ---------- Previous post was at 01:07 PM ----------

    Just tried it again without starting the radio when first running rr and still get radio played down the phone :S

  9. #1129
    Newbie
    Join Date
    Dec 2010
    Location
    Hong Kong
    Posts
    2

    Smile Please post the latest Mobilephone Plugin in this thread.

    Hello Lambosprit ,

    I have a tried many times to download your latest plugin through Auto App Mart but all were unsuccessful. It seems that the Auto Mart has some problem. I have reflect the problem in customer service but no one answer me. Could you do me a favour to place the plugin in your post as you did in the past. Thanks so much.

    WWWONG

  10. #1130
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    Quote Originally Posted by Jon-G View Post
    Ok after a bit of further testing (Im using Symplistque skin, 6.49 BS Stack, SE K800i) Iv found the following bug where if an call comes in and cuts off before it is either answered or rejected, the mobilecall skin isnt hidden again until the reject button is pressed. Is this something that can be changed in the configuration my end, or does it need to have an event fired from the dll to say the call has ended?

    Is there a bug tracking list for these sort of things anywhere?
    Not a bug, just no way to do it. I've tried for ages to create an event for when the call is ended by the other party and haven't found an answer I'm afraid.

    As for your silabs problem its because the BS takes the first audio device in the windows list. Use the wavein and waveout settings in the ini to set it to the sound card you want. Its name should be the same as you see in the sound control panel.

    ---------- Post added at 10:48 PM ---------- Previous post was at 10:44 PM ----------

    Quote Originally Posted by chancs2007 View Post
    Hello Lambosprit ,

    I have a tried many times to download your latest plugin through Auto App Mart but all were unsuccessful. It seems that the Auto Mart has some problem. I have reflect the problem in customer service but no one answer me. Could you do me a favour to place the plugin in your post as you did in the past. Thanks so much.

    WWWONG
    I dont want to do this if I can help it. I want to keep everthing in one place. I see you've downloaded it a few times. What is the problem? Does the download not start, is it corrupt etc.

Similar Threads

  1. nGhost 2.0.0 Final is out!
    By tripzero in forum LinuxICE
    Replies: 53
    Last Post: 07-16-2009, 09:16 PM
  2. Bluetooth problems their solutions
    By Clintebb in forum Bluetooth Hardware
    Replies: 9
    Last Post: 12-26-2007, 08:03 AM
  3. Hello World plugin
    By paulpv in forum CF Plugins
    Replies: 5
    Last Post: 06-08-2006, 10:07 PM
  4. How do I use the Base plugin sources ?
    By guino in forum RR FAQ
    Replies: 1
    Last Post: 04-24-2006, 03:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •