Thread: .net Bluetooth Mobilephone Plugin

  1. #1251
    Variable Bitrate
    Join Date
    Jan 2006
    Posts
    284
    Quote Originally Posted by lamaii View Post
    I've just had the same problem as you, I had built up a clean clean Win7 SP1 with all patches, .net's & VC++ 2005, 2008 & 2010 with this install I got the exact same message you get (my install is on c:\) I've just rebuilt the my rig but this time without any updates or VC++ installed and the installer worked fine. I think it;s got something to do with having one of the VC++ installed but not sure which one.

    Thanks for the reply, I've been waiting for someone to chime in about this issue for a week now. I'm not going to start from scratch in order to try and get this plugin in working. I figured Lambosprit would try and help me out with this but that didn't happen so I'm moving on

  2. #1252
    Newbie
    Join Date
    Jan 2012
    Location
    UK
    Posts
    39
    I would just try and remove the VC++ redistribute there are only 3 to remove and can easy be reinstalled, it's a very good plugin.

    One question which I have asked in the DFX skin is the battery & signal indicators, anyone here know how to get them working?

  3. #1253
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    786
    Quote Originally Posted by bumblebeemouth View Post
    I actually copied that but still no luck. If I set the default to the pureaudio card it won't switch to the onboard soundcard either. should the log file be reporting an error if it fails to switch?
    It was more the process of finding the name to use rather than just copying. The name is critical, spaces and all so the only way to find out what it should be is see how windows defines it.

  4. #1254
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    786
    Quote Originally Posted by hpric View Post
    Tried but keep getting LoadLibrary("D:\Program" failed - The specified module could not be found
    This says you don't have quotes round the file name path. The first space it sees and it assumes thats the file name.

    to register it manually use the following
    "$REGASMLOC\RegAsm" "$INSTDIR\mobilephone.dll" /tlb:mobilephone.tlb /codebase
    but replace $regasmloc with the location of regasm (it should be in the C:\Windows\Microsoft.NET\Framework\v2.0.50727 folder)
    and $install with the location of the mobilephone.dll.

    so for example
    "C:\Windows\Microsoft.NET\Framework\v2.0.50727\reg asm" "c:\program files\riderunner\plugin\mobilephone.net\mobilephon e.dll" /tlb:mobilephone.tlb /codebase

  5. #1255
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    786
    Quote Originally Posted by lamaii View Post
    I would just try and remove the VC++ redistribute there are only 3 to remove and can easy be reinstalled, it's a very good plugin.

    One question which I have asked in the DFX skin is the battery & signal indicators, anyone here know how to get them working?
    Battery and signal levels seem to be very poorly supported by BS. I've only found one phone that it works on and that was my brothers blackberry. I don't know how they get displayed in dfk though.

  6. #1256
    Raw Wave pierrotm777's Avatar
    Join Date
    May 2008
    Location
    Bordeaux, France
    Posts
    2,868
    Quote Originally Posted by lambosprit View Post
    but replace $regasmloc with the location of regasm (it should be in the C:\Windows\Microsoft.NET\Framework\v2.0.50727 folder)
    and $install with the location of the mobilephone.dll.

    so for example
    "C:\Windows\Microsoft.NET\Framework\v2.0.50727\reg asm" "c:\program files\riderunner\plugin\mobilephone.net\mobilephon e.dll" /tlb:mobilephone.tlb /codebase
    You can also found the regasm file into the RideRunner install:
    C:\Program Files\RideRunner\RRExtension Plugin Examples\Regasm for .NET 2.0 examples


  7. #1257
    FLAC -zip-'s Avatar
    Join Date
    Sep 2004
    Location
    Ontario/Canada
    Posts
    1,293
    If I leave the settings blank for sound card will this disable it attempting to use mic and speakers?

    I have integrated bluetooth phone as an option when the car was purchased however there is no graphical way to see caller ID nor dial. Your plug in seems ideal for this.
    Last edited by -zip-; 02-09-2012 at 12:12 AM.
    2008 350z GT Installed since April 22nd 2011 - Worklog
    2000 Protege Installed Since April 2, 2005 - Intel D201GLY|Fusion Brain|ODBPros ODBII|Engenius|GPS Rikaline|Powermate|Motorized Lilli
    Sound Stage
    Eclipse|MTX|Infinity

  8. #1258
    Variable Bitrate
    Join Date
    Jan 2006
    Posts
    284
    Quote Originally Posted by lambosprit View Post
    This says you don't have quotes round the file name path. The first space it sees and it assumes thats the file name.

    to register it manually use the following
    "$REGASMLOC\RegAsm" "$INSTDIR\mobilephone.dll" /tlb:mobilephone.tlb /codebase
    but replace $regasmloc with the location of regasm (it should be in the C:\Windows\Microsoft.NET\Framework\v2.0.50727 folder)
    and $install with the location of the mobilephone.dll.

    so for example
    "C:\Windows\Microsoft.NET\Framework\v2.0.50727\reg asm" "c:\program files\riderunner\plugin\mobilephone.net\mobilephon e.dll" /tlb:mobilephone.tlb /codebase
    Thanks for responding but I'm still having issues. I have now switched over to Windows 7 in the hopes I could get this going but still nothing. I followed your instructions to manually register the dll but now I'm getting an error message stating "The file does not have a program associated with it for performing this action"

    What can I do ?

  9. #1259
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    786
    Quote Originally Posted by -zip- View Post
    If I leave the settings blank for sound card will this disable it attempting to use mic and speakers?
    No afraid not. It just sets to the default.

  10. #1260
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    786
    Quote Originally Posted by hpric View Post
    Thanks for responding but I'm still having issues. I have now switched over to Windows 7 in the hopes I could get this going but still nothing. I followed your instructions to manually register the dll but now I'm getting an error message stating "The file does not have a program associated with it for performing this action"

    What can I do ?
    No idea I'm afraid

Similar Threads

  1. nGhost 2.0.0 Final is out!
    By tripzero in forum LinuxICE
    Replies: 53
    Last Post: 07-16-2009, 10:16 PM
  2. Bluetooth problems their solutions
    By Clintebb in forum Bluetooth Hardware
    Replies: 9
    Last Post: 12-26-2007, 09:03 AM
  3. Hello World plugin
    By paulpv in forum CF Plugins
    Replies: 5
    Last Post: 06-08-2006, 11:07 PM
  4. How do I use the Base plugin sources ?
    By guino in forum RR FAQ
    Replies: 1
    Last Post: 04-24-2006, 04:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •