Page 14 of 134 FirstFirst ... 45678910111213141516171819202122232464114 ... LastLast
Results 131 to 140 of 1338

Thread: .net Bluetooth Mobilephone Plugin

  1. #131
    Constant Bitrate almera's Avatar
    Join Date
    Aug 2004
    Posts
    195
    Thanks for this nice plugin. I just tested the plugin with iPhone. Connects fine, incoming call indicator works fine and plugin sends pause. Other functions like dial a number, answer or hangup a call does not work with iPhone. I have Bluesoleil Dialer plugin installed and works fine with dial/answer/hangup functions. I suppose your plugin has different method (AT commands maybe?) about that functions. (iPhone does not support AT commands AFAIK).
    As mentioned before, I have also noticed that if you set AutoAnswer=0 in the configuration the mobilecall.skin does not load and plugin does not pause RR.
    One suggestion, could you make the in call events configurable, like parameters in the ini file i.e. ringing="PAUSE" or hangup="PLAY"
    Thanks again..
    ----------------------------------------------------------------------

  2. #132
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,151
    Blog Entries
    51
    Quote Originally Posted by Nomader View Post
    yeah that is what i meant..
    one thing i noticed (when i turned auto answer off in the ini) is that the mobilecall.skin does not load at all..i don't know if that has something to do or it was a coincidence.
    good work mate..
    maybe this is my problem. Im gonna do a bunch of testing today
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  3. #133
    Variable Bitrate
    Join Date
    Feb 2006
    Posts
    393
    Quote Originally Posted by almera View Post
    Thanks for this nice plugin. I just tested the plugin with iPhone. Connects fine, incoming call indicator works fine and plugin sends pause. Other functions like dial a number, answer or hangup a call does not work with iPhone. I have Bluesoleil Dialer plugin installed and works fine with dial/answer/hangup functions. I suppose your plugin has different method (AT commands maybe?) about that functions. (iPhone does not support AT commands AFAIK).
    As mentioned before, I have also noticed that if you set AutoAnswer=0 in the configuration the mobilecall.skin does not load and plugin does not pause RR.
    One suggestion, could you make the in call events configurable, like parameters in the ini file i.e. ringing="PAUSE" or hangup="PLAY"
    Thanks again..
    The dial out, answer, hangup works fine on my iphone. I also have autoanswer to 0. I have made my own skin and commands to pause and resume playback which is working fine.

  4. #134
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    Quote Originally Posted by EricE View Post
    Thanks for the update on the file name but that file is not in those packages either.

    One other thing:Where is the "x,mobilephone" supposed to go and what does it do? Does it tell RR there is a plugin out there or what? I put it in my skin.ini file for my skin but I am not sure where it should go. Your instructions just say to put it in your main skin file which is rather ambiguous.
    Again, thanks for making this and thanks for any help you can give.

    update: ok, I put "x,mobilephone" in my menu.skin and it works now.
    you only need the x,mobilephone in your menu skin for roadrunner. Riderunner doesn't need it. Which notes say main I cant find it. They all mention menu.

  5. #135
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    Quote Originally Posted by Nomader View Post
    yeah that is what i meant..
    one thing i noticed (when i turned auto answer off in the ini) is that the mobilecall.skin does not load at all..i don't know if that has something to do or it was a coincidence.
    good work mate..
    the mobilecall.skin should be called whenever the phone rings, not just with auto answer. I'll test here to see if I can find the problem.

  6. #136
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    Quote Originally Posted by EricE View Post
    The dial out, answer, hangup works fine on my iphone. I also have autoanswer to 0. I have made my own skin and commands to pause and resume playback which is working fine.
    The plugin should pause whenever an incomming call occures or the mobilephone_dial or mobilephone_pickup are used. Has anybody found this happens?

  7. #137

  8. #138
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,151
    Blog Entries
    51
    Just tested with AutoAnswer=5... the box pops up... but the buttons dont accept/end the call. also it appeared that the MENU; command happened 2 or 3 times during the call as the box faded and came right back. I'm gonna test in the car with AutoAnswer = 0 and post results in about an hour.

    Note this is with the previous version not the version just posted.


    Ok tested in the car with 3 calls. First call had Autoanswer=10. moblecall.skin appeared the music paused AND the accept/end buttons did there job. Second call Autoanswer=0 was set and the popup didnt occur . Last call was a dialed call and the music paused.. but came back on during the call.

    I'd say the conclusion is that Autoanswer = 0 means no popup at this point. There may also be a problem with pausing during a dialed call.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  9. #139
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    thanks for the testing. Found the bug and fixed it. It was stopping the auto pause and play stuff as well if auto answer was set to 0 so that should all be working fine now. I've updated the first post but kept the same version 1009 as only two people had downloaded

  10. #140
    Newbie
    Join Date
    Feb 2008
    Posts
    29
    good stuff a new version
    it makes me all warm and fuzzy in my pants LOL

    what is the best thing to do
    1 install over the top of old one

    2 delete old files and install new one's

    edit
    just tryed it out all is good here
    i can make a call
    take a call auto answer works
    it wants to pop up the mobilecall.skin but i dont have in the folder. so rr tells me it cant find it

    but i still cant get the phone book to display
    the files location is C:\Program Files\RideRunner\Plugins\MobilePhone

    and in the mobilephone settings i have
    # Path to where the phonebook files should be stored. Leaving blank will save them to RoadRunner folder.
    PhonebookPath=C:\Program Files\RideRunner\Plugins\MobilePhone\

    all the skins are standed as the came with the plugin

    where the am i going wrong with this part
    can someone please give me a idiots guide to setting this up

Similar Threads

  1. nGhost 2.0.0 Final is out!
    By tripzero in forum LinuxICE
    Replies: 53
    Last Post: 07-16-2009, 09:16 PM
  2. Bluetooth problems their solutions
    By Clintebb in forum Bluetooth Hardware
    Replies: 9
    Last Post: 12-26-2007, 08:03 AM
  3. Hello World plugin
    By paulpv in forum CF Plugins
    Replies: 5
    Last Post: 06-08-2006, 10:07 PM
  4. How do I use the Base plugin sources ?
    By guino in forum RR FAQ
    Replies: 1
    Last Post: 04-24-2006, 03:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •