Page 29 of 134 FirstFirst ... 19202122232425262728293031323334353637383979129 ... LastLast
Results 281 to 290 of 1338

Thread: .net Bluetooth Mobilephone Plugin

  1. #281
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    786
    Quote Originally Posted by junhe View Post
    this is the screen after i registered the dll file..
    Ok. Thats showing that the plugin is registered but not connected to the phone.

    So have you
    1)Paired the phone in Bluesoleil
    2) Entered the macaddress of the phone in your mobilephone.ini? with correct : seperator
    3)Checked that the phone is connected to Bluesoliel?

  2. #282
    Newbie
    Join Date
    May 2009
    Posts
    30
    paired,mac address correct, connected(the bluesoliel icon is become green)

  3. #283
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    786
    Quote Originally Posted by junhe View Post
    paired,mac address correct, connected(the bluesoliel icon is become green)
    set your debug level to 5 then and post your log files please

  4. #284
    Newbie
    Join Date
    May 2009
    Posts
    30
    this is my log

    5/29/2009 8:41:43 PM:Info : Starting MobilePhone version: 0.1.0.10
    5/29/2009 8:41:43 PM:Info : Current directory: c:\program files\riderunner\plugins\mobilephone
    5/29/2009 8:41:43 PMebug : Path being set to C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32 \Wbem;C:\Program Files\ATI Technologies\ATI Control Panel;C:\Program Files\IVT Corporation\BlueSoleil\Mobile;C:\WINDOWS\system32\ Wbem;C:\Program Files\StormII\Codec;C:\Program Files\StormII;c:\program files\riderunner\plugins\mobilephone
    5/29/2009 8:41:43 PM:Info : Device address: 00:237:06A:61;
    5/29/2009 8:41:43 PM:Info : Pair code: 1234
    5/29/2009 8:41:43 PM:Info : International prefix = 0044
    5/29/2009 8:41:43 PM:Info : International shortcut prefix = +44
    5/29/2009 8:41:43 PM:Info : National prefix = 0
    5/29/2009 8:41:43 PM:Info : Using BlueSoleil for phone connection
    5/29/2009 8:41:43 PM:Info : MobileCall.skin: on
    5/29/2009 8:41:43 PM:Info : Trying to connect to phone.
    5/29/2009 8:41:46 PMebug : Updating phoneHandle to : 29591712
    5/29/2009 8:41:46 PMebug : Device handle found is: 29591712
    5/29/2009 8:41:46 PM:Info : You have succeeded in getting a remote device's handle.
    5/29/2009 8:41:54 PM:Info : Phonebook functionality not part of current SDK
    5/29/2009 8:41:54 PM:Info : Phonebook functionality not part of current SDK
    5/29/2009 8:41:54 PM:Info : Phonebook functionality not part of current SDK
    5/29/2009 8:41:54 PM:Info : Phonebook functionality not part of current SDK
    5/29/2009 8:41:54 PM:Info : Phonebook functionality not part of current SDK

  5. #285
    Constant Bitrate almera's Avatar
    Join Date
    Aug 2004
    Posts
    195
    Quote Originally Posted by lambosprit View Post
    @ Almera
    I have no idea at the moment why it only works in lowercase for you. I'll have a think. Is this the same for every skin / plugin you use or just mobilephone.NET?
    I'll check that later..

    Quote Originally Posted by lambosprit View Post
    The BSWrapper should only write logs out to its currently running directory which is actually the RideRunner directory because thats where its started from. You can now switch off the debug by editing the BSWrapper.ini file (new in this release ). Can you delete all occurances of the log and see if they're all created again please.
    Also, I'll check that later and let you know.

    Quote Originally Posted by lambosprit View Post
    Your right about the debug. It seems your problem manages to avoid all the debug output. Whats happening is your actually trying to redial the last dialled number because the custom list didn't populate the mobilephone_dialbox (if its blank the mobilephone_pickup redials last number) BUT because you haven't dialled a number before you got the message.

    So your problem is getting the list box to populate. Hmmmmmh...Do you have the mobilephone_PC.txt file in the place you specified in the ini? Have you manually edited it in anyway (I found there needed to be two spaces at the begining of the file to work.)...thats all assuming your trying to load that file.
    No problem in getting the custom list box to populate. I can see the list and browse the list succesfully. Problem is the custom list doesn't populate the mobilephone_dialbox. Otherwise if I dial a number using the dial pad, plugin works fine.
    ----------------------------------------------------------------------

  6. #286
    Variable Bitrate
    Join Date
    Jul 2006
    Location
    Brisbane, Australia
    Posts
    346
    Hi Guys, finally took the plunge with this. Tried my work Nokia 3120c but it was not on the supported phone list so BS had trouble with this so used a Sony Erricssen W610i. I am using the BMV2 skin.

    It connects, I can dial and receive calls but I get an error screen "MobilePhone.Skin not found."

    I could not see any ini file settings to tell it where to look for the skin. Does it pickup the skin folder from RR?

    Once I get that sorted, I need to work out why contacts etc don't show up. BS can see them.
    RodW
    2007 Toyota Hilux with a CarPC..

    Worklog: http://www.mp3car.com/vbulletin/work...ota-hilux.html
    OziExplorer GPS Embedded in RR: http://www.mp3car.com/vbulletin/sb-s...iexplorer.html

  7. #287
    One Sharp Cheddar ThunderStick's Avatar
    Join Date
    Aug 2006
    Location
    West Allis, WI
    Posts
    1,657
    Quote Originally Posted by lambosprit View Post
    Any idea why it wasn't registering. I'd like to know so I can fix the installer. It should have registered it fine.

    What version(S) of .net do you have installed? Did you see any warning message when you installed it?
    This is what I get when I register manually
    Quote Originally Posted by DOS Prompt View Post

    C:\Program Files\RideRunner\Plugins\Mobilephone>C:\WINDOWS\Mi crosoft.NET\Framework\v2.0.50727\regasm.exe "C:\Program Files\RideRunner\Plugins\Mobilephone\MobilePhone.d ll" /tlb:MobilePhone.tlb /codebase
    Microsoft (R) .NET Framework Assembly Registration Utility 2.0.50727.3053
    Copyright (C) Microsoft Corporation 1998-2004. All rights reserved.

    RegAsm : warning RA0000 : Registering an unsigned assembly with /codebase can cause your assembly to interfere with other applications that may be installed on the same computer. The /codebase switch is intended to be used only with signed assemblies. Please give your assembly a strong name and re-register it.
    Types registered successfully
    Assembly exported to 'C:\Program Files\RideRunner\Plugins\Mobilephone\MobilePhone.t lb', and the type library was registered successfully

    C:\Program Files\RideRunner\Plugins\Mobilephone>pause
    Hope this helps.
    New Age Garmin - Skin for RR
    New Age Slider - RR SKin In Progress
    "It's called CODE because I don't want you to know"

  8. #288
    One Sharp Cheddar ThunderStick's Avatar
    Join Date
    Aug 2006
    Location
    West Allis, WI
    Posts
    1,657
    Above post edited for corrections
    New Age Garmin - Skin for RR
    New Age Slider - RR SKin In Progress
    "It's called CODE because I don't want you to know"

  9. #289
    Newbie
    Join Date
    Feb 2008
    Posts
    29
    Quote Originally Posted by lambosprit View Post
    the add and edit buttons should be simple. Select a phonebook from the 4 available. Type a number into the dial box. Clicking add issues a CLADD command followed by an ONCLICK followed by a CLSAVE which saves it to your previously selected phonebook.

    edit just gets the current description of the selected list item using CLDESC and then updates that entry with the number in the dialbox and the description found previously

    does that help?
    yep that helps out heaps but how do i add a new description to a list


    edit sorry i found out how to do it
    "OSKTOCMD;NEWITEM;CLADD;$NEWITEM$"

    seem to do what i wanted

  10. #290
    FLAC Nomader's Avatar
    Join Date
    Apr 2006
    Location
    Greece
    Posts
    1,294
    it works OK for me.
    if you guys are having probems (the pluging no registering) try to completely uninstall the plugin -there is an undelete exe- and reinstall

    lambo is there any news on having the Bluetooth connection not connecting the audio so we can use a handsfree BT?

Similar Threads

  1. nGhost 2.0.0 Final is out!
    By tripzero in forum LinuxICE
    Replies: 53
    Last Post: 07-16-2009, 10:16 PM
  2. Bluetooth problems their solutions
    By Clintebb in forum Bluetooth Hardware
    Replies: 9
    Last Post: 12-26-2007, 09:03 AM
  3. Hello World plugin
    By paulpv in forum CF Plugins
    Replies: 5
    Last Post: 06-08-2006, 11:07 PM
  4. How do I use the Base plugin sources ?
    By guino in forum RR FAQ
    Replies: 1
    Last Post: 04-24-2006, 04:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •