Page 44 of 134 FirstFirst ... 34353637383940414243444546474849505152535494 ... LastLast
Results 431 to 440 of 1338

Thread: .net Bluetooth Mobilephone Plugin

  1. #431
    Newbie
    Join Date
    Feb 2008
    Posts
    12
    I have started working on getting this plugin functioning and am having a little difficulty. The plugin is loading correctly as per the plugin manager and the software skin loads properly, I have entered the phone address in the configuration and the phone confirms the plugin has requested access. When the skin loads there is one green indicator next to the con button. My phone is paired using the latest bluetooth 6 and works correctly with bluesoleil dialer.

    The problem I am having is when in riderunner I can type in a phone number to call however when pushing the SMS Send button the following error message appears.

    System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
    at MobilePhone.APIs.ReturnCallBacks(UInt16 levent)
    at MobilePhone.MobilePhone.get_Ringing()
    at MobilePhone.RRExtension.ProcessCommand(String& CMD, Object& frm)

    I am unable to locate a debug file although I have set the debug option to 5.

    Any ideas what I may have done wrong?

  2. #432
    Low Bitrate Spikemonkey's Avatar
    Join Date
    Aug 2009
    Location
    Virginia
    Posts
    111
    Quote Originally Posted by TSX2005PC View Post
    I have started working on getting this plugin functioning and am having a little difficulty. The plugin is loading correctly as per the plugin manager and the software skin loads properly, I have entered the phone address in the configuration and the phone confirms the plugin has requested access. When the skin loads there is one green indicator next to the con button. My phone is paired using the latest bluetooth 6 and works correctly with bluesoleil dialer.

    The problem I am having is when in riderunner I can type in a phone number to call however when pushing the SMS Send button the following error message appears.

    System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
    at MobilePhone.APIs.ReturnCallBacks(UInt16 levent)
    at MobilePhone.MobilePhone.get_Ringing()
    at MobilePhone.RRExtension.ProcessCommand(String& CMD, Object& frm)

    I am unable to locate a debug file although I have set the debug option to 5.

    Any ideas what I may have done wrong?
    I get this along with something else. I am using the elite lite skin, and a Razr V3m. When music is playing and I get a call, it says it can't find the mobilecall.skin. Where do I go to change it to look for mobilephone.skin? Also, do I NEED the c++ that you gave a link to installed, or is it optional? Thanks for the program.

  3. #433
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    Check the riderunner debug file. You may see an invalidcommand. This has been an issue in the past and unfortunaltly I didn't find the cause.

    There are two debug logs. The mobilephonedebug.log is written to the logs directory withing riderunners folder.
    The BSWrapper.log can get written out all over the place. Its a problem I'm trying to fix but without hardcoding the path it's difficult.

    When you find them post them if your still having problems

  4. #434
    Newbie
    Join Date
    Feb 2008
    Posts
    12
    I am still having issues however if a call comes in it is being routed through the pc, I just can't seem to dial out. Here is a fresh debug log from this morning. I suspect the problem is from the exception raised in network property errors but i have no idea what to look for.

    BS Wrapper

    08/26/09 08:17:38 Info: Version 1.0.0
    08/26/09 08:17:38 Info: Debug Level= 5
    08/26/09 08:17:38 Info: Application initialization
    08/26/09 08:17:38 Debug: Checking if currently connected to BlueSoleil Server.
    08/26/09 08:17:38 Info: Not connected so initialising.
    08/26/09 08:17:38 Debug: Connected to BlueSoleil Server.
    08/26/09 08:17:38 Debug: Looking for bluetooth adapter.
    08/26/09 08:17:38 Debug: Bluetooth adapter found.
    08/26/09 08:17:38 Debug: Bluetooth hardware is ready.
    08/26/09 08:17:38 Debug: You have succeeded in getting a remote device's handle.
    08/26/09 08:17:49 Debug: Requesting Network operator name
    08/26/09 08:17:49 Debug: Requesting Subscriber Info
    08/26/09 08:17:49 Debug: Requesting Network operator name
    08/26/09 08:17:49 Debug: Requesting Subscriber Info
    08/26/09 08:17:49 Debug: Network operator.
    08/26/09 08:17:49 Debug: Subscriber.
    08/26/09 08:17:49 Debug: Network operator.
    08/26/09 08:17:49 Debug: Subscriber.
    08/26/09 08:17:50 Debug: Requesting Network operator name
    08/26/09 08:17:50 Debug: Requesting Subscriber Info
    08/26/09 08:17:50 Debug: Network operator.
    08/26/09 08:17:50 Debug: Subscriber.
    08/26/09 08:17:52 Debug: Requesting Network operator name
    08/26/09 08:17:52 Debug: Requesting Subscriber Info
    08/26/09 08:17:52 Debug: Network operator.
    08/26/09 08:17:52 Debug: Subscriber.
    08/26/09 08:17:53 Debug: Requesting Network operator name
    08/26/09 08:17:53 Debug: Requesting Subscriber Info
    08/26/09 08:17:53 Debug: Network operator.
    08/26/09 08:17:53 Debug: Subscriber.
    08/26/09 08:17:54 Debug: Requesting Network operator name
    08/26/09 08:17:54 Debug: Requesting Subscriber Info
    08/26/09 08:17:54 Debug: Network operator.
    08/26/09 08:17:54 Debug: Subscriber.
    08/26/09 08:17:55 Debug: Requesting Network operator name
    08/26/09 08:17:55 Debug: Requesting Subscriber Info
    08/26/09 08:17:55 Debug: Network operator.
    08/26/09 08:17:55 Debug: Subscriber.
    08/26/09 08:17:56 Debug: Requesting Network operator name
    08/26/09 08:17:56 Debug: Requesting Subscriber Info
    08/26/09 08:17:56 Debug: Network operator.
    08/26/09 08:17:56 Debug: Subscriber.
    08/26/09 08:17:57 Debug: Requesting Network operator name
    08/26/09 08:17:57 Debug: Requesting Subscriber Info
    08/26/09 08:17:57 Debug: Network operator.
    08/26/09 08:17:57 Debug: Subscriber.
    08/26/09 08:17:58 Debug: Requesting Network operator name
    08/26/09 08:17:58 Debug: Requesting Subscriber Info
    08/26/09 08:17:58 Debug: Network operator.
    08/26/09 08:17:58 Debug: Subscriber.
    08/26/09 08:17:59 Debug: Requesting Network operator name
    08/26/09 08:17:59 Debug: Requesting Subscriber Info
    08/26/09 08:17:59 Debug: Network operator.
    08/26/09 08:17:59 Debug: Subscriber.
    08/26/09 08:18:00 Debug: Requesting Network operator name
    08/26/09 08:18:00 Debug: Requesting Subscriber Info
    08/26/09 08:18:01 Debug: Network operator.
    08/26/09 08:18:01 Debug: Subscriber.
    08/26/09 08:18:02 Debug: Requesting Network operator name
    08/26/09 08:18:02 Debug: Requesting Subscriber Info
    08/26/09 08:18:02 Debug: Network operator.
    08/26/09 08:18:02 Debug: Subscriber.
    08/26/09 08:18:09 Debug: Requesting Network operator name
    08/26/09 08:18:10 Debug: Requesting Subscriber Info
    08/26/09 08:18:10 Debug: Network operator.
    08/26/09 08:18:10 Debug: Subscriber.

    Mobilephone.log

    8/26/2009 8:17:37 AM:Info : Starting MobilePhone version: 1.12.3434.20297
    8/26/2009 8:17:37 AM:Info : Current directory: C:\Program Files\RideRunner\plugins\Mobilephone.NET
    8/26/2009 8:17:37 AMebug : Path being set to C:\Program Files\PC Connectivity Solution\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOW S\System32\Wbem;C:\Program Files\Toshiba\Bluetooth Toshiba Stack\sys\;C:\Program Files\IVT Corporation\BlueSoleil\Mobile;C:\WINDOWS\system32\ Wbem;C:\Program Files\RideRunner\plugins\Mobilephone.NET
    8/26/2009 8:17:37 AM:Info : Device address: 00:22:B4:48:3C:48
    8/26/2009 8:17:37 AM:Info : Pair code:
    8/26/2009 8:17:37 AM:Info : International prefix = 001
    8/26/2009 8:17:37 AM:Info : International shortcut prefix = +01
    8/26/2009 8:17:37 AM:Info : National prefix = 1
    8/26/2009 8:17:37 AM:Info : Using BlueSoleil for phone connection
    8/26/2009 8:17:37 AM:Info : MobileCall.skin: on
    8/26/2009 8:17:37 AM:Info : Trying to connect to phone.
    8/26/2009 8:17:38 AMebug : Updating phoneHandle to : 29076952
    8/26/2009 8:17:38 AMebug : Device handle found is: 29076952
    8/26/2009 8:17:38 AM:Info : You have succeeded in getting a remote device's handle.
    8/26/2009 8:17:49 AMebug : Exception raised in Network property
    8/26/2009 8:17:49 AMebug : Exception raised in Network property
    8/26/2009 8:17:50 AMebug : Exception raised in Network property
    8/26/2009 8:17:52 AMebug : Exception raised in Network property
    8/26/2009 8:17:53 AMebug : Exception raised in Network property
    8/26/2009 8:17:54 AMebug : Exception raised in Network property
    8/26/2009 8:17:55 AMebug : Exception raised in Network property
    8/26/2009 8:17:56 AMebug : Exception raised in Network property
    8/26/2009 8:17:57 AMebug : Exception raised in Network property
    8/26/2009 8:17:58 AMebug : Exception raised in Network property
    8/26/2009 8:17:59 AMebug : Exception raised in Network property
    8/26/2009 8:18:00 AMebug : Exception raised in Network property
    8/26/2009 8:18:02 AMebug : Exception raised in Network property
    8/26/2009 8:18:10 AMebug : Exception raised in Network property

  5. #435
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    Quote Originally Posted by TSX2005PC View Post
    I am still having issues however if a call comes in it is being routed through the pc, I just can't seem to dial out. Here is a fresh debug log from this morning. I suspect the problem is from the exception raised in network property errors but i have no idea what to look for.
    have you set the correct path to the ivt provider file in the ini. if you leave it as standard when installing bluesoliel it will be in C:\Program Files\IVT Corporation\BlueSoleil. What your looking for is the IVTProvider.ini file.

    Now for the bit where you can't dial. Have you checked you rr debug log for the invalidcommand?

  6. #436
    Newbie
    Join Date
    Feb 2008
    Posts
    12
    The ivtprovider path was set up correctly. The invalid command when dialing is Command not executed: MOBILEPHONE_DIAL

  7. #437
    Low Bitrate Spikemonkey's Avatar
    Join Date
    Aug 2009
    Location
    Virginia
    Posts
    111
    Hey, sorry it took so long. I have attached the logs and a copy of what my screen looks like when I load the plug in. You'll notice some out of place text and no battery or signal strength meters. Also, I don't think that RR is making a debug log for me. I have it set to debug mode in RRConfig, and I made sure to make it error a few times, but no log was created, at least one that I could find.

    You never did answer my question: I do not have Visual Basic C++ installed. DO I NEED IT?

    Also, any chance of getting a proper mobilecall.skin skin put in the package, or released seperately?

    Thanks again.
    Attached Images Attached Images  
    Attached Files Attached Files

  8. #438
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    Quote Originally Posted by TSX2005PC View Post
    The ivtprovider path was set up correctly. The invalid command when dialing is Command not executed: MOBILEPHONE_DIAL
    Just so I'm sure of what your saying. You see invalid command in the riderunner debug?
    This has happened for another user and we didn't manage to find out what was causing it. Try changing the commands to lowercase in the skin file. (My program does this automatically but it made a difference for the other guy).

    Do you see any other invalid commands in the rr debug?

  9. #439
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    Quote Originally Posted by Spikemonkey View Post
    Hey, sorry it took so long. I have attached the logs and a copy of what my screen looks like when I load the plug in. You'll notice some out of place text and no battery or signal strength meters. Also, I don't think that RR is making a debug log for me. I have it set to debug mode in RRConfig, and I made sure to make it error a few times, but no log was created, at least one that I could find.

    You never did answer my question: I do not have Visual Basic C++ installed. DO I NEED IT?

    Also, any chance of getting a proper mobilecall.skin skin put in the package, or released seperately?

    Thanks again.
    you shouldn't need to create an error to get rr to write out debug. The log file for rr is created in rr's installation directory, Its called debug.txt if you want to do a search.

    You need the vc++ runtime installed for the BSWrapper bit to work. I keep forgetting to make it part of the installer. This is probably the cause of all your problems.

    The mobilecall.skin I use is part of the installer. I use freedom ultimate. I have posted all the skin files I have. If anyone produces any others I am happy to include them in the installer but otherwise this is something you'll have to do yourself I'm afraid.

  10. #440
    Low Bitrate Spikemonkey's Avatar
    Join Date
    Aug 2009
    Location
    Virginia
    Posts
    111
    Quote Originally Posted by lambosprit View Post
    you shouldn't need to create an error to get rr to write out debug. The log file for rr is created in rr's installation directory, Its called debug.txt if you want to do a search.

    You need the vc++ runtime installed for the BSWrapper bit to work. I keep forgetting to make it part of the installer. This is probably the cause of all your problems.

    The mobilecall.skin I use is part of the installer. I use freedom ultimate. I have posted all the skin files I have. If anyone produces any others I am happy to include them in the installer but otherwise this is something you'll have to do yourself I'm afraid.
    I will get right on it as soon as I can. I have to take my car in for some body work due to an incompetent mechanic closing my hood on a tool of some sort. I should have it back by tomorrow afternoon.

    I will get all the stuff you require installed, give it a run through, and get back to you.

    Thanks again.

Similar Threads

  1. nGhost 2.0.0 Final is out!
    By tripzero in forum LinuxICE
    Replies: 53
    Last Post: 07-16-2009, 09:16 PM
  2. Bluetooth problems their solutions
    By Clintebb in forum Bluetooth Hardware
    Replies: 9
    Last Post: 12-26-2007, 08:03 AM
  3. Hello World plugin
    By paulpv in forum CF Plugins
    Replies: 5
    Last Post: 06-08-2006, 10:07 PM
  4. How do I use the Base plugin sources ?
    By guino in forum RR FAQ
    Replies: 1
    Last Post: 04-24-2006, 03:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •