Page 83 of 134 FirstFirst ... 33737475767778798081828384858687888990919293133 ... LastLast
Results 821 to 830 of 1340

Thread: .net Bluetooth Mobilephone Plugin

  1. #821
    Constant Bitrate
    Join Date
    Jan 2006
    Posts
    156
    Quote Originally Posted by lambosprit View Post
    I've asked them for advice but they say I have had enough "free" support. We'll see if they come up with anything more.
    That's literally "BS"! Give me your list of questions, I'll ask them and see what they say.

  2. #822
    Newbie
    Join Date
    Feb 2010
    Posts
    40
    Hello,

    Quick question:

    How can I configure mobilecall.skin to play a .mp3 or .wav file when it is activated?

    I'm busy modifying the skinfile because I don't want to use the flash file but as a result I lost the ringing sound which is in the mobilecall.swf file.

    Thanks! Porto

  3. #823
    Variable Bitrate Dartman_71's Avatar
    Join Date
    Feb 2009
    Location
    Finland
    Posts
    425
    Quote Originally Posted by lambosprit View Post
    I was just surprised that you found out about the audio device things and assumed you'd read the readme.

    Anyway the update thing will have to stay for now as getting events to work through managed and unmanaged code is beyond me for now.

    You should see a line like

    19/03/2010 21:11:11: Que Exec: True, menu.skin, "ONMOBILEPHONECONNECTED", False
    19/03/2010 21:11:11: Executing: PLAYSOUND;C:\Program Files\carputer\RideRunner\Skins\Ultimate\ringin.wa v


    in the riderunner debug.txt file. Do you see that?
    Have you tried a simpler exectbl.ini line say just with the playsound bit?
    I notice straight those audio device settings and realize what those was. Now I read readme and perhaps you forgot to update it because I can't find a word about it. Well now I know those doesn't work.

    I don't see those lines in rr debug, here's mine:

    20.3.2010 9:41:50: Que Exec: True, menu.skin, "SETVAR;mobilephone_photopath;D:\Ohjelmat\RideRunn er\Plugins\Mobilephone.NET\Phonepics\N/A.jpg", False
    20.3.2010 9:41:50: Executing: SETVAR;mobilephone_photopath;D:\Ohjelmat\RideRunne r\Plugins\Mobilephone.NET\Phonepics\N/A.jpg
    20.3.2010 9:41:50: Que Exec: True, menu.skin, "RADIOMUTE;ON", False
    20.3.2010 9:41:50: Executing: RADIOMUTE;ON
    20.3.2010 9:41:50: Command not executed: RADIOMUTE;ON
    20.3.2010 9:41:50: Que Exec: True, menu.skin, "ONCOMMANDINVALID", False
    20.3.2010 9:41:50: Executing: ONCOMMANDINVALID
    20.3.2010 9:41:50: Que Exec: True, menu.skin, "SETVAR;mobilephone_batterystrength;D:\Ohjelmat\Ri deRunner\Skins\Reborn\SLIDER_MOBILE\\MOBILEPHONE_B ATTERY_5.gif", False
    20.3.2010 9:41:50: Executing: SETVAR;mobilephone_batterystrength;D:\Ohjelmat\Rid eRunner\Skins\Reborn\SLIDER_MOBILE\\MOBILEPHONE_BA TTERY_5.gif
    20.3.2010 9:41:50: Que Exec: True, menu.skin, "SETVAR;mobilephone_signalstrength;D:\Ohjelmat\Rid eRunner\Skins\Reborn\SLIDER_MOBILE\\MOBILEPHONE_SI GNAL_5.gif", False
    20.3.2010 9:41:50: Executing: SETVAR;mobilephone_signalstrength;D:\Ohjelmat\Ride Runner\Skins\Reborn\SLIDER_MOBILE\\MOBILEPHONE_SIG NAL_5.gif
    20.3.2010 9:41:50: Leave Exec: False, menu.skin, SETVAR;mobilephone_signalstrength;D:\Ohjelmat\Ride Runner\Skins\Reborn\SLIDER_MOBILE\\MOBILEPHONE_SIG NAL_5.gif, False

    I test exectbl code with skintool and code is valid.

    "ONMOBILEPHONERING","MENU;MOBILECALL.skin||PLAYSOU ND;$SKINPATH$SOUNDS\RINGING.wav"
    "ONMOBILEPHONECONNECTED","PLAYSOUND;$SKINPATH$SOUN DS\CONNECTED.wav"

    Few words about audio devices. I have set usb mic as default audio input device in Windows audio settings and I manage to get usb mic work in carpc when I made one call with BS cPhonetool first. But I can't get usb mic work in desktop, BS things Silabs radio is mic and use it. I have Directed HD radio in carpc so no Silabs problem there. If I try to run cPhonetool in desktop, I don't have cPhone tool lisence for desktop so I only can try to run it, then BS start to use usb mic but after rebooting desktop Silabs is BS's favorite mic again.

  4. #824
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    786
    looks like I posted the wrong version

    try this

    It has extra debug so set the level to 5 and it will show if the events have been fired.

  5. #825
    Variable Bitrate Dartman_71's Avatar
    Join Date
    Feb 2009
    Location
    Finland
    Posts
    425
    Okay now we going somewhere. All events execute fine (inc.ONMOBILEPHONEDISCONNECTED), but plugin send RADIOMUTE;OFF every ten sec. So if I listen radio and mute it manually, after ten sec it start to play again.

  6. #826
    Maximum Bitrate bratnetwork's Avatar
    Join Date
    Oct 2007
    Location
    Haledon, NJ
    Posts
    503
    Quote Originally Posted by lambosprit View Post
    The audio device thing doesn't work because the BS sdk doesn't work. I've asked them for advice but they say I have had enough "free" support. We'll see if they come up with anything more.
    This feature would be REALLY nice to have. It would solve all the problems of using a dedicated sound card like the Andrea one for noise and echo cancellation and still allow use to use our higher end sound cards for all our other audio.

    How much would the tech support be? I'd be willing to chip in for it and I'm sure others would be also willing to help out. This plugin has already been a huge advance in BT usage with our PCs and we all appreciate your time and dedication.

  7. #827
    Newbie
    Join Date
    Feb 2010
    Posts
    40

    Multiple numbers

    Hello,

    I miss something quite handy in the plugin: choosing out of multiple phonenumbers.

    Currently, you have to make an entry for every number one person has, so the contactlist will be quite full of identical names but with their other numbers beneath it:

    Porto (Home)
    Porto (Work)
    Porto (Mobile01)
    Porto (Mobile02)

    etc etc.

    It must be possible to have one name 'Porto' in the list and selecting this name will give you a (popup) screen with all the numbers he has so you can select the one you want to dial.

    There are multiple options when selecting a name in the contactlist:

    - Tap a contact, list all saved numbers in a little popup window, tap the wanted number and it will show in the dialer screen (in mobilephone.skin) so you can call him.

    - Tap a contact, transform the dialer screen to some sort of scroll menu, it gets you the present numbers listed stacked. Hit a number to select and that also closes the scroll menu and you're ready to dial that number.

    - Tapping the name multiple times will cycle through the available numbers for that specific contact.


    This option would be quite cool to have!



    Also another feature would be quite interesting to have:

    A free editable 'contact information' screen that can contain the contacts address, birthday, a message, a note or whatever you want to add to that contact. 10 - 15 lines of info per contact would be enough, I guess.

    Add the necessary label/button (e.g. 'Contact Info') to the above number-select listing and it will bring you to a new window with the current information listed and with only maybe an EDIT, DELETE and SAVE/BACK button.


    Just my pennies!

  8. #828
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    786
    new test version. Only unmutes radio if it was unmuted before the call. If it was muted then it should stay muted.

    Also found a bug in the multi phone code so now it does allow more than one phone mac code to be entered. It still only allows one phone connection only

  9. #829
    Variable Bitrate Dartman_71's Avatar
    Join Date
    Feb 2009
    Location
    Finland
    Posts
    425
    Awesome!!! Radiomute works perfectly, also knows source and not send radiomute cmd if music player is on. Multi phone connecting works too, no problem.

    Excellent work like always, thank you very much!

  10. #830
    Newbie
    Join Date
    May 2007
    Location
    Duarte, CA
    Posts
    28
    Not sure if this is a bug or if it is isolated to my setup, but after installing 1.15, everytime RR loads, volume is set to 50%, and it can not be changed unless I mute, and then unmute the volume. Then i can adjust the volume. I figured it was isolated to this plugin just because it only started happening after i installed.

    i am by no means knocking the plugin, because it is awesome and very easy to implement into the car. This is just a minor set back with the volume, but well worth it in comparison to what mobilephone offers

    Any one else experience this? I did a thread search, but nothing relevant popped up.

Similar Threads

  1. nGhost 2.0.0 Final is out!
    By tripzero in forum LinuxICE
    Replies: 53
    Last Post: 07-16-2009, 10:16 PM
  2. Bluetooth problems their solutions
    By Clintebb in forum Bluetooth Hardware
    Replies: 9
    Last Post: 12-26-2007, 09:03 AM
  3. Hello World plugin
    By paulpv in forum CF Plugins
    Replies: 5
    Last Post: 06-08-2006, 11:07 PM
  4. How do I use the Base plugin sources ?
    By guino in forum RR FAQ
    Replies: 1
    Last Post: 04-24-2006, 04:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •