Page 94 of 134 FirstFirst ... 4484858687888990919293949596979899100101102103104 ... LastLast
Results 931 to 940 of 1338

Thread: .net Bluetooth Mobilephone Plugin

  1. #931
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    786
    Quote Originally Posted by wired48 View Post
    I,ve been trying to get this plugin to work for about two weeks and it is not showing up in the plugin manager. Help please
    As I said above check the debug logs. Sometimes it crashes and because it's died it doesn't show in the plugin manager. Make sure the debug levels are set to 5.

  2. #932
    Low Bitrate
    Join Date
    Mar 2007
    Location
    Barbados
    Posts
    69
    here is my debug log. When i manually register the plugin it says it was successful. the log was created after i tried to register the the plugin
    Attached Files Attached Files

  3. #933
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    786
    Quote Originally Posted by wired48 View Post
    here is my debug log. When i manually register the plugin it says it was successful. the log was created after i tried to register the the plugin
    WOW you're the first person I've seen using the ATSM version......is this intentional? Its all old code from lucifers original plugin which I hope I haven't broken. If you did intend to use ATSM I can try to help with more debug. If you intended to use the bluetooth then you should read up on what needs to be set to make it work.

  4. #934
    Low Bitrate mcfly's Avatar
    Join Date
    Dec 2007
    Location
    Romania
    Posts
    98
    I'm trying to install v1.6, but it gets interrupted at registering the DLL. Regasm executes and syas "...Types registered successfully. Assembly exported to 'd:.....\MobilePhone.tlb', and the type library was registered successfully" and in the next instance installation stops with "Failed to register mobilephone.dll" error.
    Which framework do I need? Or something else...
    Plugin v1.4 worked.

    Edit: Before registering, "VC++ Redistributable not found" pops up. I choose OK to install vcredist, but nothing happens, it jumps over to regasm part. I installed vcredist 2008 manually, rerun mobilephone 1.6 setup, the same error, vcredist not found.

  5. #935
    Low Bitrate mcfly's Avatar
    Join Date
    Dec 2007
    Location
    Romania
    Posts
    98
    Temporary workaround: installed 1.14 and copied over the dll and tlb from 1.16.

    I was again looking to figure out why battery and signal aren't showing up, but the log at debug level 5 doesn't contain that info. I know the test skin shows that info, but should also the log file?

  6. #936
    Variable Bitrate sargeants's Avatar
    Join Date
    Oct 2008
    Location
    Ontario, Canada
    Posts
    232
    battery and signal don't show up with many phones. I've had it show up twice with both my phones (Blackberry 8330, and Motorola Milestone/Droid) - but it's not happening everytime. It's more of a problem with the phone than the plugin. This has been mentioned multiple times.

    As for the installation, can't help you there... sorry
    03 Hyundai Elantra GT {Worklog}
    HP TC4400; 250GB SATA, WiFi, BT, 12.1" touch
    RideRunner; w/ mobilephone.net, OBDMPG, mediaart, RRMedia, DFXVoice and more...
    cmdRR tall skin creator

    86 Pontiac Fiero SE 2m6
    possible carpc install

  7. #937
    Low Bitrate mcfly's Avatar
    Join Date
    Dec 2007
    Location
    Romania
    Posts
    98
    Yea, I know. I wouldn't blame the phone though. Centrafuse manages to show these sliders every time.
    Anyway, this is an insignificant problem, I just had some spare time to do some debugging...
    Quote Originally Posted by sargeants View Post
    As for the installation, can't help you there... sorry
    Well that's been taken care now as I said earlier; now I have to make use of the new features in the skin I use (Reborn) -especially BT PAN!

  8. #938
    Maximum Bitrate
    Join Date
    Jan 2005
    Posts
    515
    I know this has been brought up but I want to findout if reading contacts from the handset is a sdk issue or just not implemented yet

    Thanks,
    yonu

  9. #939
    Low Bitrate mcfly's Avatar
    Join Date
    Dec 2007
    Location
    Romania
    Posts
    98
    Quote Originally Posted by yonu View Post
    reading contacts
    I ran some AT commands thru putty, my phone (k800i) responds ok. I read battery level, and phone make/model. I didn't know the command for listing the contacts, instead I turned to RRMobile for help, and it manages to display my contacts, and the battery level correctly.
    Signal level value is always 99.99, this I admit, may be a bug in the phone (although signal displays correctly in Centrafuse), maybe it has to be queried another way.
    Battery level is replied as 0.xx meaning xx%
    As for phone model: Mobilephone.net displays make as "Sony-Ericsson" and model as "AAD"-something. I found that "K800i" is replied to AT+GMM. That "AADxxx" stuff is AT+CGMM.

    Now if I understood correctly, Lambosprit, you don't deal with AT commands directly. So I guess there's not much you can do about the phonebook functionality. Maybe you could use AT commands for the phonebook and leave the rest to the BS SDK (?)

  10. #940
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    786
    Quote Originally Posted by mcfly View Post
    Now if I understood correctly, Lambosprit, you don't deal with AT commands directly. So I guess there's not much you can do about the phonebook functionality. Maybe you could use AT commands for the phonebook and leave the rest to the BS SDK (?)
    You understand correctly. Thats the main reason why I went for BS because all the other phone plugins required lots of work to get all the AT commands but BS has done all the work.

    Now it is possible to send AT commands so I may be able to implement contacts using AT commands. It would mean people discovering the command though and setting it somewhere.

Similar Threads

  1. nGhost 2.0.0 Final is out!
    By tripzero in forum LinuxICE
    Replies: 53
    Last Post: 07-16-2009, 09:16 PM
  2. Bluetooth problems their solutions
    By Clintebb in forum Bluetooth Hardware
    Replies: 9
    Last Post: 12-26-2007, 08:03 AM
  3. Hello World plugin
    By paulpv in forum CF Plugins
    Replies: 5
    Last Post: 06-08-2006, 10:07 PM
  4. How do I use the Base plugin sources ?
    By guino in forum RR FAQ
    Replies: 1
    Last Post: 04-24-2006, 03:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •