Page 11 of 34 FirstFirst ... 23456789101112131415161718192021 ... LastLast
Results 101 to 110 of 337

Thread: RRVoice

  1. #101
    FLAC
    Join Date
    Jun 2002
    Location
    Virginia
    Posts
    1,789
    Quote Originally Posted by Blue ZX3 View Post
    Yes, that is a problem.
    I have over 25k numbered files. That essentially makes the music management aspect of RRVoice a no-can-do for me.

    I read somewhere that someone (you?) is looking into whether RRVoice can be integrated with or take advantage of the RRMedia database, which relies on tags rather than file names. Do you think that's a possibility?

  2. #102
    Mod - all of it.
    Join Date
    Jul 2007
    Location
    Buena Park, So Cali
    Posts
    524
    Quote Originally Posted by kbreeden View Post
    Also, perhaps related, is that most of my songs have numbers at the beginning of their names. So it would be 01-Come Together, 02-Something, 03-Maxwell's Silver Hammer and so on. Is that a problem?
    I had song numbers as well. The song numbers are only a problem where you have to say the title, so I use the text editor to remove the song numbers from the what to say part of the title.

    My original file looked like this:

    Play Song One Reference Point=Acoustic Alchemy\Reference Point\01 Reference Point.wma

    If you use the replace feature of Notepad, you can do it pretty fast and painless. I set up the replace to do this:

    Replace: Song One (followed by a space)

    with

    Song (followed by a space)

    It goes through the whole text file and removes the One from every song one. I then did it for all the song twos, etc etc. I dont have 35000 songs but I do have 10000 so it did take a while, but now I have full voice control of my music library.

    I actually had to do a lot of manual editing to the song.ini file.

    Hope this makes sense. If not ask and I will try to explain better.
    CAR: 2007 G35 Sport Coupe 5AT
    HARDWARE: Dell D630 w/ dock, internal 80G HD, internal 320G HD, Verizon Wireless Card, iBlue GM-2 GPS w/iGuidance, OBDPros w/DashCommand, Visteon HD Radio w/ Home Made Cable, Current Version of RR w/ DFX Skin. My Install.

  3. #103
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    I did actually make a util for that, it just doesn't quite match up like jebus does... but could give to you for a try..
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  4. #104
    FLAC
    Join Date
    Jun 2002
    Location
    Virginia
    Posts
    1,789
    @ drew,

    Your explanation makes perfect sense and works well. Most of my songs are named 1- Song, 2 - Song, etc. If I open the songs.ini Word, I can search and replace using wildcards. Thus, I can search for "?? -" and replace with nothing so that all the numbers will be removed. Takes about two minutes. Of course, I must search for "??-" "??_" as well. Thanks for the tip.

    @blue,

    I wouldn't mind taking a look at that script if you don't mind.

  5. #105
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Mine even had the extra processing that would do word replacements.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  6. #106
    FLAC
    Join Date
    Jun 2002
    Location
    Virginia
    Posts
    1,789
    I still have not been able to play a song using RRVoice, even where I'm certain that the song name contains no unrecognizable characters. I can load songs into the playlist using RRVoice, but they won't play. Even if it's a single song, I can see it in the playlist but it won't play. If I close RR and load Winamp and view file info for the song, there is nothing shown. So, the title of the song is being loaded, but the song itself is not being found. Any thoughts?

    WinXP SP3, Winamp 5.13, RR 09/10. DFX 5 RC2.

  7. #107
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    After you have a bogus playlist present (loaded with rrvc), issue a savelist;xxx cmd to like the desktop and look at the file.

    My thinking is that its not working is because of how you set the config(music root path wise) to scan your collection, and then when you issue a vc to play a artist, ect... that its messing up the path as its not the same as your rr music path so it creates a playlist with incorrect paths.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  8. #108
    Variable Bitrate Jebus's Avatar
    Join Date
    Dec 2007
    Location
    Washington, USA
    Posts
    313
    I don't know how you are creating the music.ini and songs.ini, but,
    remember Blue, if he changes his music he has to run your dbase rescan...
    RRVoice is only issuing a playitem command on a song and a loadlist/ plexec on album or artist command, so it has to match RMDatabase when rr wants to play it...playlist position????
    ...JJG

  9. #109
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    I know, but is/was using your config and stated that he set the config to scan his collection one folder level in compared to what he has his music path set in RR as. I don't know if you only uses relative paths when your config scans and saves to the ini's. I was just putting my thought as to maybe a reason that he cant seem to get it to work...
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  10. #110
    FLAC
    Join Date
    Jun 2002
    Location
    Virginia
    Posts
    1,789
    Quote Originally Posted by Blue ZX3 View Post

    My thinking is that its not working is because of how you set the config(music root path wise) to scan your collection, and then when you issue a vc to play a artist, ect... that its messing up the path as its not the same as your rr music path so it creates a playlist with incorrect paths.
    Yes, that's it. I set config to scan on D:\Rock. This produced lines in the songs.ini like:

    Play Song Here Comes the Sun=Beatles\Abbey Road\Here Comes the Sun

    The song is actually in the path Rock\Beatles\Abbey Road. So RR was trying to play a song that didn't exist in the path requested. I used Notepad search and replace to replace "=" with "=Rock\" and all is now well. (Detailed explanation is for those who may be having similar problems.) This is definitely cool once it's working.

    That being said, it sure would be nice if RRVoice could provide the option to make use of the RRMedia database as you guys discussed in the original RRVoice thread. That would save a lot of time and effort in building and modifying the songs.ini file.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •