Page 12 of 34 FirstFirst ... 2345678910111213141516171819202122 ... LastLast
Results 111 to 120 of 337

Thread: RRVoice

  1. #111
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    This can be done, I think though that I need to rethink my rrvc ini maker's inner workings. But this will not be looked into at least till dfx5 is released...
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  2. #112
    FLAC
    Join Date
    Jun 2002
    Location
    Virginia
    Posts
    1,789
    Well I now have it installed and working perfectly in my car with the mouse as the trigger. Wow, it's amazing how much this enhances the carputing experience. To think that a week ago I barely knew this plugin existed and now it is installed, fully configured and working beautifully in my car. (Of course, this has meant that a couple of Wifey's horses have escaped through the holes in the fence, but a man has to have his priorities straight.) Many thanks, Jebus, for this plugin and for RRMousetrap.

  3. #113
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Hopefully, we just don't see a posting with the mention of the "D" word... divorice...LOL
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  4. #114
    FLAC
    Join Date
    Jun 2002
    Location
    Virginia
    Posts
    1,789
    Here's an article published today that has some relevance to this thread.

  5. #115
    Variable Bitrate Jebus's Avatar
    Join Date
    Dec 2007
    Location
    Washington, USA
    Posts
    312
    That being said, it sure would be nice if RRVoice could provide the option to make use of the RRMedia database as you guys discussed in the original RRVoice thread. That would save a lot of time and effort in building and modifying the songs.ini file.
    This can be done, I think though that I need to rethink my rrvc ini maker's inner workings. But this will not be looked into at least till dfx5 is released...
    It definitely can be done, and RRVoice is going to be developed further...

    Blue, think of how RRVoiceConfig makes the ini's.
    It is the same way RR found music before RMDatabase, a Folder View search.
    Now you take all that and stuff it into a database with sqlite3.
    Tags, path, and all are readily accessable. Very Nice.

    IMO all you have to do is have RMDatabase generate and store
    a Voice Command, or multiple Voice Commands, (artist, album, song, genre, ect..) for each mp3 found. User editable, of course.

    Then a command file needs to be generated, on the fly, like a voice playlist with key=value pairs
    Many variables can be taken into account before generating a size and format VR acceptable Voice Playlist. VR will never be able to be accurate if you generate a grammar file that is too large. Same with the format.

    This Voice Playlist can be consumed by RRVoice into a collection, adding menu elements, to feed the grammer engine so it can match to the users spoken command.

    Once the match is made, then RRVoice "knows" what "key' to get the "value" from. This value is the command sent to RR to get the mp3 of choice.

    That command can be an RMDatabase command...
    Playitem and Loadlist||Plexec can be changed in the RRVoice.ini...

    How does RMDatabase "find" the song after you click in one of your many screens for RMDatabase? I'm sure it just does a query...
    Maybe RRVoice could "send" that query?

    RRVoice is very simple in function, It only knows what words to match on.
    The ini files control the rest...
    ...JJG
    RRVoice Version 1.1.0.10 BETA
    RRVCConfig Version 1.0.0.69 BETA
    RRMouseTrap Version 1.5 Beta
    RRPointer Version 1.0 BETA Update Soon
    RRTTS Testing
    RRScript Testing
    SerialSwitch In Development

  6. #116
    FLAC
    Join Date
    Dec 2008
    Posts
    1,322
    i think that is absolutely the way to go forward in the future. if RRvoice went by the ID2/3 tags, and it automatically setup the ini file for you, then you are talking about some seriously easy software to use....

  7. #117
    Low Bitrate
    Join Date
    Aug 2006
    Location
    Columbus, OH
    Posts
    75
    Quote Originally Posted by Jebus View Post
    Then you missed one of your PM's...
    I know I PM'ed this to everyone in RC2 group..
    And it was dloaded 7 times...
    No worries...
    Current released version is here. RRVoice

    ...JJG
    Jebus, I'm trying to test your new version (posted) and I'm now getting stuck with RRVoiceConfig with the following error:

    You must have a DefaultMediaPath in RRVoice.ini!

    I have tried to add the following lines to RRVoice.ini but not luck:

    [Paths]
    DefaultMediaPath=D:\My Music\
    or also
    MediaPath=D:\My Music\

    Can you provide some light of where I need to head to ?

    I did not had this issue with your previous version. Thank you.

  8. #118
    Variable Bitrate Jebus's Avatar
    Join Date
    Dec 2007
    Location
    Washington, USA
    Posts
    312
    I need to add to my instructions to run RideRunner with RRVoice enabled before running RRVoiceConfig.
    The ini has changed a bit from the earlier version...
    I imagine you didn't want to loose all your commands and didn't copy the ini or the newer RRVoiceConfig.exe from the zip.
    RRVoiceConfig.exe should be dated 9/6/2010...
    There is an updated RRVoice_Skin_Commands.txt that explains all this in the zip...
    The top part of the RRVoice.ini should look like this and at least have the keys in there.
    Your [Paths] values will be different...

    [Paths]
    LoadPath=C:\Program Files\Road Runner\Plugins\RRVoice\
    MusicPath=C:\Media\Music\
    SkinPath=C:\Program Files\Road Runner\Skins\DigitalFX 5.0\

    [Settings]
    MusicCmdStatus=You Have 1151 Voice Command Songs!
    StripChar=-_[],.()!@#$%^*+><?
    ConfigDebug=False
    UserName=Joe Grau
    Debug=False
    LoadIniSection=Commands
    LoadIniFile=Menu.ini
    PlayMusicCommand=LOADLIST;
    PlayMusicXtra=PLEXEC
    PlaySongCommand=PLAYITEM;
    PlaySongXtra=
    LastScreen=exit_menu.skin
    LastArtist=Play Artist The Who
    LastAlbum=
    LastSong=Play Song Pinball Wizard
    LastCommand=Test Script

    ...JJG
    RRVoice Version 1.1.0.10 BETA
    RRVCConfig Version 1.0.0.69 BETA
    RRMouseTrap Version 1.5 Beta
    RRPointer Version 1.0 BETA Update Soon
    RRTTS Testing
    RRScript Testing
    SerialSwitch In Development

  9. #119
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,700
    Blog Entries
    1
    Quote Originally Posted by kbreeden View Post

    I saw on your video in the DFX thread that you have the play artist, play album, play song commands working perfectly. In reviewing the RRVoice threads I saw that at one time you had issues with the music scanner not properly recognizing your artists, albums, songs, etc. I am having the same problem. My directory structure, which I think is similar to yours, is:

    D:\Genre\Artist\Album\ 1 - Song 1
    2 - Song 2
    3 - Song 3



    It does scan all the songs, but it thinks my genres are the artists and does not list any artists. I'm wondering how you solved this problem. I thought I read this was going to be integrated with RRMedia so tags would be used rather than relying on folder structure and file names. Any idea how I might be able to fix this?
    As a fix for now, you MAY be able to open the music.ini and do a global search and replace. I would have to see a section of your music.ini to see if it could be done. It is a band-aid, but would work till something better comes along
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  10. #120
    FLAC
    Join Date
    Jun 2002
    Location
    Virginia
    Posts
    1,789
    Quote Originally Posted by JohnWPB View Post
    As a fix for now, you MAY be able to open the music.ini and do a global search and replace. I would have to see a section of your music.ini to see if it could be done. It is a band-aid, but would work till something better comes along
    Thanks, John. I wound up doing exactly that a couple of days ago and it worked great. The problem was that because of the way the build works the song.ini and music.ini were not pointing to the correct folders containing the mp3 files. Interestingly, having the sequential song number at the beginning of the file names (e.g., 1 - Here Comes the Sun) does not appear to have any negative impact.

    By the way, I sent you a PM a couple of minutes ago.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •