Page 2 of 34 FirstFirst 123456789101112 ... LastLast
Results 11 to 20 of 337

Thread: RRVoice

  1. #11
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,711
    Blog Entries
    1
    Ok, I am having a couple of issues here.

    When I start RR, the !RRVC_Ind indicator showing that the plugin is listening, turns ON when RR is started.

    Also when RR starts, the VROnCmd=VoiceStart is firing when the plugin starts up. (VoiceStart is a command I have in the ExecTbl.ini to handle muting of the active audio source, in this case it is muting the audio on RR start because the command is firing)

    Isn't VROnCmd only supposed to only fire when the RRVCON command is issued? The same thing for the indicator being turned on?
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  2. #12
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Just Making sure that this would be the correct flow of cmds/events start to finish...

    ONRRVCSTARTUP

    RRVC_ON

    BeforeVRONCmd=

    VROnCmd=

    ONRRVC_ON

    < RRVC is listening and waiting >

    [ RRVC_OFF ] - If VC is/was canceled

    ONRRVC_OFF

    VROffCmd=

    AfterVROFFCmd=

    ONRRVCSHUTDOWN
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  3. #13
    Variable Bitrate Jebus's Avatar
    Join Date
    Dec 2007
    Location
    Washington, USA
    Posts
    313
    Blue, That looks right. Less, on a trigger to listen,
    RRVoice does a startup init to set things up correctly.
    John you should see this @ startup but should be all off after init...Ready to trigger...
    Here's what I see in the Skinner Tool @ Startup...
    ...JJG
    Attached Images Attached Images  

  4. #14
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Using the 6/2010 RR version, your dll from above, and NOTHING set in cmd wise in the RRVoice.ini file. I also commented out the onskinstart cmd to keep things simple.

    This is what I have in my widow:
    ONRRVCSTARTUP
    -
    SAVETOINI;RRVCPath;C:\Program Files\RideRunner\Plugins\RRVoice\
    -
    SETIND;!RRVC_Ind;ON
    -
    ONRRVC_ON
    -
    ONLINE


    So, I don't see:
    the indicator being turned off
    no, onrrvc_off event fired
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  5. #15
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    How "I" think that your plugin startup should look like, in theory...

    RR Starts up
    RR begins loading of RRVoice PI

    <Inside PI>
    pluginLoaded=False
    < create sapi object >
    < other setup codeing for vcrecon >
    [ when going to call or execute any of the cmd settings or events it ]
    [ checks if the plugin is done initilizing and if not, should NOT ]
    [ fire/execute anything till after that first initial on/off that your doing ]
    [ example: ]
    [ If Pluginloaded then rrsdk.Execute(<VCOncmd>) ]
    pluginLoaded=true
    <Inside PI>

    RR finishes loading of RRVoice PI
    RR Done and at a Ready state

    This would not execute any cmds or events till the PI is told to do so.

    I hope you understand what i'm talking about or getting at. I don't have the code to give you a clearer/better example.

    Understand?
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  6. #16
    Variable Bitrate Jebus's Avatar
    Join Date
    Dec 2007
    Location
    Washington, USA
    Posts
    313
    Blue: I gotta look @ code tnight. I said I spotted a potential issue earlier, by removing my vroncmd and vroffcmd. I'll see why it is not fully initializing...
    ...JJG

  7. #17
    Low Bitrate Challenged's Avatar
    Join Date
    Jan 2010
    Posts
    86
    First of all, this is really a wonderful plugin so thank you very much for all of your work on this. Having a CarPC is great, but having to take your eyes off the road frequently to look at the touch-screen is a very dangerous game to play at times; RRVoice should hopefully help out with this. A number of my friends are already envious of my CarPC, and this should make them even more so.

    I installed RRVoice today and had a couple of issues that I wanted to share. The first was that I ended up scanning my music on my home PC because the scan routine would hang when I attempted to use it inside of my car. I was able to scan just a single folder in the car, so I know it was working fine, but I let it sit for an hour and a half trying to scan my full collection (over 20,000 songs) and it never started counting the songs. The scan on my home computer seemed to work fine on the entire collection, however, so perhaps this isn't a big deal or was a configuration issue on my part. My home computer is much much faster than the CarPC as well...

    The second problem I'm having is that after I used RRVoice for a while, I turned off my car and then came back out later to try some more things, but now Ride Runner crashes about 10 seconds after I launch it. If I'm really quick, I can usually say one command before it crashes and it will acknowledge and run that command, so I know the plugin is working before the crash.

    That said, if I simply remove the RRvoice plugin directory, or un-register the RRVoice plugin, then Ride Runner works without issue. I enabled debugging in both Ride Runner and RRVoice, but didn't see anything offhand in the debug logs that looked funky, but I also didn't really know what to look for.

    I'm running the June 2010 Ride Runner release on Windows 7 32bit. Would you like a debug.txt file from either Ride Runner or the RRVoice process? I know this was just released, so if either of these is a known issue, I'll just wait patiently.

    Thanks again for this great addition to my CarPC.

  8. #18
    Low Bitrate Challenged's Avatar
    Join Date
    Jan 2010
    Posts
    86

    Fixed

    Well, I knew this would happen but I restarted my CarPC and then wiped out the RRVoice.ini file and re-created it with the config program and now it seems that everything is hunky dory again.

    One odd thing not related to RRVoice, is that is that if I turn on the "Acoustic Echo Cancellation" on my Realtek card, then the speech recognition engine fails to init. However, leaving on the Noise Reduction feature doesn't seem to cause the same problem.

  9. #19
    Variable Bitrate Jebus's Avatar
    Join Date
    Dec 2007
    Location
    Washington, USA
    Posts
    313
    Blue,
    Gotcha, Not the issue though, startup timing.
    It is code flow that got interrupted when I needed to have different VROnCmd and VROffCmd accounted for...I made sure I didn't hardcode it, but I didn't account for it in code...

    Challenged,
    RRVoice was not developed for Win7.
    RRVoice is gonna give you trouble in Win 7, cause it has to run in compatibility mode....I think RR does too...
    Also I am not abiding by the MicroHoo Directive that all ini's or user files go into user folder. They are in the plugin's folder...Check file/folder permissions there...
    Win7 probably won't be supported by me in the near future...
    I am using Win2K on all my boxes except the linux ones.
    It works fine, and I do more than most on one...
    If I move up it will be all Linux...
    Why would anyone need Win7 and 20,000 songs in their car????
    On a slower CarPC thats gonna choke for awhile on indexing 20,000 songs.
    And, with a nice skin, RR works and looks just the same on Win2k, XP, or Win7...
    I don't get it...
    Don't know if I have an answer to help...

    ...JJG

  10. #20
    Low Bitrate Challenged's Avatar
    Join Date
    Jan 2010
    Posts
    86
    Jebus, no worries at all. I completely understand that you can't debug and/or program for all setups. I can't tell you how thankful I am that you released this and it seems that just refreshing the RRVoice.ini seemed to do the trick for me for the time-being.

    Honestly I spend probably 95% of my time in Fedora (my company is actually 100% Linux), and I'm not terribly familiar with Windows anymore, but I decided on Windows for the car, mainly due to driver support and the fact that I really wanted to use Garmin Mobile PC for nav. I'm usually not happy leaving well enough alone, so I can see myself moving to Linux in the car eventually as well.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •