Page 31 of 48 FirstFirst ... 212223242526272829303132333435363738394041 ... LastLast
Results 301 to 310 of 472

Thread: DFXVoice A Voice Control Plugin [v1.1.0.1 Released 09/23/2012]

  1. #301
    Maximum Bitrate Dave One's Avatar
    Join Date
    Mar 2005
    Location
    Norfolk UK
    Posts
    549
    I probably should add (in my defence) that I have used some heavily modified Nav commands to save multiple key presses, lol
    Vauxhall Astra SXi Car PC installed.

  2. #302
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    I have updated the installer and dll files in the first post, timeout is now 60 days from today...
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  3. #303
    Maximum Bitrate Dave One's Avatar
    Join Date
    Mar 2005
    Location
    Norfolk UK
    Posts
    549
    Quote Originally Posted by Blue ZX3 View Post
    I have updated the installer and dll files in the first post, timeout is now 60 days from today...
    Downloaded, Thanks Blue. Now to find out why my .mp3 tag info keeps vanishing since the RR Feb release????? (I know that's not a DFXVoice issue )
    Vauxhall Astra SXi Car PC installed.

  4. #304
    Variable Bitrate michaelrj9's Avatar
    Join Date
    Feb 2005
    Location
    Huntsville, AL
    Posts
    288
    I am having a problem trying to get it working with XP.
    I am using the DFX skin so the it is pretty much setup already to activate DFXVoice. I did edit the skin to get the music Tag scanner to work in the DFX skin and completed a scan.
    I can switch screens with DFXVoice but can't get it to play any songs Via voice commands.
    Instructions seem pretty basic but can someone tell me what I am going wrong?
    If I understand it corectly all I do is say "Direct play (name of artist)" wait for the continue sound (voiceunderstood.wav) then say "song (name of song)"
    Correct?
    Or what am I missing?
    If I say it like above, and say "Direct Play Buchcherry" after I get the voiceunderstood.wav sound 1-2 seconds I get the voicedirectplayunderstood.wav sound before I get a chance to say "song crazy bit**"

    I would really like to get this working!!

    If I can get that working. What would I say to play an artist ( all songs)

    Thanks

    Michael
    Last edited by michaelrj9; 03-19-2012 at 06:04 PM.
    Win 7 Pro 64bit, 4gb DDR2 Ram, q6600 Processor, Solid state drive & 7200 drive, Andrea mic, Sirius, DE HD Radio, Opus power supply, 10.4" touchscreen.
    1.)Orion 2500d Amp
    1.)Orion 15" h2 Sub
    1.)Orion 8004 Amp
    2.) Sets Orion Components - P-SERIES

  5. #305
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    With the "Direct Play" interface, you get both acknowledgments, you get the normal one, telling you that it understood and then wait till the second one, telling you that its now ready for the next command. You can of course still do Play Artist xxxx, just like in RRVoice which will play all the songs by that artist.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  6. #306
    Variable Bitrate michaelrj9's Avatar
    Join Date
    Feb 2005
    Location
    Huntsville, AL
    Posts
    288
    Quote Originally Posted by Blue ZX3 View Post
    With the "Direct Play" interface, you get both acknowledgments, you get the normal one, telling you that it understood and then wait till the second one, telling you that its now ready for the next command. You can of course still do Play Artist xxxx, just like in RRVoice which will play all the songs by that artist.
    Ok, I am not going crazy yet, because that is what I was trying and did not work.

    What I found is if I scan the music collection again it works until I close RR then it don't work again until I re-scan the music collection again.

    Any ideas why?

    Upon first installation of the plugin and doing a music scan RR crashed and closed auomatically 5-6 times until I found & fixed or removed the mp3's that was causing the crash. It completes the scan now without any errors.

    Don't know if there is a corrupt file causing DFXVoice not to work after restarting RR.
    Or maybe somes tags it still don't like but still completes a scan now?

    Any ideas?

    What are the requirements for the tag info? like no ()_ - [] etc?. I know one didn't have a year and it was causing one of the crashes.

    Thanks again

    *EDIT*

    I made a real small music collection of a few artists and songs 15 songs in all and re-scanned but still does the same thing happens as stated above. So I would think that would rule out bad mp3s and or tag info unless one of those are bad too.

    I also tried to reinstall the plugin thinking if it was a corrupt file it would replace it but it still did not work.

    Any more ideas?

    Thanks
    Last edited by michaelrj9; 03-20-2012 at 04:35 PM. Reason: more info from testing
    Win 7 Pro 64bit, 4gb DDR2 Ram, q6600 Processor, Solid state drive & 7200 drive, Andrea mic, Sirius, DE HD Radio, Opus power supply, 10.4" touchscreen.
    1.)Orion 2500d Amp
    1.)Orion 15" h2 Sub
    1.)Orion 8004 Amp
    2.) Sets Orion Components - P-SERIES

  7. #307
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Quote Originally Posted by michaelrj9 View Post
    Ok, I am not going crazy yet, because that is what I was trying and did not work.

    What I found is if I scan the music collection again it works until I close RR then it don't work again until I re-scan the music collection again.

    Any ideas why?

    Upon first installation of the plugin and doing a music scan RR crashed and closed auomatically 5-6 times until I found & fixed or removed the mp3's that was causing the crash. It completes the scan now without any errors.
    There is one known issue with the scanner, that if a file has NO tags, the thread handling that half will crash. I don't think I have fixed that issue yet..

    Quote Originally Posted by michaelrj9 View Post

    What are the requirements for the tag info? like no ()_ - [] etc?. I know one didn't have a year and it was causing one of the crashes.
    Just that they are there, as it is reading them it does clean them up a little as so it won't confuse either the voice recog or make so that it won't recognize it when you try to say it. A missing year shouldn't effect it at all, its only looking for the artist, album and title tags.

    Quote Originally Posted by michaelrj9 View Post
    I made a real small music collection of a few artists and songs 15 songs in all and re-scanned but still does the same thing happens as stated above. So I would think that would rule out bad mp3s and or tag info unless one of those are bad too.

    I also tried to reinstall the plugin thinking if it was a corrupt file it would replace it but it still did not work.

    Any more ideas?

    Thanks
    The only thing else i can recommend would be to turn on the Music commands debugging either in the skin or by using the dfxvoice xml editor... then re run a scan and look at the dfxvoice_debug.txt

    files found in either the plugin folder or Docs\riderunner\plugins\dfxvoice
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  8. #308
    Variable Bitrate michaelrj9's Avatar
    Join Date
    Feb 2005
    Location
    Huntsville, AL
    Posts
    288
    Quote Originally Posted by Blue ZX3 View Post
    The only thing else i can recommend would be to turn on the Music commands debugging either in the skin or by using the dfxvoice xml editor... then re run a scan and look at the dfxvoice_debug.txt

    files found in either the plugin folder or Docs\riderunner\plugins\dfxvoice

    I did what you said and looked at the debugs and don't really see anything but I don't know what to look for unless it says errors or something like that.

    What I did was started a fresh new database in RRMediaDB then scanned it and it shows a total of the 16 songs that is in my new "small revised music collection" then I rescanned it in RRVoice and was quick 1 sec compared to 5 min for my real music collection. This debug shows no artists.

    I also did the fresh new database in RRMediaDB again after I put my real collection of songs back in the folder then scanned it and it shows all the songs again. Then I rescanned in RRVoice again and it took 5 min or so to finish. This shows a lot more stuff and all the artists.

    I attached the 2 debugs, one from my complete collection and one with the 16 songs and a few artists.
    Attached Files Attached Files
    Win 7 Pro 64bit, 4gb DDR2 Ram, q6600 Processor, Solid state drive & 7200 drive, Andrea mic, Sirius, DE HD Radio, Opus power supply, 10.4" touchscreen.
    1.)Orion 2500d Amp
    1.)Orion 15" h2 Sub
    1.)Orion 8004 Amp
    2.) Sets Orion Components - P-SERIES

  9. #309
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Part of the issue is that the RRMedia implementation is not finished yet, and I can tell from the log that you must have it enabled in dfxvoice. So, first set the RRMedia setting in dfxvoice to off, then try scanning again (dfxvoice) and the log should look a bit different and it should work then..
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  10. #310
    Variable Bitrate michaelrj9's Avatar
    Join Date
    Feb 2005
    Location
    Huntsville, AL
    Posts
    288
    Quote Originally Posted by Blue ZX3 View Post
    Part of the issue is that the RRMedia implementation is not finished yet, and I can tell from the log that you must have it enabled in dfxvoice. So, first set the RRMedia setting in dfxvoice to off, then try scanning again (dfxvoice) and the log should look a bit different and it should work then..
    Thanks, That did it.
    It seems to be working now.

    Time to go play and get everything else put back in!!!

    Check your Paypal! You've got a little something for the BIG headaches I have been giving you. More your way once I can land a job.

    Thanks!!
    Last edited by michaelrj9; 03-21-2012 at 09:56 PM.
    Win 7 Pro 64bit, 4gb DDR2 Ram, q6600 Processor, Solid state drive & 7200 drive, Andrea mic, Sirius, DE HD Radio, Opus power supply, 10.4" touchscreen.
    1.)Orion 2500d Amp
    1.)Orion 15" h2 Sub
    1.)Orion 8004 Amp
    2.) Sets Orion Components - P-SERIES

Similar Threads

  1. Plugin Manager control of plugin Config
    By lambosprit in forum RR Plugins
    Replies: 17
    Last Post: 10-17-2010, 04:46 PM
  2. Better Voice Control Plugin?
    By HiJackZX1 in forum CF Plugins
    Replies: 2
    Last Post: 11-21-2008, 09:39 AM
  3. Voice Tunes voice control software
    By kelmk in forum Software & Software Development
    Replies: 0
    Last Post: 03-18-2008, 10:29 PM
  4. Replies: 1
    Last Post: 03-15-2008, 11:26 AM
  5. New voice itunes voice control software!
    By The Don in forum MacCar
    Replies: 0
    Last Post: 03-25-2005, 09:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •