Page 4 of 9 FirstFirst 123456789 LastLast
Results 31 to 40 of 84

Thread: New Weather Plugin Beta

  1. #31
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    I had looked at noaa.gov briefly, one issue was the coverage outside the US, the other issue was looking at their samples, there was no wind, humidity and pressure information for the forecast days directly available - it may be available on with some specific queries or require extra queries, but I didn't see it right away. Just like google, nothing prevents us from making another weather plugin using noaa's data - it will just have less information than the current plugin (which for a lot of people should be fine).
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  2. #32
    Low Bitrate cmcd2820's Avatar
    Join Date
    May 2010
    Location
    Roswell, New Mexico, United States
    Posts
    56
    I never believe long range forecast of wind pressure and humidity anyway. It comes from growing up in New Mexico where the weather is described as "give it 5 minutes, it will change". Thanks for looking at it and explaining it. I appreciate what you and Mitch and everyone else do to keep the backend and the plugin's up to date and working.

  3. #33
    Low Bitrate
    Join Date
    Aug 2006
    Location
    Hong Kong
    Posts
    69
    Any log can let me know the weather is work fine? I install it at 7-Dec, everything is OK, but today I can't get the result anymore (the weather skin no data appear), I haven't change the variables "cityweatherid" and "weatherundergroundkey" in RR.ini.

    I try to delete the variable "weatherundergoundkey" to let the program read from weather.com, it has data appear (absolutely this is old data). And then I add back the "weatherundergroundkey", no data appear again.

    I double confirm the api key between wunderground.com and the variable, it is the same.

    Do you have this matter?

  4. #34
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    I just tried it here and it appears to continue working. I would check if there is only one wundergroundkey= line in rr.ini and check that your internet (on the carpc) works, if everything checks out, look at the wunderground site to see if there's anything wrong with your account (went over limit etc). If everything seems fine, delete mywsearch.xml and myweather.xml, and try again and post your most current mywsearch.xml and myweather.xml files from RR (if any of them are created).
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #35
    Newbie
    Join Date
    Nov 2006
    Location
    Russia
    Posts
    18
    Have tried the new plugin (using wunderground.com) with no luck - skin fields are empty. File myweather.xml is updated every time I open weather screen, it has information, but it seems that it isn't parsed. What I've missed?

    I'm using RR 04/11/11 version and DFX 5 skin.

    Attached myweather.xml for reference.
    Attached Files Attached Files

  6. #36
    Newbie bhitman's Avatar
    Join Date
    May 2008
    Location
    Runkel, Germany
    Posts
    34
    I've a strange effect: Plugin works fine, except for "w_lsup" and/ or "w_dayf". It shows everytime the same wrong date (30th dec.). Also the day-names of the forecast are wrong.
    All ohters datas are ok.

    Part of myweather.xml:
    <weather>
    <head>
    <ut>C</ut>
    <ud>km</ud>
    <us>km/h</us>
    <up>mb</up>
    </head>
    <loc>
    <dnam>Runkel, Germany</dnam>
    <tm>17:30</tm>
    <lat>50.40000153</lat>
    <lon>8.16666698</lon>
    <sunr>08:27</sunr>
    <suns>16:29</suns>
    </loc>
    <cc>
    <lsup>21.01.2000 Dec2011</lsup>
    <obst>Runkel, Germany</obst>
    <tmp>8</tmp>
    <flik>4</flik>
    <t>Regen</t>
    <icon>45</icon>
    ...

    Name:  weatherUpdate.jpg
Views: 293
Size:  26.0 KB
    (Today is the 22nd december!)

    Short info: since the 1st january the update-date is correct.
    Very strange...
    Last edited by bhitman; 01-06-2012 at 09:13 PM.
    Intel D945GCLF2, 2GB RAM, 160GB SATA, DVD-ROM SATA, WiFi Belkin USB, Navibe-GPS-Mouse, TFT 7" Lilliput, Win XP SP3, Silabs-radio, bluetooth by bluesoleil, RR last versions

  7. #37
    Low Bitrate
    Join Date
    Aug 2006
    Location
    Hong Kong
    Posts
    69
    Does it support Multi-Language? I found that some language xml file in the My Documents\RideRunner\Plugins\Weather\Languages, so I create one in Traditional Chinese name TChinese.xml, and change the variable "weatherlanguage=tchinese", but the weather information still shown english. Attached is my language file.
    Attached Files Attached Files

  8. #38
    Low Bitrate
    Join Date
    Aug 2006
    Location
    Hong Kong
    Posts
    69
    Anyone could help me? Thanks!

    Quote Originally Posted by WolfSkin View Post
    Does it support Multi-Language? I found that some language xml file in the My Documents\RideRunner\Plugins\Weather\Languages, so I create one in Traditional Chinese name TChinese.xml, and change the variable "weatherlanguage=tchinese", but the weather information still shown english. Attached is my language file.

  9. #39
    Low Bitrate
    Join Date
    Aug 2006
    Location
    Hong Kong
    Posts
    69
    Anyone could help me? Thanks!

    Quote Originally Posted by WolfSkin View Post
    Does it support Multi-Language? I found that some language xml file in the My Documents\RideRunner\Plugins\Weather\Languages, so I create one in Traditional Chinese name TChinese.xml, and change the variable "weatherlanguage=tchinese", but the weather information still shown english. Attached is my language file.

  10. #40
    Newbie
    Join Date
    Jun 2007
    Posts
    50
    Hi guys,i've just replaced the old dll,with the new one...

    registered it...

    created the account on wunderground.com and purchased the api key

    added it on rr.ini

    changed the city

    but i can't see nothing on weather skin...

    myweather.xml and mywsearch.xml are compiled and updated correctly


    Skin: Carwings
    RideRunner:latest and installed with profile mode

    here the rr.ini section....

    Code:
    [Extras]
    testpluginvar=defaultValue
    weatherundergroundkey=XXXXXXXXXXXXXXXXXX
    cityweather=Seriate,IT
    cityweatherid=USNY0996
    weatherunits=WORLD
    weatherdegrees=
    weatherlanguage=
    weatherupdateinterval=1
    weatherpreset01=
    weatherpresetid01=
    weatherpreset02=
    weatherpresetid02=
    weatherpreset03=
    weatherpresetid03=
    weatherpreset04=
    weatherpresetid04=
    weatherpreset05=
    weatherpresetid05=
    weatherpreset06=
    weatherpresetid06=
    weatherpreset07=
    weatherpresetid07=
    weatherpreset08=
    weatherpresetid08=
    weatherpreset09=
    weatherpresetid09=
    weatherpreset10=
    weatherpresetid10=
    some help??
    Attached Files Attached Files
    Last edited by tommy_xx84; 01-31-2012 at 05:19 PM.

Similar Threads

  1. 05/27/08 Road Runner Official Beta, Weather Fixed!
    By JohnWPB in forum Road Runner
    Replies: 57
    Last Post: 09-02-2008, 07:06 AM
  2. Weather Plugin
    By f1anatic in forum Centrafuse
    Replies: 7
    Last Post: 05-10-2008, 10:35 PM
  3. weather plugin
    By nadforever in forum Centrafuse
    Replies: 1
    Last Post: 06-11-2007, 11:15 AM
  4. Weather Plugin
    By Thor_PT in forum CF Plugins
    Replies: 4
    Last Post: 03-13-2006, 06:54 PM
  5. Weather Plugin
    By veetid in forum CF Plugins
    Replies: 27
    Last Post: 09-22-2005, 02:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •