Page 3 of 13 FirstFirst 123456789101112 ... LastLast
Results 21 to 30 of 126

Thread: RRPandora plugin for RideRunner

  1. #21
    Raw Wave pierrotm777's Avatar
    Join Date
    May 2008
    Location
    Bordeaux, France
    Posts
    2,846
    Quote Originally Posted by Sonicxtacy02 View Post
    When you say Pandora you mean the main site or my plugin? Are you connecting through a proxy?

    If referring to my plugin, how are you inputting your password. You must enter your password through the plugin manager settings button, passwords are encrypted.
    I have an issue with your plugin only and use a proxy because i live in France !

  2. #22
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,166
    Blog Entries
    52
    Quote Originally Posted by pierrotm777 View Post
    I have an issue with your plugin only and use a proxy because i live in France !
    ok, thats half of what i asked. Help me help you, answer the rest.

    And share your debug, what message are you getting
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  3. #23
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,166
    Blog Entries
    52
    Name:  RRPandoraeLite.jpg
Views: 361
Size:  417.4 KB

    -Elite skin created.
    -Also created (correct) labels for track length, track length, and slider
    -Fixed bug where music would skip between tracks

    Uploading tomorrow!
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  4. #24
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,700
    Blog Entries
    1
    The plugin is working 90% for me. Entering user /pass on plugins setting screen worked well, all my stations list correctly, I can add a new station, all playback is working perfectly. The 10% that is not working for me are the tags. I am using the included default CW Dynamic Lite skin. I am not sure what other plugin that could be messing with it, as none of the ones I have installed currently do anything with the tags.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  5. #25
    Raw Wave pierrotm777's Avatar
    Join Date
    May 2008
    Location
    Bordeaux, France
    Posts
    2,846
    Quote Originally Posted by Sonicxtacy02 View Post
    ok, thats half of what i asked. Help me help you, answer the rest.

    And share your debug, what message are you getting
    I use as proxy:HotSpot Shield v2.24- http://anchorfree.com.
    The debug file return me:
    26/02/2012 16:04:45
    Debug mode setting found. Debug set to True

    26/02/2012 16:04:45
    Username setting found. Username set to [email protected]

    26/02/2012 16:04:45
    Error during password decryption. - Longueur non valide pour un tableau de caractères Base 64.

    26/02/2012 16:04:45
    ResumeLastPlayed setting found. ResumeLastPlayed is False

    26/02/2012 16:04:45
    Last Station ID setting found. LastStationID is

    26/02/2012 16:04:45
    Settings Loaded

    26/02/2012 16:04:45
    Pandora audio format set

    26/02/2012 16:04:45
    Authorization handler initiated

    26/02/2012 16:04:45
    Connection handler initiated

    26/02/2012 16:04:45
    album client handler initiated

    26/02/2012 16:04:45
    Image handler initiated

    26/02/2012 16:04:45
    Status timer initiated

    26/02/2012 16:04:46
    ONLINE Command executed

    26/02/2012 16:04:52
    ONSOURCECHANGE Command executed

    26/02/2012 16:05:26
    RRPANDORA command executed

    26/02/2012 16:05:27
    Authorization worker started

    26/02/2012 16:05:27
    ONSOURCECHANGE Command executed

    26/02/2012 16:05:28
    Attempting to login with saved credentials...

    26/02/2012 16:05:40
    RRPANDORA command executed

    26/02/2012 16:05:40
    Authorization worker started

    26/02/2012 16:05:41
    Attempting to login with saved credentials...

    26/02/2012 16:06:16
    RRPANDORA command executed

    26/02/2012 16:06:16
    Authorization worker started

    26/02/2012 16:06:17
    Attempting to login with saved credentials...
    An when i use the RR command RRPandora, i have an error screen with:
    Error During Login, An Error occured during login. Please check your credentials !

  6. #26
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,166
    Blog Entries
    52
    Quote Originally Posted by JohnWPB View Post
    The plugin is working 90% for me. Entering user /pass on plugins setting screen worked well, all my stations list correctly, I can add a new station, all playback is working perfectly. The 10% that is not working for me are the tags. I am using the included default CW Dynamic Lite skin. I am not sure what other plugin that could be messing with it, as none of the ones I have installed currently do anything with the tags.
    Do you currently have an older version of RRShoutcast installed? It could be messing with the labels. The latest version has fixed this issue. If not then i dunno what the problem could be. My tag label code is basically pulled right out of mitch's webradio plugin so they should be working.

    Quote Originally Posted by pierrotm777 View Post
    I use as proxy:HotSpot Shield v2.24- http://anchorfree.com.
    The debug file return me:

    An when i use the RR command RRPandora, i have an error screen with:
    Error During Login, An Error occured during login. Please check your credentials !
    The problem is your username or password for pandora uses a character or set of characters that cannot be encrypted/decrypted by the method i'm using. There's really no way around this aside from changing your pandora password.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  7. #27
    Raw Wave pierrotm777's Avatar
    Join Date
    May 2008
    Location
    Bordeaux, France
    Posts
    2,846
    Quote Originally Posted by Sonicxtacy02 View Post
    The problem is your username or password for pandora uses a character or set of characters that cannot be encrypted/decrypted by the method i'm using. There's really no way around this aside from changing your pandora password.
    What do i must to change:
    my login is [email protected] and my password has 6 normal letters

  8. #28
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,700
    Blog Entries
    1
    Quote Originally Posted by Sonicxtacy02 View Post
    Do you currently have an older version of RRShoutcast installed?
    That was the problem! I had installed your Shout Cast plugin (.dll is Dated Feb 12th) and it prevented the labels and album artwork from working in this plugin. (Even though I am using the latest version of the Pandora plugin from a day or so ago)

    Do you have a skin or code to share for the new additions, slider, track time ect? I tried the standard CURRENTTRACKTIME and TRACKTIME as well as RRPANDORATRACKTIME and RRPANDORACURRENTTRACKTIME


    I really... REALLY like this plugin! I just pray that Pandora does not go changing how they to their XML or what you are using to interface with them!

    So many hours of work goes into something, and the company changes something... my Twitter plugin comes to mind, your MovieShowTimes plugin, Weather Channel weather ect ect....
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  9. #29
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,166
    Blog Entries
    52
    The plugin uses an MD5 based algorhythm for encryption. Your password must break down to a base 64 string. One of the password characters is failing this test, causing an encryption error (the error you see in your debug).

    Quote Originally Posted by JohnWPB View Post
    That was the problem! I had installed your Shout Cast plugin (.dll is Dated Feb 12th) and it prevented the labels and album artwork from working in this plugin. (Even though I am using the latest version of the Pandora plugin from a day or so ago)

    Do you have a skin or code to share for the new additions, slider, track time ect? I tried the standard CURRENTTRACKTIME and TRACKTIME as well as RRPANDORATRACKTIME and RRPANDORACURRENTTRACKTIME


    I really... REALLY like this plugin! I just pray that Pandora does not go changing how they to their XML or what you are using to interface with them!

    So many hours of work goes into something, and the company changes something... my Twitter plugin comes to mind, your MovieShowTimes plugin, Weather Channel weather ect ect....
    Yea the problem was in RRShoutcast code not this plugin. Latest version of RRShoutcast has the label code fixed.

    The slider and time codes aren't in the current public build, but the "default" rr labels for time will work fine. I'm current trying to tweak the time labels. Pandora provides the total length of the song, but its TOO long, and as a result there's anywhere from 10-30 seconds of dead air for each song after it plays. No idea why its like that, i guess they must be estimating the song time based on the bits in the file, buts its clearly not accurate.

    Whether or nor pandora changes its API is out of my hands. The beauty of this plugin is that all of the pandora connection handling is done by a referenced dll file, and that reference is managed by a group of people that seem to know how to handle the changes as they come.

    I'm also debating whether to ditch DirectShow in favor of winamp, just like RRShoutcast. I'm willing to listen to peoples preference here, but in my car DirectShow volume is too low. That and the fact i have no EQ makes me lean towards winamp. Preferences?

    The build i'm currently running will be available later today. It completely fixes the issue with songs skipping at the conclusion of last song played, but you'll have to (temporarily) deal with the dead air at the conclusion of each song to prevent going against your skip count.


    Oh yea, this plugin will soon have a home on codeplex, as it is a part of the licensing requirement to be open source
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  10. #30
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,166
    Blog Entries
    52
    And just that fast i've made an "executive decision" to use winamp for playback. Using winamp fixes:

    -Problem with songs skipping after first song play through
    -Problem being able to rate first song playing
    -Adds Volume and EQ control
    -Fixes Song Length, Song Position accuracy and eliminates dead air on track end

    Just makes more sense this way
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

Similar Threads

  1. How is this car called in the U.S. ?
    By kraft in forum Off Topic
    Replies: 10
    Last Post: 12-30-2010, 12:51 AM
  2. HAHAHA busted for the cable for the XM thing you guys worked SOOO hard on
    By jimmythecow in forum General Hardware Discussion
    Replies: 6
    Last Post: 10-15-2004, 11:53 AM
  3. Replies: 1
    Last Post: 02-19-2003, 08:29 AM
  4. What do you guys thing of this screen....
    By Mwilhelm100 in forum LCD/Display
    Replies: 4
    Last Post: 07-09-2002, 06:18 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •