Page 4 of 6 FirstFirst 123456 LastLast
Results 31 to 40 of 60

Thread: PowerMon plugin - for laptop carpcs

  1. #31
    Newbie
    Join Date
    Aug 2008
    Posts
    6
    Hey all. I got road runner installed finally, and am working on the power gauge.

    I have barely a clue what I'm doing, but with forums and small alterations in code I learned quickly.

    I got rid of the Rotating Honda logo in the skin, and replaced it with the power monitor. Works wonderfully.

    But I can't for the life of me get the battery gauge images to work.

    As it's on another computer, I'll spare you all the code for everything else. This is the code for the images:

    Code:
    I,367,300,35,19,"POWERMON_GBATTLEVEL"
    I loaded the most recent updated version (the user-provided altered v0.3) using the "Run -> regsvr32 powermon.dll" function. My skin is the default BMV2

    I have version 0.3, and the have put all the files just about everywhere I can think of. All of them are still here. The latest files (the image folder and powermon.dll or whatever) are in the following locations. The image folder is in each four times, once as \images, once as \image, once as pm_image, and once as pm_images. I figured I'd cover all my bases.

    C:\WINDOWS\system\

    C:\Program Files\RoadRunner\

    C:\Program Files\RoadRunner\powermon\

    Still no dice.

    Any help? Don't neglect to mention the simplest of simple things, too. It's likely to be the problem.

  2. #32
    The Last Good Gremlin GizmoQ's Avatar
    Join Date
    Nov 2004
    Location
    St Louis
    Posts
    2,348
    Quote Originally Posted by Kurt_ View Post
    Hey all. I got road runner installed finally, and am working on the power gauge.

    I loaded the most recent updated version (the user-provided altered v0.3) using the "Run -> regsvr32 powermon.dll" function. My skin is the default BMV2

    I have version 0.3, and the have put all the files just about everywhere I can think of. All of them are still here. The latest files (the image folder and powermon.dll or whatever) are in the following locations. The image folder is in each four times, once as \images, once as \image, once as pm_image, and once as pm_images. I figured I'd cover all my bases.

    C:\WINDOWS\system\

    C:\Program Files\RoadRunner\

    C:\Program Files\RoadRunner\powermon\

    Still no dice.

    Any help? Don't neglect to mention the simplest of simple things, too. It's likely to be the problem.
    O.K. Let's attack this systematically.


    1. Unregister your current powermon.dll:
    C:\windows\system32\regsvr32 /u powermon.dll

    2. Move the powermon directory to:
    C:\Program Files\Road Runner\Plugins\Powermon

    3. Delete all other copies of the powermon and pm_images directories or whatever else you may have named them.

    4. Register the dll using the "register.bat" batch file.

    5. Move the "pm_images" folder from beneath the powermon directory to the skin directory:
    C:\Program Files\Road Runner\Skins\bmv2\pm_images

    6. Restart RR.

    DONE.
    HARDWARE: Fujitsu Stylistic ST5111w/WiFi and dock, internal Hitachi 500G HD, external 1TB HD, Sierra Wireless Aircard 550, DVD-RW, BoomzBox HD radio, XM Commander, Delorme GPS, Saitek X-52 Pro joystick, BluSoleil Bluetooth, TPMS, FB, Elm327

  3. #33
    Low Bitrate festy's Avatar
    Join Date
    Jun 2006
    Location
    Sydney, OZ
    Posts
    109
    Not sure what the pm_images directory is for, but powermon_gbattlevel looks for images in two directories, both relative to the dll's path:
    .\images\slider_*.gif, and
    .\images\ext\slider_*.gif

    The first directory is images to display when on battery power, the second to show while on external (AC) power.

    If you put powermon.dll in say c:\roadrunner\plugins\powermon, the image directories should be c:\roadrunner\plugins\powermon\images\ and c:\roadrunner\plugins\powermon\images\ext\

    Probably best to make sure you only have 1 copy of powermon.dll on your system too.

    Edit - ok I see Sal R mad a change to the image path to skin\pm_images, not sure I agree with that.
    If you left it as app.path + \images then it's relative to the dll's location, not skin dependent.

  4. #34
    The Last Good Gremlin GizmoQ's Avatar
    Join Date
    Nov 2004
    Location
    St Louis
    Posts
    2,348
    Quote Originally Posted by festy View Post
    Not sure what the pm_images directory is for, but powermon_gbattlevel looks for images in two directories, both relative to the dll's path:
    .\images\slider_*.gif, and
    .\images\ext\slider_*.gif

    The first directory is images to display when on battery power, the second to show while on external (AC) power.

    If you put powermon.dll in say c:\roadrunner\plugins\powermon, the image directories should be c:\roadrunner\plugins\powermon\images\ and c:\roadrunner\plugins\powermon\images\ext\

    Probably best to make sure you only have 1 copy of powermon.dll on your system too.
    Sal R's version changed all that.
    HARDWARE: Fujitsu Stylistic ST5111w/WiFi and dock, internal Hitachi 500G HD, external 1TB HD, Sierra Wireless Aircard 550, DVD-RW, BoomzBox HD radio, XM Commander, Delorme GPS, Saitek X-52 Pro joystick, BluSoleil Bluetooth, TPMS, FB, Elm327

  5. #35
    Newbie
    Join Date
    Aug 2008
    Posts
    6
    Got it! I did everything both of you told me to do. In the end, switching from Sal's version back to the original v0.3 made it work, even though I had pm_images in the right place.

    One small problem though. I'm at 81% and I'm showing a full green battery. When I plug the laptop in, I get the charging icon, also over a full battery.

    The numerical gauge is correct, as is the state.

    EDIT: Nevermind, silly mistake. I now notice the gauges are pretty basic, I'll have to fix that.

    Thanks so much for the help and the plugin and such. I'm sure you'll hear more from me in the summer when I'll have the actual parts to turn this into a car pc. Right now it's just a laptop with a gps receiver hooked up to an inverter.

  6. #36
    Low Bitrate festy's Avatar
    Join Date
    Jun 2006
    Location
    Sydney, OZ
    Posts
    109
    Not sure what images you're using, but the example ones that come with powermon will show full from 80% onwards, I could only be bothered making 4 different images

  7. #37
    Low Bitrate festy's Avatar
    Join Date
    Jun 2006
    Location
    Sydney, OZ
    Posts
    109
    I think I've come up with a good compromise for image paths.
    I can see Sal R's point on having the images within the skin's dir, so what I've done is made the plugin check for a $skinpath\pm_images directory, if that doesn't exist then use the plugin's path\images.

    Note - this is not $rrpath\images, it's the directory that the plugin is in (usually something like $rrpath\plugins\powermon\images)

    New version is in first post.

  8. #38
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    Quote Originally Posted by festy View Post
    I think I've come up with a good compromise for image paths.
    I can see Sal R's point on having the images within the skin's dir, so what I've done is made the plugin check for a $skinpath\pm_images directory, if that doesn't exist then use the plugin's path\images.

    Note - this is not $rrpath\images, it's the directory that the plugin is in (usually something like $rrpath\plugins\powermon\images)

    New version is in first post.
    Cool.

    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  9. #39
    Constant Bitrate
    Join Date
    Mar 2008
    Posts
    133
    m4 atx work?
    RUSSIA - WINER!!!

  10. #40
    Constant Bitrate Startingline13's Avatar
    Join Date
    Nov 2007
    Location
    Long Island, NY
    Posts
    155
    I'm sorry, not to sound like a n00b or like I want free hand outs and stuff, but how do I install this? Or could you direct me to a place where I could learn to install road runner plugins? I get a bit confused on the whole registering a dll part.

Page 4 of 6 FirstFirst 123456 LastLast

Similar Threads

  1. Garo's Extra POI Plugin 1.0 beta 1
    By garo in forum Map Monkey
    Replies: 63
    Last Post: 01-18-2007, 01:32 PM
  2. XMLTraffic Plugin
    By 307SW_NLD in forum RR Plugins
    Replies: 20
    Last Post: 09-14-2006, 06:20 PM
  3. Hello World plugin
    By paulpv in forum CF Plugins
    Replies: 5
    Last Post: 06-08-2006, 11:07 PM
  4. How do I use the Base plugin sources ?
    By guino in forum RR FAQ
    Replies: 1
    Last Post: 04-24-2006, 04:43 PM
  5. Winamp LCD display plugin / IRMan plugin - together?
    By Jarrod in forum Software & Software Development
    Replies: 9
    Last Post: 06-03-2002, 06:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •