Page 10 of 25 FirstFirst 1234567891011121314151617181920 ... LastLast
Results 91 to 100 of 246

Thread: Milage plugin - trip meter and fuel consumption

  1. #91
    Variable Bitrate
    Join Date
    Mar 2005
    Location
    Sweden/Vaxjo
    Posts
    418
    Quote Originally Posted by festy View Post
    Even though a dozen or so decimal places are stored in the ini, only 2 are displayed in the labels. This can be overridden by creating a milage.ini in the plugin's dir, with the line 'decimalplaces=1' for 1 decimal place etc.

    I can change it so only 2dp are saved to the ini, i don't suppose much accuracy is gained by having any more than that, but I'm not sure that's the problem.

    After deleting your tripmeter.ini file and starting, do all meters show 0?
    I think what you were saying was that they did show 0, then you drove 29km, stopped RR and restarted - and that's when the numbers all went wrong?
    Was there a tripmeter.bak file created in the plugin's dir?
    Ok... so my second guess was wrong... So, lets see if I can give you some answers...
    I deleted all the files in the milage folder I have, registered the dll, started RR and they all showed 0. when I got to work I shut down RR, disconnected the laptop and went into my office (I havn't had the money for a TS yet... ), started RR again and when I went to the Tripmeter screen it looked like that screenshot... I reseted everything tonight when I was heading home but it's still the same...

    and yup, I have a tripmeter.bak that contains:
    Code:
    29|3966763549631
    0
    exactly the same as my tripmeter.ini... I'm getting real confused by all this...

    hmm... I just tried something... I deleted the last bunch of numbers in my ini file so it looked like this:
    Code:
    29|39
    0
    and now my tripmeter screen looks like this instead:

    if I was confused a minute ago it's nothing compared to now...
    Swedish site for CarPC's
    http://www.bilpc.info

  2. #92
    Low Bitrate festy's Avatar
    Join Date
    Jun 2006
    Location
    Sydney, OZ
    Posts
    109
    So how do I get my laptop to use commas in place of periods like yours? It would make testing a whole lot easier.

    Here's a new version, this one reads the 'decimalchar' line from milage.ini to work out if it should be doing commas or periods.
    There has to be a better way to do it than this, but just see if this works.
    Attached Files Attached Files

  3. #93
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Here is another FYI...

    I'm still just testing this out(GREAT plugin BTW!), and just now notice something strange...

    Drove home from school and pulled into the garage and compared the milage car/comp and was comp was slightly off(np), but then while I was just sitting there at a dead stop and no sats b/c I'm in the garage, the milage continued to very slowly creap. Like .01 of a mile every like 2 mins or so..

    Figure that one out??

    Now seeing this, I would think that over say the course of a tank of gas and stitting in a traffic jam or lights day to day would continue to rack up a small extra amount of ghostly miles...

    ps I was using the not the very latest but the second latest dll file..
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  4. #94
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Quote Originally Posted by festy View Post
    So how do I get my laptop to use commas in place of periods like yours? It would make testing a whole lot easier.
    Start menu>control pannel>regional and language setting and change it to like dutch or which ever countries show that they use the comma inplace of a period.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  5. #95
    Low Bitrate festy's Avatar
    Join Date
    Jun 2006
    Location
    Sydney, OZ
    Posts
    109
    Thanks, I was trying changing language or something before, which wasn't working too well.
    I thought I had something in the code to stop the small distance increments from position creep, obviously not, I'll fix that up.

  6. #96
    Variable Bitrate
    Join Date
    Mar 2005
    Location
    Sweden/Vaxjo
    Posts
    418
    Quote Originally Posted by festy View Post
    So how do I get my laptop to use commas in place of periods like yours? It would make testing a whole lot easier.

    Here's a new version, this one reads the 'decimalchar' line from milage.ini to work out if it should be doing commas or periods.
    There has to be a better way to do it than this, but just see if this works.
    Guess what... it works... /cheer
    I even changed the number of decimals to 2 and 3 and it still worked out great, I took it for a spin this morning and everything worked like a charm. sorry for bugging you so much with this,
    Swedish site for CarPC's
    http://www.bilpc.info

  7. #97
    Low Bitrate festy's Avatar
    Join Date
    Jun 2006
    Location
    Sydney, OZ
    Posts
    109
    Glad to hear we got there in the end

  8. #98
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    One more small idea...

    If it could update the tripmeter.ini at some set interval like 30secs or whatever, so that if something goes wrong in RR and we have to kill it, it wouldn't loose the current milage counts. Had this happen on the way to work, as it only saves the data on a clean exit.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  9. #99
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,168
    Blog Entries
    51
    thats more than a small idea... its a must. if rr crashes or the computer is shut down with rr still open none of the data gets saved. I've had this happen twice.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  10. #100
    Low Bitrate festy's Avatar
    Join Date
    Jun 2006
    Location
    Sydney, OZ
    Posts
    109
    New dll in post #1 implements this and a few other things.

Similar Threads

  1. A Working RR Trip Meter
    By ashgrovered in forum RR Plugins No Longer Supported
    Replies: 42
    Last Post: 01-06-2007, 12:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •