Page 20 of 23 FirstFirst ... 1011121314151617181920212223 LastLast
Results 191 to 200 of 225

Thread: Velleman K8055 USB I/O Board Extension plugin

  1. #191
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    That would confirm that something is needed in the class initizialition. You shouldn't need to go to the plug-in's screen in order to get it started....

    Hmmm....sounds fishy..
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  2. #192
    Variable Bitrate 307SW_NLD's Avatar
    Join Date
    Apr 2005
    Location
    The Netherlands
    Posts
    235
    What did you have in the menu.skin besides X,RRK8055? Are you only using the menu command functionality of the board. In that case I can see that I probably need to change something. Normally I would not initialize the board unless it is going to be used in a skin.
    My car: 2009 MAZDA CX-9 3.7L V6 runnin on LPG (Liquid Petrol Gas)
    Hardware: None at the moment
    Software: None at the moment
    See: Velleman K8055 Plugin for Road Runner

    Progress: [XXXXXXXXXX] 0 % DONE

  3. #193
    Newbie
    Join Date
    Apr 2007
    Posts
    5
    Quote Originally Posted by 307SW_NLD View Post
    What did you have in the menu.skin besides X,RRK8055? Are you only using the menu command functionality of the board. In that case I can see that I probably need to change something. Normally I would not initialize the board unless it is going to be used in a skin.
    1. I am using the BMV2 skin (don't know author) and, other than changing B06 to call Relays.skin and adding the X,RRK8055, there are no other changes.

    2. relays.skin is unchanged from the sample configuration

    The documentation regarding plugins recommends loading them in menu.skin and I would expect initialisation here as well. If, for example, one is using the I/O board for steering wheel controls for audio, there are several skins that use this and should not require using them in a particular order to initialise the dll.

    Thanks for the good work on this

  4. #194
    Newbie
    Join Date
    Apr 2007
    Posts
    5
    Another issue that you may be able to assist with.

    I have my steering wheel controls working in all skins (via RRK8055.ini) other than Tripmeter.skin, the only difference I can see being that this skin is called through a specific LOAD command rather than being a built-in RR command (such as 'GPS ' and 'AUDIO').

    I am attempting to use the 'mode' button on my steering wheel controls to cycle through functions in RR (Menu -> audio player -> GPS -> tripmeter -> audio -> GPS -> etc as well as the normal volume and NEXT/PREV functions. However, all works fine until I get to the tripmeter skin and all of the controls fail to work.

    I have added a section to RRK8055.ini titled "TRIPMETER.SKIN" - is there anything in RR that works differently for a LOADed skin compared to the loading via the built-in commands??

  5. #195
    Variable Bitrate
    Join Date
    Nov 2006
    Location
    Romania
    Posts
    298
    Getting back after few months. Please forgive me, can you remind me what should i download for my board? What are the latest skin/dll files to get?
    My second Subaru skin
    Full screenshots second skin
    My car photos

    CarPC Progress
    ■■■■■■■ - 75%

  6. #196
    Newbie
    Join Date
    May 2008
    Posts
    1
    Hi!
    I'm a french student, and i work on the K8055 card.
    I recuperate the programm libk8055 to advance my project.

    But i have a problem, i can't control multi card with your program.
    For explain, when i use the adress 0 (SK5 ON an SK6 ON), there is no probleme, the communication is ON when i put ipid=0.
    But when i use another adress (for exemple adress 1, SK5 OFF, SK6 ON) i can't communicate with the card, and i have this error :

    Velleman Device Found @ Address 010 Vendor 0x010cf Product ID 0x05501
    get driver name: could not get bound driver: No data available
    Found interface 0
    Took over the device
    Read retry
    Read retry
    Read retry
    Write retry
    Read retry
    Read retry
    Read retry
    Write retry
    Read retry
    Read retry
    Read retry
    Write retry
    Could not open the k8055 (port:1)
    Please ensure that the device is correctly connected.


    So i don't know what is the problem.. If you want, i can drop you my program.
    I really need your help because i am lost....
    Thank you very much.

    Jeremy Gaillard, From south of FRANCE.

  7. #197
    Newbie
    Join Date
    Sep 2008
    Posts
    4
    i can't download the plugin.......

  8. #198
    Low Bitrate
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    84
    Hi.

    the Plugin works nearly perfect. Indicators & Output-Buttons perfect.

    But, i cannot use the Digital Inputs for Commands.

    I have one Digital Input, when that goes ON, the PC should go in Hibernate, in all Screens.
    But this doesnt function in RR.

    To test I push the Buttons on the USB Board and use other Commands, like Play/next/prev. They all have no function.
    The Indicator in Screen "k8055_di_bit_5" function perfect!

    Can you help me?

  9. #199
    Variable Bitrate 307SW_NLD's Avatar
    Join Date
    Apr 2005
    Location
    The Netherlands
    Posts
    235
    Please make sure the x,rrk8055 is in your main start screen. This should load the plugin from the main menu and the commands should be availeble. Come to think of it, you will also need the k8055_menu indicator on the screens where you should be able to reveice commands.

    Hope this helps
    My car: 2009 MAZDA CX-9 3.7L V6 runnin on LPG (Liquid Petrol Gas)
    Hardware: None at the moment
    Software: None at the moment
    See: Velleman K8055 Plugin for Road Runner

    Progress: [XXXXXXXXXX] 0 % DONE

  10. #200
    Low Bitrate
    Join Date
    Jun 2005
    Location
    Dresden, Germany
    Posts
    73
    Works the plugin also with the new Ride Runner Version, instead of Road Runner?

Similar Threads

  1. Replies: 10
    Last Post: 08-22-2008, 06:36 PM
  2. i think i burn my USB controller board
    By susuking in forum LCD/Display
    Replies: 0
    Last Post: 01-26-2006, 12:55 PM
  3. USB Control Board component burned
    By carfreak01 in forum LCD/Display
    Replies: 4
    Last Post: 08-24-2005, 03:43 PM
  4. Lilliput USB Circuit Board...
    By gleinz in forum LCD/Display
    Replies: 1
    Last Post: 01-18-2005, 05:09 PM
  5. Replies: 4
    Last Post: 04-06-2004, 10:52 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •