View Poll Results: While Using the DFX skin, do you use the RRMedia database for your music?

Voters
97. You may not vote on this poll
  • Yes, I use it as the primary music browser

    75 77.32%
  • No, I use the standard folder browser

    22 22.68%

Thread: DFX 5.1.2 Released [ Updated 04-02-12 ]

  1. #2101
    Newbie
    Join Date
    Apr 2012
    Location
    Fredonia, NY
    Posts
    3

    Semi-exoerienced noob

    .Hey there, all. First off, I love this site. I've been messing around with this stuff for a while, on and off, and as long as my wife doesn't kill me, shall continue to do so. I am having a problem with dfx 5.1. I've had it working fine before but now, when I start it and click on a menu, it freezes. I can't seem to figure this out. I have winamp 5.13, all win7 updates, and june 2010 dist for directx. What am I missing? I've searched but to no avail. Please help!
    Last edited by a1dznr; 04-26-2012 at 08:13 PM.

  2. #2102
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    Quote Originally Posted by pierrotm777 View Post
    About my post #2087, i have added these two lines into my exectbl.ini file and my RR Exit is now easier !

    just noticting this... killing winamp is a bad idea... let RR close it... if its hanging, solve the problem
    dont kill the task...
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  3. #2103
    Low Bitrate
    Join Date
    May 2009
    Location
    Ladispoli, ROMA
    Posts
    73
    HellÚ, I have a little problem, I can't open any GPS program from MENU_1 but if I open Music and gps all is ok, can someone tell me why?
    thank-you

  4. #2104
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Quote Originally Posted by mitchjs View Post
    just noticting this... killing winamp is a bad idea... let RR close it... if its hanging, solve the problem
    dont kill the task...
    Your forgetting that a bigger delay was added to this, for those times when RR can't/won't/don't close winamp

    Current operation of this is:

    First it waits 5 secs, attempts to tell winamp to close (same way like RR) if its still running , waits 2.4 secs, rechecks if its still open, then if still open, then terminates its process
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  5. #2105
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Quote Originally Posted by a1dznr View Post
    .Hey there, all. First off, I love this site. I've been messing around with this stuff for a while, on and off, and as long as my wife doesn't kill me, shall continue to do so. I am having a problem with dfx 5.1. I've had it working fine before but now, when I start it and click on a menu, it freezes. I can't seem to figure this out. I have winamp 5.13, all win7 updates, and june 2010 dist for directx. What am I missing? I've searched but to no avail. Please help!
    First, before anyone else tells you...update winamp to current, we are no longer saying to only use 5.13. I'll follow that up with turn on RR's debug and look at the log and/or attach here to help narrow the issue down as your "click on a menu, it freezes" is a bit vague when dealing with such a complex skin.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  6. #2106
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Quote Originally Posted by Ba11s Deep View Post
    I have attached a zip of the debug files for both rr and rrmedia. thanks for any assistance you can provide.
    Couple of fixes,

    In your RR\plugins\RRmedia folder open up the storepath.ini and remove that trailing backslash. Not causing any harm but not correct either.

    With RR closed, go to the storepath\cache location, and delete any non *.cache files. Startup RR, goto the browser, check if you now have a _db.txt in your cache folder, which should match the foldercache.cache file.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  7. #2107
    Variable Bitrate navputer's Avatar
    Join Date
    Jan 2007
    Location
    DFW Area
    Posts
    301

    Music Not Showing/Resuming after Always or Start/Hibernation setting

    I am having a problem with DFX5 with the music resuming. After starting RR from cold boot or hibernation, go to to start DFX5, get to the main menu screen, the music does not show or resume the last playlist/song. I have to hit the Music icon to go the audio player so it can start playing (and it always start from beginning). I have selected in rrconfig Resume "always" and "start/hibernation". It does the same thing for both. I also have renamed resume.ini to create a new one but it does the same thing.

    Any ideas of what I am doing wrong? I had this working fine before.

    DFX 5 (latest updates from skin)
    Winamp 5.601
    RR April

    I am attaching the debug file as well.
    Attached Files Attached Files
    Gee

  8. #2108
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    well.. after you RESUME AT

    4/28/2012 1:32:23 PM: ResumeFromHibernate: (start)

    4/28/2012 1:32:27 PM: INFO: CheckResume() - ResumeMusic=1 WasRadio=0
    4/28/2012 1:32:27 PM: INFO: LoadResume() - Reading resume data from C:\Program Files\RideRunner\resume.ini
    4/28/2012 1:32:27 PM: AudPlayerStart: music player: PLPosition=0 TrackPosition=51628
    4/28/2012 1:32:27 PM: AudPlayerStart: player volume be 0: 0
    4/28/2012 1:32:27 PM: AudPlayerStart: player should be playing: PLAYING
    4/28/2012 1:32:27 PM: Enter Exec: False, exit_menu.skin, , False
    4/28/2012 1:32:27 PM: Que Exec: True, exit_menu.skin, "OFFLINE", False
    4/28/2012 1:32:27 PM: Leave Exec: False, exit_menu.skin, OFFLINE, False
    4/28/2012 1:32:27 PM: AudPlayerStart: Player.GetTrackLength: 348000
    4/28/2012 1:32:27 PM: AudPlayerStart: Player.SetTrackPosition: 51628
    4/28/2012 1:32:28 PM: INFO: CheckResume() - Resuming to music player: PLAYING


    sure looks like its playing...
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  9. #2109
    Newbie
    Join Date
    Nov 2010
    Posts
    40
    Quote Originally Posted by navputer View Post
    I am having a problem with DFX5 with the music resuming. After starting RR from cold boot or hibernation, go to to start DFX5, get to the main menu screen, the music does not show or resume the last playlist/song. I have to hit the Music icon to go the audio player so it can start playing (and it always start from beginning). I have selected in rrconfig Resume "always" and "start/hibernation". It does the same thing for both. I also have renamed resume.ini to create a new one but it does the same thing.

    Any ideas of what I am doing wrong? I had this working fine before.

    DFX 5 (latest updates from skin)
    Winamp 5.601
    RR April

    I am attaching the debug file as well.

    i have this problem too!!! i think when you click in the music, it do a "Refresh" and finally load playlist/last song, so you can play music normally again, but in the next hibernate resume, the same problem =/!!

    but its so normal for me now to click in music button to load the playlist, that i forgot to say this problem here!!

  10. #2110
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    from resume? or from fresh start?

    just look at you own debug.. its pretty easy to see what rr is told to do
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

Similar Threads

  1. Skype Plugin released
    By lambosprit in forum RR Released Plugins
    Replies: 157
    Last Post: 12-21-2010, 10:58 AM
  2. Teknik v2.0 - RELEASED
    By Valheru in forum RR Skins
    Replies: 0
    Last Post: 12-04-2007, 10:22 AM
  3. DFx skin + winamp 5.13
    By vicky_obee in forum Road Runner
    Replies: 1
    Last Post: 12-04-2007, 12:26 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •