Thread: LSX (VOID) released

  1. #1201
    Constant Bitrate deus ex machina's Avatar
    Join Date
    Mar 2006
    Posts
    136
    Here's the code to get the 'anti-status' ("Pause" when playing, "Play" when paused) on the play button. (You have to get the beta with a working eval;;strcomp() function for this to work.)

    LSX Void EXECTBL.ini
    Code:
    "ONSKINSTART","[otherstuff...]||SETUPANTISTATUS"
    
    "SETUPANTISTATUS","SETVARBYCODE;VSTATUS;STATUS||EVAL;B_ANTISTATUS;strcomp("PLAY";"$VSTATUS$")||BYVAR;B_ANTISTATUS;ISNTPLAYING<<ISPLAYING"
    
    "ISPLAYING","SETVAR;ANTISTATUS;PAUSE||SETVAR;STATUSSYM;;"
    "ISNTPLAYING","SETVAR;ANTISTATUS;PLAY||SETVAR;STATUSSYM;4"
    Any play buttons or other methods of changing the play status you might have ("play" must go before "setupantistatus"):
    Code:
    PLAY||SETUPANTISTATUS
    The webdings label on the play buttons:
    Code:
    "Webdings:B","=$STATUSSYM$"
    I only wish there was an "ONNEWCLICK" for when you select a different track without playing it, then we could change the play button to show "Play".

  2. #1202
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    NICE, i was actually looking for the older code for this the other day.

    here is a slightly revised version.

    EXECTBL.ini
    Code:
    /,ANTISTATUS
    "SETUPANTISTATUS","SETVARBYCODE;VSTATUS;STATUS||EVAL;B_ANTISTATUS;strcomp("PLAY";"$VSTATUS$")||BYVAR;B_ANTISTATUS;ISNTPLAYING<<ISPLAYING"
    
    "ISPLAYING","SETVAR;ANTISTATUS;PAUSE||SETVAR;STATUSSYM;;"
    "ISNTPLAYING","SETVAR;ANTISTATUS;PLAY||SETVAR;STATUSSYM;4"
    "PLAY","PLAY||SETUPANTISTATUS"
    "ONPLCLICK","SETVAR;ANTISTATUS;PAUSE||SETVAR;STATUSSYM;;"
    /ANTISTATUS END
    the changes are:
    I set "PLAY","PLAY||SETUPANTISTATUS"
    so i dont have to go into all the .skin files and change the code on the buttons.
    added, ONPLCLICK so if you pause music and then click on a song from the playlist it will change the status correctly.

    Im also creating my own font, i'll still use the dingbat fonts but ill prob change the font for this to my custom one so when RR starts up it doesn't show all the other characters (for a brief sec) before it sets the status.

    Think im going to ask guino to delay drawing the RR interface until the entire ExecTBL.ini file is processed. I think it isnt till 2sec after you first see the interface till the file is fully processed.
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/rr-faq/
    mp3car live search

    i have joost invites, just hit me up for one.

  3. #1203
    Constant Bitrate deus ex machina's Avatar
    Join Date
    Mar 2006
    Posts
    136
    Yeah, I thought of trying that just as I was falling asleep last night a few minutes after posting the code.

    Edit- This would probably make more sense too:
    Code:
    "SETUPANTISTATUS","SETVARBYCODE;VSTATUS;STATUS||EVAL;B_ANTISTATUS;strcomp("PLAY";"$VSTATUS$")||BYVAR;B_ANTISTATUS;DISPLAYPLAY<<DISPLAYPAUSE"
    
    "DISPLAYPAUSE","SETVAR;ANTISTATUS;PAUSE||SETVAR;STATUSSYM;;"
    "DISPLAYPLAY","SETVAR;ANTISTATUS;PLAY||SETVAR;STATUSSYM;4"
    "PLAY","PLAY||SETUPANTISTATUS"
    "ONPLCLICK","DISPLAYPAUSE"

  4. #1204
    Low Bitrate kireol's Avatar
    Join Date
    Oct 2006
    Location
    Royal Oak, MI
    Posts
    89
    So I went on a 3 hour trip this week. I played some movies and music and IGuidance. My passengers were blown away at all it does and how it looks.




    Here's some notes/questions:

    1)Is there a way to get the built in native GPS stuff to work with lsx (mph/heading/etc) while still letting iguidance work? I'm sure it's posted 20 million times but I wouldnt know what to search on other than iguidance.

    2)Sometimes winamp gets bugged. I havent really figured out why yet. mostly when I quit/reload RR. Then MP3s wont play. So i have to requit out of RR and force a quit on winamp (sometimes several copies are in memory). then it works fine. Any way to force a quit of winamp(s) that are running at startup? Just thoughts

    3)load an album. start listening. Load up navi. an hour later when the albums done, "close" navi and the album starts again where it left off when you first switched to navi, like a spawn or something. not a bug or broke, but a weird thing anyhow.

    4) bigger fonts for track names? more real estate for same? a way to pull out the artist name for the track names so it doesnt show/take up space?


    everything's working great, and i'm sure most of what I'm experiencing is things I need to play with/learn, but figured i'd just ask first

  5. #1205
    Maximum Bitrate tn6478's Avatar
    Join Date
    Jun 2006
    Location
    Houston, TX
    Posts
    791
    I tried your skin out today. All i get is audio labels. am i doing something wrong

  6. #1206
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    Quote Originally Posted by kireol View Post
    So I went on a 3 hour trip this week. I played some movies and music and IGuidance. My passengers were blown away at all it does and how it looks.




    Here's some notes/questions:

    1)Is there a way to get the built in native GPS stuff to work with lsx (mph/heading/etc) while still letting iguidance work? I'm sure it's posted 20 million times but I wouldnt know what to search on other than iguidance.

    2)Sometimes winamp gets bugged. I havent really figured out why yet. mostly when I quit/reload RR. Then MP3s wont play. So i have to requit out of RR and force a quit on winamp (sometimes several copies are in memory). then it works fine. Any way to force a quit of winamp(s) that are running at startup? Just thoughts

    3)load an album. start listening. Load up navi. an hour later when the albums done, "close" navi and the album starts again where it left off when you first switched to navi, like a spawn or something. not a bug or broke, but a weird thing anyhow.

    4) bigger fonts for track names? more real estate for same? a way to pull out the artist name for the track names so it doesnt show/take up space?


    everything's working great, and i'm sure most of what I'm experiencing is things I need to play with/learn, but figured i'd just ask first
    1.) you need a gps port splitter, so more than one application can access your gps port at the same time. Do a search for XPORT on this site.

    2.) You can try to add this line to rr.ini
    winampclass=<Winamp v1.x>
    ive seen this problem many times in the past, the problem is when you exit RR it maynot shutdown winamp, so next time to load it loads another copy.
    Also in winamp options there is a setting for only allowing one copy of winamp to be run.
    what version of winamp are you using, that makes a big difference too.

    3.) That is weird, ive never seen that happen. Could be related to #2

    4.)Track names are slightly bigger in the upcoming update.
    To remove artist name from the playlist, in RRConfig.exe you have to setup how you want that stuff to show.
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
    mp3car live search

    i have joost invites, just hit me up for one.

  7. #1207
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    Quote Originally Posted by tn6478 View Post
    I tried your skin out today. All i get is audio labels. am i doing something wrong
    you didn't follow the instructions during setup.
    start over.
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
    mp3car live search

    i have joost invites, just hit me up for one.

  8. #1208
    Variable Bitrate
    Join Date
    Apr 2004
    Location
    A Brit in Las Vegas
    Posts
    237
    I am really tearing my hair out with this skin and no-one else seems to have a problem.

    I installed LSX Void but regardless of what screen size setting I use I always lose the buttons along the bottom and screens like the gas screen are all screwed up. I tried setting it to default as well as 800*480 in rrconfig and also tried various other settings but none of them give me a clean display.

    Can anyone help or suggest?

    RV : Samsung Q1 + Kyocera KR1 (EVDO) + GPS<br>
    Car: AMD 3000+ Book PC + Lilliput 8" Touch + 13" TFT

    Webmaster for the European Ford Scorpio Site

  9. #1209
    Variable Bitrate
    Join Date
    Apr 2004
    Location
    A Brit in Las Vegas
    Posts
    237
    Don't worry - just found a weird line in the default General.ini - showheight=600

    Don't know why that's in the default setting

    RV : Samsung Q1 + Kyocera KR1 (EVDO) + GPS<br>
    Car: AMD 3000+ Book PC + Lilliput 8" Touch + 13" TFT

    Webmaster for the European Ford Scorpio Site

  10. #1210
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    Quote Originally Posted by SteveC View Post
    Don't worry - just found a weird line in the default General.ini - showheight=600

    Don't know why that's in the default setting
    thats the default because most people run 800x600 screen res inside there car.

    general.ini should look like this

    if you want 800x480

    OriginalWidth=800
    OriginalHeight=480
    ShowWidth=800
    ShowHeight=480

    if you want 800x600

    OriginalWidth=800
    OriginalHeight=480
    ShowWidth=800
    ShowHeight=600
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
    mp3car live search

    i have joost invites, just hit me up for one.

Similar Threads

  1. LSX....void
    By liquid_smoke in forum RR Skins
    Replies: 172
    Last Post: 05-06-2006, 05:59 PM
  2. LSX Scripts
    By Osiris in forum RR Skins
    Replies: 12
    Last Post: 01-14-2006, 10:13 PM
  3. QT 4 crossplatform released
    By s003apr in forum Software & Software Development
    Replies: 5
    Last Post: 07-02-2005, 03:41 PM
  4. Will molding a dash void a lilliput's warranty?
    By mykolJay in forum Fabrication
    Replies: 15
    Last Post: 06-29-2004, 08:48 PM
  5. Lorty's mp3car plugin 2.4.08 released
    By lorty in forum Software & Software Development
    Replies: 3
    Last Post: 01-19-2001, 09:47 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •