Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Help with directory list

  1. #1
    Newbie
    Join Date
    Feb 2008
    Location
    Dunedin, NZ
    Posts
    10

    Unhappy Help with directory list

    Hi guys, another long time reader, first time poster. I've just started on this whole CarPC business and I'm pretty green when it comes to skinning, so forgive me if the solution is obvious, but I can't seem to work it out!

    Ok I've looked at the Skin Commands.txt, searched this forum for help, tried a million things, and I still can't get this to work!! Basically what I want is a directory list that displays a folder with all my playlists in it. I thought this code should work but for some reason it doesnt.

    Code:
    Code:
    /, S, x, y, w, h, fore R;RGB, G, B,  back R;RGB, G, B,  folder R;RGB, G, B,  file R;RGB, G, B, selected R;RGB, G, B, select R;RGB, G, B, trs, font pt;FONT, font name
    S01,114,110,575,262,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,0,0,0,TRUE,12,"Verdana"
    
    /, SD, Alignment;Alignment, Disp;MODE, Icon Width, Icon Heigth, Path
    SD,01,00,50,50,"C:\Playlists","*.*",False
    Some of the SD stuff works (like the alignment) but the directory part doesnt. It just defaults to C:\.

    Help anyone?

  2. #2
    Variable Bitrate
    Join Date
    Jan 2007
    Location
    East Central FLA
    Posts
    241
    This might be stupid, but do have you checked the spelling between the skin and the directory name, i.e., skin has "Playlists", but the actual directory is "Playlist" or "Platlists" or other typo?

    And while I only use this sort of thing one place in the skins I've built, try instead of "*.*" use "*.m3u" (or whatever the extension is for your playlist files).

  3. #3
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    Try putting the back slash at the end.

    i.e.
    C:\Playlists\
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  4. #4
    Newbie
    Join Date
    Feb 2008
    Location
    Dunedin, NZ
    Posts
    10
    Nothing is stupid at this stage

    Thanks guys but there's definitely no typos and the backslash has no effect... I really hope I can get this to work!

  5. #5
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    Obvious question: Does the "Playlists" folder have files in it?

    EDIT: I just copied and pasted your code above into my skin file and it works just fine.
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  6. #6
    Newbie
    Join Date
    Feb 2008
    Location
    Dunedin, NZ
    Posts
    10
    Yep it has my playlists in it (.pls files). Could it be something to do with my RR config? Like the default directories or something? Because it's certainly not working on mine.

  7. #7
    Variable Bitrate
    Join Date
    Jan 2007
    Location
    East Central FLA
    Posts
    241
    1st, is the .pls format defined in the rr.ini file? It can be checked/set in the rrconfig program.

    Winamp is supposed to recognize .pls file structures, but I wonder if the older versions did as well.

    You should try the traditional .m3u format and see if that's the problem, in which case you will have to change the playlist files, or move to a newer version of winamp.

  8. #8
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    Quote Originally Posted by dannybolabo View Post
    Yep it has my playlists in it (.pls files). Could it be something to do with my RR config? Like the default directories or something? Because it's certainly not working on mine.
    I just tried it w/ a .pls file and it worked just fine.

    What version of Winamp and RR are you using?

    Why don't you post up your rr.ini and let's take a look at your settings...
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  9. #9
    Newbie
    Join Date
    Feb 2008
    Location
    Dunedin, NZ
    Posts
    10
    I tried using .m3u but didn't work. I don't think it's a problem with the actual playlist, because once i navigate to the directory they play fine, i'd just like the list to show my playlist directory by default.

    Ok here's my rr.ini:

    Code:
    [Player Setup]
    player=Winamp
    winamppath=C:\Program Files\Winamp\
    hidewinamp=true
    exitmute=true
    
    [General]
    voice=false
    disableinternat=false
    showicons=false
    showextensions=false
    hidemouse=false
    hidetaskbar=false
    hidedesktop=false
    hidedots=false
    gpstime=false
    exitmode=0
    dateformat=DD/MM/YYYY
    timeformat=HH:MM AM/PM
    locale=0
    screentype=16:9
    debugmode=false
    enableclipping=true
    nozoom=false
    usegestures=false
    leavemousealone=false
    closeapps=false
    fastmode=-1
    usedualmon=false
    soundcard=0
    screenlimit=10
    mastervolmap=0
    hibernateaware=true
    forcehibernate=false
    hibernatereload=true
    usbsound=false
    browsertype=0
    browserpath=C:\Program Files\Mozilla Firefox\firefox.exe
    usevoicecontrol=false
    usecar2pc=false
    fadeinvolume=true
    picspath=To set path, Click --->
    
    [Skins]
    skinpath=C:\Program Files\Road Runner\Skins\Minimal Reflection\
    nightskin=C:\Program Files\Road Runner\Skins\Minimal Reflection\
    transition=0
    background=To set path, Click --->
    TransitionTime=0.2
    
    [Gamma]
    gammamode=3
    gpsgammamodeoffset=0
    gammaday=0:0:0
    gammanight=-50:-50:-50
    gammadaytime=1:00
    gammanighttime=1:00
    autogammamode=1
    autoskinmode=1
    
    [Preload Screens]
    preload=audio_browser.skin;Loading
    preload=Audio_Player.skin;Loading
    preload=video_browser.skin;Loading
    preload=video_player.skin;Loading
    
    [Music]
    musicpath=
    playlistpath=C:\Program Files\Road Runner\skins\Minimal Reflection\playlists\play\
    useid3=0
    singleclickaudio=false
    noformat=false
    listnumbers=true
    listfollowssong=true
    id3listformat=%title%
    id3browseformat=%title%
    titlesafter=-
    coverfile=*.jpg
    albumart=*.txt
    fadeimages=true
    audiofiles=.mp3,.pls,.m3u
    visuname=MilkDrop
    scrollmode=1
    circularlist=false
    groupnumbers=false
    resumemusic=0
    audiorepeat=false
    audioshuffle=false
    transparentvisu=false
    opacityvisu=40
    
    [Radio]
    radiomode=0
    allowallfreqs=false
    radioline=0
    userbds=false
    
    [XM]
    xmport=0
    xmline=0
    xmlineinplugin=false
    xmtype=0
    singleclickxm=false
    xmformat=%station% %artist%
    
    [SIRIUS]
    srport=0
    srline=0
    srlineinplugin=false
    singleclicksr=false
    srformat=%station% %artist%
    
    [Video]
    videopath=C:\Users\Danny\Videos\
    mpcpath=C:\Program Files\Windows Media Player\wmplayer.exe
    videoautohide=true
    videohidetime=4
    builtinvideo=true
    videoshuffle=false
    
    [TV]
    tvline=0
    
    [GPS]
    mapmonkeypath=Click here to set path
    gpspath=Click here to set path
    gpsname=
    overspeed=55
    gpsport=0
    mappointmap=1
    mapcountry=United States
    mapcity=
    mapautozoom=true
    isunits=true
    usegpsserv=false
    gasfinderautorefresh=false
    
    [IG Native]
    
    [Speed Att Vol]
    speedatt=false
    
    [Phidget]
    phidget1=0
    phidget2=0
    phidget3=0
    phidget4=0
    phidget5=0
    phidget6=0
    phidget7=0
    phidget8=0
    
    [4 Temps]
    tcomport=0
    tempscale=c
    temp1=c
    temp2=c
    temp3=c
    temp4=c
    
    [Volt Meter]
    vcomport=
    
    [Phone]
    phoconodesign=false
    motophone=false
    phonelistspath=Click here to set path
    contactspicturespath=Click here to set path
    ringtone=Click here to set path
    smstone=Click here to set path
    maxcalllistentries=100
    phoconoincallevent=false
    connecthsp=true
    standardphonebook=0
    phonebooksencoding=windows-1252
    
    [Weather]
    cityweather=
    weatherunits=USA
    weatherdegress=
    localdatacaptureinterval=0
    
    [Extra's]
    There's probably a lot of stuff not configured right I haven't really looked much at it. Thanks for the help so far guys

  10. #10
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,618
    Quote Originally Posted by Sal R. View Post
    I just copied and pasted your code above into my skin file and it works just fine.




    can yopu post the whole .skin file this is in?

Page 1 of 2 12 LastLast

Similar Threads

  1. Alignment of the Directory List
    By liquid_smoke in forum RR Bug Tracker
    Replies: 6
    Last Post: 05-07-2006, 08:51 PM
  2. Replies: 4
    Last Post: 05-01-2006, 11:48 AM
  3. Newest Music list not updating properly
    By ninja0n3 in forum Media Engine
    Replies: 2
    Last Post: 04-28-2006, 02:12 PM
  4. Replies: 4
    Last Post: 02-24-2005, 05:35 PM
  5. problem with directory search
    By Farkum in forum FP Bug Reports
    Replies: 2
    Last Post: 02-16-2005, 04:48 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •