Results 1 to 8 of 8

Thread: DFX Button Editor Problems Discussion

  1. #1
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079

    DFX Button Editor Problems Discussion

    This is a thread to discuss and hopefully get the button editor working for all.

    First make sure that you are using the latest one, which has a window title of:
    "3.0/4.0 DFX Menu Button Editor by BlueZX3"

    #1 List which version of the skin 3.0 or 4.0.
    #2 Now describe what its either doing or not doing and when its doing it with any descriptions of any error messages.

    And possibly attach your "Exectbl.ini" file in your DFX folder to your post, do NOT copy/paste the file to your post please.

    We will get to the bottom of this!
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  2. #2
    Constant Bitrate Stealth915's Avatar
    Join Date
    Apr 2004
    Location
    Bay Area, CA
    Posts
    137
    I've noticed that when I change more than one button property at a time, it does not save correctly. Example: I click an unused button to edit, change the name to "Gas Prices" the command to "rrgas" and label to "Gas Prices", and click OK. It shows up with the new button name in the editor. I click "Save and Exit", and when I relaunch the button editor, the button shows up as "UnUsed" as if nothing was saved.

    However, if I change one button property at a time and "save and exit" between each change, it all works fine, for me at least. This is for DFX 4.0.
    2004 Mazda3 Carputer Worklog - Update 5/17/11: Carputer 2.0 Hardware Selection

  3. #3
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Will check and comfirm my results.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  4. #4
    Variable Bitrate
    Join Date
    Apr 2005
    Posts
    267
    How do you go about changing the button anyway? I dont see a dfxbutton editor.
    I just want to add my own pictures next to the buttons instead of what is there already.

  5. #5
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,707
    Blog Entries
    1
    When you press and hold a button, and have the choices, simply use the name you see on those buttons "GPS Gas" for instance. Just put a png named "GPS Gas.png" into the MenuIcons folder. It will then immediately show up as the icon on the main menu.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  6. #6
    Variable Bitrate
    Join Date
    Apr 2005
    Posts
    267
    Sweet got it.
    WTf, I just opened it and and I get a pic of your car with eyes like the guy from cars. I've had it set to the mitsu symbol forever and it just changes on it's own now. It won't change back.

  7. #7
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Quote Originally Posted by Stealth915 View Post
    I've noticed that when I change more than one button property at a time, it does not save correctly. Example: I click an unused button to edit, change the name to "Gas Prices" the command to "rrgas" and label to "Gas Prices", and click OK. It shows up with the new button name in the editor. I click "Save and Exit", and when I relaunch the button editor, the button shows up as "UnUsed" as if nothing was saved.

    However, if I change one button property at a time and "save and exit" between each change, it all works fine, for me at least. This is for DFX 4.0.
    Well, both doing and checking the code, I can not create this issue. By chance, after you change all three properties and save, have you looked in the exectbl file and see if any part of newly created button is getting saved?
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  8. #8
    Newbie
    Join Date
    Sep 2008
    Posts
    34
    OK, heres a thing.
    I found that when using the editor to create/edit a button for the Garmin Overlay specifically, i put the code in, apply it, save the changes.
    Then I go into the config files and the button script hasn't been updated ? I had to manually update the button def, and then it worked a treat.
    If it's my system being daft, so be it, wouldn't surprise me
    Just thought I'd let ya know.

Similar Threads

  1. Replies: 34
    Last Post: 11-06-2007, 02:42 PM
  2. Relocating computer power button
    By King_Xerxes in forum General Hardware Discussion
    Replies: 8
    Last Post: 02-21-2007, 09:15 PM
  3. Button request: Minimize
    By DaveB in forum Mobile Impact
    Replies: 17
    Last Post: 01-04-2007, 08:35 PM
  4. Replies: 2
    Last Post: 04-04-2005, 03:45 PM
  5. PC power button problem
    By BMp3W in forum Power Supplies
    Replies: 4
    Last Post: 10-12-2002, 02:36 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •