Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Adding an IMG to a button

  1. #1
    Maximum Bitrate kpjuk's Avatar
    Join Date
    Dec 2003
    Location
    West Midlands
    Posts
    474

    Adding an IMG to a button

    Hi guys, I want to remove the logo on the Black Vinyl on Aluminm skin, to make it more customisable, for others to add any Menu image they want. I have used the IMG tag, and the image appears where it should, but when I move the mouse over the button, the image disappears, and doesn't come back.

    So I tried to add the IMG to every layer, including the OUT layer, and the same thing happens! Is this a bug, or am I doing something crazy ?

    /, IMG, x, y, w, h, File Name, Option;IMGLAYER
    IMG01,700,530,90,60,"Menu.jpg","Out"
    IMG02,700,530,90,60,"Menu.jpg","Empty"
    IMG03,700,530,90,60,"Menu.jpg","Off"
    IMG04,700,530,90,60,"Menu.jpg","On"
    IMG05,700,530,90,60,"Menu.jpg","Down"

    KPJUK
    M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
    DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

  2. #2
    Maximum Bitrate
    Join Date
    Aug 2005
    Posts
    520
    LOL i just realized you are a skin maker and the creator of the "Black Vinyl on Aluminm skin", so my advice was stupid.

  3. #3
    FLAC
    Join Date
    May 2005
    Location
    Vienna, VA
    Posts
    1,375
    Try taking out the quotes on Out, On, Off, etc. like this.

    Code:
    /, IMG, x, y, w, h, File Name, Option;IMGLAYER
    IMG01,700,530,90,60,"Menu.jpg",OUT
    IMG03,700,530,90,60,"Menu.jpg",OFF
    IMG04,700,530,90,60,"Menu.jpg",ON
    IMG05,700,530,90,60,"Menu.jpg",DOWN

  4. #4
    Maximum Bitrate kpjuk's Avatar
    Join Date
    Dec 2003
    Location
    West Midlands
    Posts
    474
    Nice one B8bboi, the editor takes the quotes off the filename, but puts them on the layer name !

    I spotted the quotes were missing on the Filename and added them. This is a little inconsistent with all the other commands which generally have quotes around all parameters !

    Its working now so thanks m8.

    KPJUK
    M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
    DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

  5. #5
    FLAC djmickyg's Avatar
    Join Date
    Feb 2004
    Posts
    1,314
    bring back an old thread..

    im now tying to put a IMG ontop of a button.. i gather this is what u did here and you seemed to have gotton in

    this is what i have
    IMG,9,115,64,64,"icons\media.gif",OUT

    it wont show ontop of the button but if i more the box away from the button will show??

  6. #6
    Maximum Bitrate kpjuk's Avatar
    Join Date
    Dec 2003
    Location
    West Midlands
    Posts
    474
    Hi djmickeyg,

    You can output the image to 5 layers, OUT, EMPTY, OFF, ON, and DOWN. Try each (or all of these) and see if any work.

    The only other suggestion is to confirm that the image is being found, but you seem to suggest that it works if it's not over a button ?

    I had a problem adding an image to the Video Player skin. The skin is only about 100 pixels high, and I was adding the image at around 550 pixels down, so it was off the screen. (feeling like a plonker again just thinking about it !), just somethign else to check.

    Good Luck
    KPJUK
    M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
    DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

  7. #7
    FLAC djmickyg's Avatar
    Join Date
    Feb 2004
    Posts
    1,314
    thanks

    ill play around a little more..
    i have tried al the options cus u said that in the first post
    but maybe im doing something wrong

  8. #8
    Variable Bitrate
    Join Date
    Jun 2006
    Posts
    348

    IMG Button assistance.... (stuck!!!) ?

    Guys - I think I tried every combo here and simply can't nail this one. I've tried every combo of this and can get the images to show hit and miss - but when a button is placed on the image, it blanks it out.

    At this point I am really just guessing but Really Need this Or some option like this.

    Any help would be very sincerely appreciated!!! I have some areas where I just need this vs restructuring the entire skin image if possible. Would also be nice if the skin editor showed these but I can live without that for now.

    Any help - much thanks...

  9. #9
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Buttons don't overwrite/overlap/overdraw any images you load into the skin. They merely display the On/Off/Down layers that you loaded (including via IMG definitions). If something is getting drawn over, you need to load the image into the appropriate layers so it won't disappear -- i.e. for images over buttons, you'll need to load the ON/OFF/DOWN and OUT layers if you wish to update it immediately and make sure it displays the same image when redrawing the different button states.. If it still doesn't work, post the definitions you used.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  10. #10
    Maximum Bitrate kpjuk's Avatar
    Join Date
    Dec 2003
    Location
    West Midlands
    Posts
    474
    Hi kolemieux,

    here is an extract from my skin which I use to place an image on a button. I use the same image for all layers, this is a menu buttom at the bottom left of the screen.

    /, IMG, x, y, w, h, File Name, Option;IMGLAYER
    IMG01,698,527,90,60,"Menu.gif",Out
    IMG02,698,527,90,60,"Menu.gif",Empty
    IMG03,698,527,90,60,"Menu.gif",Off
    IMG04,698,527,90,60,"Menu.gif",On
    IMG05,698,527,90,60,"Menu.gif",Down

    Using this technique allows your skins to be customised by anyone, so it is very user friendly

    cheers
    KPJUK
    M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
    DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

Page 1 of 2 12 LastLast

Similar Threads

  1. iGmod Beta 2 release
    By PURDooM in forum Other Cool Stuff
    Replies: 625
    Last Post: 05-12-2006, 02:52 PM
  2. Power Button not working?
    By NoTicketsPlease in forum Newbie
    Replies: 5
    Last Post: 02-28-2006, 10:43 PM
  3. Replies: 4
    Last Post: 01-03-2006, 08:12 AM
  4. Replies: 2
    Last Post: 04-04-2005, 03:45 PM
  5. OPUS plus power button
    By The Grinch in forum Power Supplies
    Replies: 2
    Last Post: 07-25-2004, 01:55 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •