Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: 2004 Ford Explorer XLT

  1. #11
    Constant Bitrate seanshine's Avatar
    Join Date
    May 2004
    Location
    Behind the Zion Curtain
    Posts
    142
    Quote Originally Posted by snowspeeder View Post
    Looks like the screen wasn't a good deal afer all. Only about an hour of playing with it, the screen started flickering, then the image would go upside down, then a WHIT SCREEN! I opened it up to find this below. This makes me mad, since I'm on a very limited budget this could very well set the project back by at least 3 or 4 months. Not to mention I wasted money.

    The clip that holds the ribbon cable together is missing and hotglue is in its place... Not to mention the clip is broken in half and can be bent with my fingernail... (see pics)

    Does anyone know of a service that could fix this? I would gladly send it in for repair if it doesn't cost an arm and a leg.

    I'm in desperate need of help and would love to hear any suggestions.


    Since you bought it on ebay,I'd suggest asking the seller for a refund as the item he sold you is broken...if you paid with paypal and the seller refuses to refund you,a dispute is easy to file and you will get your money back.

    As an alternative,you can buy another board from another seller if you don't feel like bothering with the dispute process.
    Any sufficiently advanced technology is indistinguishable from magic - Arthur C. Clarke

  2. #12
    Low Bitrate
    Join Date
    Jan 2008
    Posts
    87
    take it to any electrical repair shop they will be able to do it probably, with the correct connector and everything.

  3. #13
    Newbie
    Join Date
    Jun 2007
    Posts
    28
    Looks like the connector came off with trying to remove the hot glue. I was just sitting there and glued on >.<

    So now I just have bare solider points...

    I'd return it but Id get such good of deal if I can fix it cheaply

    I wish we had a local electronics shop around here, yet I've lived in this small community and have never heard of a "good" electronics supply store. All we have is Radio Shack and that's 30 miles away :P

    Where could I buy a flat connector "the beige thing in my picture"?

    I looked on digi-key at the 40 pin connectors, but I have no idea which one I should get. Anyone know a specific model?

    Thanks for all your help guys I really appreciate it!

  4. #14
    Newbie
    Join Date
    Jun 2007
    Posts
    28
    Just got my mobo in a few minutes ago. Posting some pics. The link below is the specs.














  5. #15
    Newbie
    Join Date
    Jun 2007
    Posts
    28
    I think I found a link to a longer ribbon cable to replace the "hot glued" one. Can anyone tell what kind of connector I need to buy if I wanted to solder a new one on?

    Ribbon Cable

    Edit

    I think I found it. Would this be the right one?
    Connector

  6. #16
    Low Bitrate
    Join Date
    Jan 2008
    Posts
    87
    that looks like them mate

  7. #17
    Newbie
    Join Date
    Jun 2007
    Posts
    28
    Anyone know of a good usb gps device that would accept an external antenna. Id like to get that all-in-one antenna from mp3car store :P

  8. #18
    Newbie
    Join Date
    Jun 2007
    Posts
    28
    I just received my Opus Power supply one step closer.



    Still don't know why picasa pics doesn't load sometimes... >.>

  9. #19
    Newbie
    Join Date
    Jun 2007
    Posts
    28
    Ok, finally got some funds to continue on with my project. I bought the ABS PLASTIC FRAME from ByByte.com. I mounted my lilliput in it already. I was thinking about making a "in dash" case such as the one in this thread. However it seems that I do not have enough room behind my dash...

    So I'm just going to mount all the components in a case and mount it under the drivers side seat and the amp "when I buy one" under the passenger seat...




  10. #20
    Newbie
    Join Date
    Jan 2008
    Posts
    48
    how is the quality of the new bybyte frame? I've heard that the old one used adhesives.

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. My 1998 Ford Explorer XLT one day installation
    By david69leonard in forum Show off your project
    Replies: 17
    Last Post: 08-15-2011, 05:02 AM
  2. 1994 Ford Explorer XLT CAR PC - LOTS OF PICS!!!
    By xdjxklusivex in forum Show off your project
    Replies: 36
    Last Post: 09-04-2009, 02:07 PM
  3. 2004 Ford F350 CarPC
    By takissd in forum Show off your project
    Replies: 23
    Last Post: 08-31-2007, 10:14 PM
  4. 1996 Ford Explorer XLT - Complete
    By rulouder22 in forum Show off your project
    Replies: 6
    Last Post: 03-14-2007, 11:03 AM
  5. 2002 Ford Explorer XLT
    By argetim in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 2
    Last Post: 12-28-2004, 03:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •