Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: 2004 Ford Explorer XLT

  1. #1
    Newbie
    Join Date
    Jun 2007
    Posts
    28

    2004 Ford Explorer XLT

    I ordered my liliput 7' LED LCD today. I already have a lot of parts to get started. This is my ride. I hope to mount the LCD in the dash to make it look stock. So far I have the following

    - Mini-ITX computer, 1ghz VIA processor "fanless", and a gig of ram.
    - Liliput screen "coming in"
    - Double DIN Dash kit.
    - USB Bluetooth adapter
    - USB Linksys 802.11N Wireless adapter
    - Bluetooth GPS Reciver

    I plan on running RoadRunner. I hope to use my cellphone "Verizon xv6900" as a EVDO modem while driving. I want to add a rear backup camera, and a usb OTA capture card.

    Unfortunately I don't have the cash to but a DC to DC psu. So I'll use an inverter. Notice on my dash I have extra buttons on the right of my radio bezel. I plan on making an on/off switch for both the screen and carputer.

    I'll need to buy a cheap amp, since I have no room for the stock radio. Any suggestions on this, I'm new to all this so any advice helps.





  2. #2
    Variable Bitrate dMand's Avatar
    Join Date
    Oct 2007
    Location
    The Evergreen State, Washington
    Posts
    346
    Welcome aboard SnowSpeeder We look forward to seeing something unique. Best wishes with your new endeavor.

    Happy Holidays!

  3. #3
    Newbie
    Join Date
    Jun 2007
    Posts
    28
    Well my touchscreen came in. It a liliput 629-gl LED Backlit. I got it off ebay for $70.00. Works fine! I decided agenst using my mini-itx VIA pc. The processor is too slow to handle video (1ghz VIA C3) so I bought a new one off newegg.

    Intel Atom Mobo
    I also changed my mind about the PSU and now want to buy a DC-DC one. I saw on ebay a M2-ATX for sale for around $60. Is this a good PSU?




  4. #4
    FLAC Machinehead's Avatar
    Join Date
    Jun 2007
    Location
    hijacks small portable city
    Posts
    1,381
    I used to have an Explorer, a '98 Sport. It'll be interesting to see how you mold the lilli into that 1.5 din opening.

  5. #5
    Who am I? HiJackZX1's Avatar
    Join Date
    Jul 2007
    Location
    Miami
    Posts
    6,603
    Quote Originally Posted by Machinehead View Post
    I used to have an Explorer, a '98 Sport. It'll be interesting to see how you mold the lilli into that 1.5 din opening.
    the looks like a double din!? I know mine was that retarded 1.5, but thankfully Nexson got a EBY701 to fit.

    Nirwana Project, the Android/Win 7 hybrid system!

    1X Ainol Novo Flame Tab
    4X MK808b
    3x Perixx Touchpads
    3x 7 inch Screens
    1X 7 inch motorized Screen
    1x Win 7 PC

  6. #6
    FLAC Machinehead's Avatar
    Join Date
    Jun 2007
    Location
    hijacks small portable city
    Posts
    1,381
    Crutchfield says it's double din. *shrugs* It looks exactly the same as my '98 which was smaller than double din.

  7. #7
    Who am I? HiJackZX1's Avatar
    Join Date
    Jul 2007
    Location
    Miami
    Posts
    6,603
    Quote Originally Posted by snowspeeder View Post
    I ordered my liliput 7' LED LCD today. I already have a lot of parts to get started. This is my ride. I hope to mount the LCD in the dash to make it look stock. So far I have the following

    - Mini-ITX computer, 1ghz VIA processor "fanless", and a gig of ram.
    - Liliput screen "coming in"
    - Double DIN Dash kit.
    - USB Bluetooth adapter
    - USB Linksys 802.11N Wireless adapter
    - Bluetooth GPS Reciver

    I plan on running RoadRunner. I hope to use my cellphone "Verizon xv6900" as a EVDO modem while driving. I want to add a rear backup camera, and a usb OTA capture card.

    Unfortunately I don't have the cash to but a DC to DC psu. So I'll use an inverter. Notice on my dash I have extra buttons on the right of my radio bezel. I plan on making an on/off switch for both the screen and carputer.

    I'll need to buy a cheap amp, since I have no room for the stock radio. Any suggestions on this, I'm new to all this so any advice helps.




    For the AMPS, you can buy motorcycle amps. I use 5 of them. 1 for front, 1 for middle, 1 for rear, 1 for center/phone, and 1 for Bass. They of course sell 4 channel versions, but hard to find. Just Ebay Motorcycle amps. They are about the size of a pocket PC, so they are easy to hide. If you cant find the 4 channel then buy two 2 channel motor cycle amps. Would be less the $50.00.
    Nirwana Project, the Android/Win 7 hybrid system!

    1X Ainol Novo Flame Tab
    4X MK808b
    3x Perixx Touchpads
    3x 7 inch Screens
    1X 7 inch motorized Screen
    1x Win 7 PC

  8. #8
    Newbie
    Join Date
    Jun 2007
    Posts
    28
    Looks like the screen wasn't a good deal afer all. Only about an hour of playing with it, the screen started flickering, then the image would go upside down, then a WHIT SCREEN! I opened it up to find this below. This makes me mad, since I'm on a very limited budget this could very well set the project back by at least 3 or 4 months. Not to mention I wasted money.

    The clip that holds the ribbon cable together is missing and hotglue is in its place... Not to mention the clip is broken in half and can be bent with my fingernail... (see pics)

    Does anyone know of a service that could fix this? I would gladly send it in for repair if it doesn't cost an arm and a leg.

    I'm in desperate need of help and would love to hear any suggestions.








  9. #9
    Who am I? HiJackZX1's Avatar
    Join Date
    Jul 2007
    Location
    Miami
    Posts
    6,603
    Quote Originally Posted by snowspeeder View Post
    Looks like the screen wasn't a good deal afer all. Only about an hour of playing with it, the screen started flickering, then the image would go upside down, then a WHIT SCREEN! I opened it up to find this below. This makes me mad, since I'm on a very limited budget this could very well set the project back by at least 3 or 4 months. Not to mention I wasted money.

    The clip that holds the ribbon cable together is missing and hotglue is in its place... Not to mention the clip is broken in half and can be bent with my fingernail... (see pics)

    Does anyone know of a service that could fix this? I would gladly send it in for repair if it doesn't cost an arm and a leg.

    I'm in desperate need of help and would love to hear any suggestions.







    Wait, thats how you got it?!?!?!?! Wow that sux.... How long ago did you buy it, and were? You can maybe open a dispute if bought ebay.
    Nirwana Project, the Android/Win 7 hybrid system!

    1X Ainol Novo Flame Tab
    4X MK808b
    3x Perixx Touchpads
    3x 7 inch Screens
    1X 7 inch motorized Screen
    1x Win 7 PC

  10. #10
    Variable Bitrate dMand's Avatar
    Join Date
    Oct 2007
    Location
    The Evergreen State, Washington
    Posts
    346
    that's a simple fix. I've done it before, and I'm quite sure you can do it.

    Repair items needed:
    rubbing alcohol
    2 ea Q-Tips
    thin double-sided nylon carpet tape


    apparently the ribbon cable's plastic clip was broken, and is missing, so the previous owner attempted a fix. Hot glue is not good for that type of repair.

    Any way, remove all of the hot glue very carefully without scratching the board or the ribbon. Slightly heat the glue with a lighter and rub it off with your thumb. But do not heat the ribbon cable, only the surface of the board away from the plastic contact.

    After everything is thoroughly cleaned, dampen a Q-Tip with alcohol and swab the pcb board free of residual oils that got there from your finger tips, including the cable. This is very important to do, and will ensure that tape does stick to it. Then go to Lowe's/Home Depot and pick up a roll of baby blue two sided heavy duty thin carpet tape. Sorry, I forgot the brand of the tape. Ask an attendant for assistance. He or she will point you in the right direction. The actual tape is gray in color with threaded nylon reinforcement. However, the backing is baby blue.

    Using a sharp pair of scissors, cut a small piece of tape 3/4" x 1 1/2 " wide, and apply it centered evenly, to the board along the mating edge of the contacts. Make sure you press the tape firmly throughout the surface with your fingernail, before removing the backing of the tape. Now peel off the backing, then carefully insert the ribbon cable into the socket without touching the tape. Once you're sure the contacts are centered, and has been fully inserted, affix the ribbon to the tape firmly.

    Then cut a bigger piece of tape and place it over the entire connection. Again, using your finger nail, rub the backing of the tape along the connection to ensure that it is firmly applied. Don't bother removing the backing this time. Just leave it there. That should hold it pretty good, and will last over a year of trouble free service if done as instructed.

    Now power it up and enjoy your Lilli. Good Luck, and happy carputing

Page 1 of 3 123 LastLast

Similar Threads

  1. My 1998 Ford Explorer XLT one day installation
    By david69leonard in forum Show off your project
    Replies: 17
    Last Post: 08-15-2011, 04:02 AM
  2. 1994 Ford Explorer XLT CAR PC - LOTS OF PICS!!!
    By xdjxklusivex in forum Show off your project
    Replies: 36
    Last Post: 09-04-2009, 01:07 PM
  3. 2004 Ford F350 CarPC
    By takissd in forum Show off your project
    Replies: 23
    Last Post: 08-31-2007, 09:14 PM
  4. 1996 Ford Explorer XLT - Complete
    By rulouder22 in forum Show off your project
    Replies: 6
    Last Post: 03-14-2007, 10:03 AM
  5. 2002 Ford Explorer XLT
    By argetim in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 2
    Last Post: 12-28-2004, 02:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •