Page 5 of 7 FirstFirst 1234567 LastLast
Results 41 to 50 of 68

Thread: 95 Civic Hatch: relocated a/c + 6000 watts and 300hp *tons of pics*

  1. #41
    Variable Bitrate vxcarpc's Avatar
    Join Date
    Jan 2005
    Location
    Melbourne, Australia
    Posts
    356
    That's some fair power out of a 4 cylinder..
    CAR INFO HERE
    "He who dies with the most toys, wins".

  2. #42
    Variable Bitrate 4u2n's Avatar
    Join Date
    May 2004
    Location
    Denmark
    Posts
    333
    nice litte, hevy audio system

    do you have power for the amp? 2 * 3000 W is 500A ????
    Plan for project = 100%
    Part the project. = 100%
    Built...................= 99%
    Finish.................= 99%
    Install ...............= 99% -50%
    Ditail at 4u2n.dk
    Here

  3. #43
    Maximum Bitrate Dragonknell911's Avatar
    Join Date
    Aug 2004
    Posts
    521
    lol @ 500 amps. That is maximum for about a 1/2 second. Those are peak numbers. The amps do 1500 or so continous each.

    Plus that 500 amps number is assuming 100% efficiency, which no electronics can boast.

    Still to do 2 x 1500 watts continous that is crazy.. I want to see that engine/alt/batt setup / hear it.

    edit: if each does ~1500 continous that is 3000 watts total, if they are 75% efficient that is 4000 watts. 4000/12, that is still like 333 amperes just for those amps. crazy.

    Unless your running a complete upgrading electronic system just for those amps at like 19volts or something
    REBUILDING!!

  4. #44
    Low Bitrate
    Join Date
    Mar 2005
    Location
    LaBelle FL
    Posts
    68
    2 batteries, 170 amp alternator soon to be dual alternators, 1/0 ga Stinger wire (soon to be 2 strands) and a 300a ANL fuse up front. The amps are rated at 1800 rms at 2ohm CEA at 14.4v. So yes about 1500ish+ continuous but I run them at 1ohm so ??? It does draw some serious current but I have not seen 300. I am definatly peaking my voltage and amperage as my guage on the Tsunami Hybrid holds steady at 178amps. Basicaly all my charging system can put out haha. Either way it beats down and still current FL USACI state record. I got invited to World Finals infact

    Thanks again everyone I truly appreciate the kind words. Also, thanks for going easy on me about the paint lmao! Maybe in another year or so.

    edit: btw she's puttin down 348whp now New turbo, bigger injectors and more BOOST!

  5. #45
    Maximum Bitrate Dragonknell911's Avatar
    Join Date
    Aug 2004
    Posts
    521
    Awesome setup! I'm getting a new alternator soon, they are so expensive for the newer civics, it just kills me. My stock one seems like it is going anyways, so eh thats life.
    REBUILDING!!

  6. #46
    Low Bitrate
    Join Date
    Mar 2005
    Location
    LaBelle FL
    Posts
    68
    As promised here are a few not so great pics. The weather wasnt the best and the sun wasnt shining but you get the idea. Me = no photographer haha!









  7. #47
    Low Bitrate
    Join Date
    Mar 2005
    Location
    LaBelle FL
    Posts
    68








  8. #48
    Newbie
    Join Date
    Sep 2006
    Posts
    33
    i envy you..... i usually dont like hatchbacks, but this.... wow... words can not explain how much time you must have put in this car, and it shows, down to the door handles, i really respect people like you who take so much time and dont just throw a wal-mart amp in there civic, add a bunch of stickers and talk ****

  9. #49
    Constant Bitrate damarble's Avatar
    Join Date
    Jan 2006
    Location
    Spokane
    Posts
    173
    I'm not a Honda fan but I am very impressed with your ride. And *drool* over those new seats, they look perfect.
    {Xenarc 700TSV} {Celeron M 1.3 ghz} {ASUS mATX mobo w/CT479} {MX440 128mb AGP} {1x512mb RAM} {3.5" Seagate 40gb (rated at 350 G's)} {M1-ATX}

    MY INSTALLATION LOG

  10. #50
    Low Bitrate Epon's Avatar
    Join Date
    Oct 2005
    Posts
    86
    im not a fan of civics at all, but this might be one of the baddest rides i've seen. solid job bro.

    quick question, how did you run the CDROM up to the front? I'm assuming some form of IDE2USB cable... am i correct?
    2004 Ford Mustang


Page 5 of 7 FirstFirst 1234567 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •