Results 1 to 4 of 4

Thread: Run() with Command Line Parameters

  1. #1
    Newbie theminor's Avatar
    Join Date
    Feb 2006
    Location
    Macon, GA
    Posts
    33

    Run() with Command Line Parameters

    I'm trying to embed iGuidance and I'm using the new skin posted here. The skin works great but it still uses a slow way to deal with the nag screen. I want to simply use the "nowarning" command-line parameter when the skin executes iGuidance.exe, per this post in this thread. Then, I'll take out all the pausing and killing of teh nag screen in the iGuidance skin so that it will load faster.

    In the skin, how do I use the Run() command and include command-line paramters? I tried putting a space between the command and parameters, but it doesn't like that, and I tried just about every character (like comma, pike, etc.) as well. Any ideas?

  2. #2
    Banned RPM_VR4's Avatar
    Join Date
    Nov 2004
    Location
    L.A.
    Posts
    1,893
    hummm... Sb (or more directly, Delphi's built-in INI file parser) allows spaces sometimes but doesn't like them at other times. I haven't really figured it out (and development has been on hold for a long time). I will probably go to XML eventually.

    Also, the nag is closed instantly on my home PC, but it waits the 3 seconds for the embed time-out in my car as well??? I'm not sure what is up with that. You could always decrease the embed time-out (or just "type(enter)" after a "wait(x ms)" and not bother embedding the nag screen and then focusing it first). This will still not be instant and could not work at all if you set it too short though.

    Anyway, I didn't know about that command-line thing... cool! A good work around for the parameter issue would be to have Sb run an AutoIt script that launched iG with the parameter.

    ...and thanks for the excellent use of hyperlinks... many people in this forum could learn a lot from you

    EDIT: ...including me as I just went back and linked AutoIt

  3. #3
    Banned RPM_VR4's Avatar
    Join Date
    Nov 2004
    Location
    L.A.
    Posts
    1,893
    I have updated the SKIN to use "nowarning" via auto-it script.

  4. #4
    Newbie theminor's Avatar
    Join Date
    Feb 2006
    Location
    Macon, GA
    Posts
    33
    Wow, that AutoIt software is great! And thanks for the new skin - it really loads fast now and was exactly what I was looking for! I really appreciate it!

Similar Threads

  1. UPS run from inverter?
    By FyreDaug in forum Power Supplies
    Replies: 28
    Last Post: 01-18-2007, 06:03 PM
  2. Replies: 7
    Last Post: 02-22-2005, 12:17 AM
  3. Is it possible to run every prog embedded?
    By memy in forum Road Runner
    Replies: 8
    Last Post: 02-13-2005, 06:19 PM
  4. Can OnCourse 4 run on a carputer?
    By blkfire in forum GPS
    Replies: 0
    Last Post: 02-01-2005, 11:20 AM
  5. What software should I run? This is giving me a headache...
    By Bailey in forum Software & Software Development
    Replies: 13
    Last Post: 01-12-2005, 06:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •