Page 1 of 5 12345 LastLast
Results 1 to 10 of 44

Thread: Oziexplorer

  1. #1
    Newbie
    Join Date
    May 2005
    Location
    Perth, West Oz
    Posts
    10

    Oziexplorer

    I've seen a few people having probs with Ozi and Skinbedder and was wondering if anyone has found a solution?

    With 2.9999 I can get the app to embed, but can't load any buttons, the same issue posted in [V3 Questions]

    With V3 & Oziexp3962a.exe I can't even get the app to embed

    Would be great to get Ozi skinned as it is really useful for those of us who venture off the main roads

  2. #2
    Low Bitrate
    Join Date
    Jun 2005
    Location
    Crazyburn, Melbourne, Vic, Australia
    Posts
    96

    Some Success

    Here's the files which I have had some success with so far... It's a bit messy as I haven't renamed anything from GooPs, but Ozi embeds ok and the zoom buttons and play button work. [EDIT] I am using V3 Prerelease 2 [/EDIT]

    Still workin on it...

    Is SB able to embed a window component? I'm trying to work out how to get rid of the tool bars...Attachment 32287
    '89 GQ Patrol
    TD42 (go the Diesel!) NEW: Now with DTS Turbo - woot!!!
    "It's times like these you go BUGGER!!!"

  3. #3
    Banned RPM_VR4's Avatar
    Join Date
    Nov 2004
    Location
    L.A.
    Posts
    1,893
    Yep, just get the window title and class from the AutoIt window tool, and Sb can embed it.

  4. #4
    Low Bitrate
    Join Date
    Jun 2005
    Location
    Crazyburn, Melbourne, Vic, Australia
    Posts
    96
    This is the info from AutoIt tool:

    Press CTRL-ALT-F to pause the display.

    >>>>>>>>>>>> Window Details <<<<<<<<<<<<<
    Title: OziExplorer - Blank Map
    Class: TfmMainForm
    Size: X: 110 Y: 120 W: 1440 H: 858

    >>>>>>>>>>> Mouse Details <<<<<<<<<<<
    Screen: X: 1330 Y: 526
    Cursor ID: 2

    >>>>>>>>>>> Pixel Color Under Mouse <<<<<<<<<<<
    RGB: Hex: 0xFFFFFF Dec: 16777215

    >>>>>>>>>>> Control Under Mouse <<<<<<<<<<<
    Size: X: 0 Y: 89 W: 1432 H: 701
    Control ID: 1311794
    ClassNameNN: TScrollBox11
    Text:

    >>>>>>>>>>> Status Bar Text <<<<<<<<<<<


    >>>>>>>>>>> Visible Window Text <<<<<<<<<<<
    100
    100
    149 02.400 E
    UTM 55U 6 50 184E 53 93 003N
    48 40.320 N
    WGS 84

    >>>>>>>>>>> Hidden Window Text <<<<<<<<<<<
    Zoom


    Does that mean that I just put "WindowClass=TScrollBox11" ?

    Is this what is done to the other apps that are embedded without their normal toolbars?
    '89 GQ Patrol
    TD42 (go the Diesel!) NEW: Now with DTS Turbo - woot!!!
    "It's times like these you go BUGGER!!!"

  5. #5
    Banned RPM_VR4's Avatar
    Join Date
    Nov 2004
    Location
    L.A.
    Posts
    1,893
    WindowClass=TfmMainForm

    ...at the top!

  6. #6
    Low Bitrate
    Join Date
    Jun 2005
    Location
    Crazyburn, Melbourne, Vic, Australia
    Posts
    96
    I get this bit... that gets the whole program embedded, but if I only want to see the map section (ie remove the button toolbars etc), do I use WindowClass=TScrollBox11 which is what I had the mouse on when I took the autoit info.
    '89 GQ Patrol
    TD42 (go the Diesel!) NEW: Now with DTS Turbo - woot!!!
    "It's times like these you go BUGGER!!!"

  7. #7
    Banned RPM_VR4's Avatar
    Join Date
    Nov 2004
    Location
    L.A.
    Posts
    1,893
    Q: How do you embed just the map, not the whole window?
    A: You embed the entire program, then you "crop" the embedded window down to the map size using the four "Nudge" values. Sb can only grab "Forms" with a desktop-level WindowHandle. It cannot grab individual parts of windows. It can grab most popup-windows as these are their own form. It may be able to grab MDI sub-windows, but I am not sure.


    Q: Does Sb have a time-stamp function for saving filenames?
    A: No.

  8. #8
    Low Bitrate
    Join Date
    Jun 2005
    Location
    Crazyburn, Melbourne, Vic, Australia
    Posts
    96

    Red face Thanks

    Ahh.. OK

    Thanks for your help RPM.
    '89 GQ Patrol
    TD42 (go the Diesel!) NEW: Now with DTS Turbo - woot!!!
    "It's times like these you go BUGGER!!!"

  9. #9
    Low Bitrate
    Join Date
    Jun 2005
    Location
    Crazyburn, Melbourne, Vic, Australia
    Posts
    96
    Hey RPM

    I keep getting this error:
    Access violation at address 004615E8 in module 'SKINbedder.exe'. Read of address 00000000.

    It's when I'm loading up some new png's that I've just created... Is it something to do with incorrect png format? I've createded them in MS Paint for a quick trial.
    '89 GQ Patrol
    TD42 (go the Diesel!) NEW: Now with DTS Turbo - woot!!!
    "It's times like these you go BUGGER!!!"

  10. #10
    Banned RPM_VR4's Avatar
    Join Date
    Nov 2004
    Location
    L.A.
    Posts
    1,893
    ? Don't know. I use PhotoShop for all my PNGs, but any app should work.

    The only time I have ever gotten access violations is when exiting skinbedder (something was wrong with my code that free's all arrays in memory before exit), but that has been fixed for a while now too.

    Try a different .png (or running it with a downloaded SKIN) and see if that fixes it.

Page 1 of 5 12345 LastLast

Similar Threads

  1. 4WD Skin
    By ashgrovered in forum RR Skins
    Replies: 33
    Last Post: 06-03-2011, 05:03 AM
  2. Replies: 12
    Last Post: 08-26-2008, 06:37 AM
  3. Replies: 64
    Last Post: 06-19-2005, 10:48 AM
  4. Mapsource and oziexplorer
    By reactbob in forum GPS
    Replies: 0
    Last Post: 05-14-2005, 08:09 PM
  5. Replies: 0
    Last Post: 01-05-2004, 03:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •