Page 11 of 18 FirstFirst ... 23456789101112131415161718 LastLast
Results 101 to 110 of 180

Thread: HQCT software development

  1. #101
    Maximum Bitrate bes51659's Avatar
    Join Date
    Sep 2005
    Location
    Vasastaden, Stockholms Län, Sweden, Sweden
    Posts
    852

    one step further

    Hi putput and thanks for your thorough answer!

    After powering off and on the module I did find a car-radio HID device in the HID list.

    (I have only black and red connected to +12V. There is also orange blue and purple unconnected and a white wire loop. I've lost my wiring diagram and cannot download it from XTronic. Its gone from their site. But since I now can see the HID device I think I'm alright)

    Problem remains.

    I use WinXP pro, sp2.

    The version I've downloaded from your site is (from readme file)
    "CPCTuner"
    "Version 0.1"
    "Build 36, 14-12-2006"
    (I will try more versions, obviously)

    My thought was if there might be a conflict between other USB devices. Have you had people reporting such? I have quite a few.
    1) DVD,
    2) BT,
    3) touchscreen,
    4) OBDII port,
    5) Creative soundcard,
    6) a GPS receiver
    7) the radio and
    8) a Huawei E220 3G modem (which I specifically have had problems with)

    From the pic, the BT devices are broadcom, the "hid compliant device" is standard system device, and the "hid compliant consumer control device" is microsoft. They all are "working".

    Come to think of it I should off-cause disconnect everything but the radio...

    Well, thanks to you Putput I've got a few things to try out still! I'll mail again if I get stuck.

    Cheers, B-O
    Attached Images Attached Images  

  2. #102
    Maximum Bitrate bes51659's Avatar
    Join Date
    Sep 2005
    Location
    Vasastaden, Stockholms Län, Sweden, Sweden
    Posts
    852
    Hi putput

    I have a little report.

    It did not matter if I had only the HQCT connected to USB.

    But the different software behaved differently. Maybe you are right that this is because I've got an (untested) HQCT-e module?

    The RRHQCT original ver 2.0 - WORKING (I think)



    CPCTuner 1.0.36



    CPCTuner 1.0.41 does not start at all



    CPCTuner 1.0.42 (splash says 41...)



    CPCTuner 1.0.43 is the same



    CPCTuner 1.1.1.50


  3. #103
    Constant Bitrate Putput's Avatar
    Join Date
    Sep 2005
    Location
    Belgium
    Posts
    181
    Hello bes51659,
    Great testing I must say. Strange that none of the versions detect the module connected. Because as I explained earlier, the older versions do not test for a specific HQCT device, any HQCT device will do. (Apparently not :-( )
    But don't panic, download this little cmd line program and it will create a log file (use the latest build) in a .\Log folder. It’s called CPCLogdriver but it isn't a real driver, it’s just a small multi-threaded program that captures logging messages and writes these messages into a text file. Start CPCLogdriver first (double click on the .exe file), then start CPCTuner and you should see some messages in the command line screen. Now wait until the error messages pops up, click ok and that's it. Now close the log tool by pressing CTRL-C (when it has focus) or simply close the window. You should now see a newly created folder with a file inside, something like '20071121Log.dat'. Send this file to me via email (check my website for my email address) and I will have a look at it.
    Again thank you very much for all your efforts, hopefully I can find a solution for you soon.

    Regards,
    Putput

  4. #104
    Constant Bitrate Putput's Avatar
    Join Date
    Sep 2005
    Location
    Belgium
    Posts
    181
    Hello bes51659,
    Could you please download the latest CPCTuner build again and check if there are any changes? I did some testing and discovered that there is still something wrong with the RR communications but it should work for your HQCT-e as a standalone app. I found a bug that was the probable cause for your connection troubles.

    CU,
    Putput

  5. #105
    Maximum Bitrate bes51659's Avatar
    Join Date
    Sep 2005
    Location
    Vasastaden, Stockholms Län, Sweden, Sweden
    Posts
    852
    Hi P
    I am just about to go to bed, but I had to test the new latest first. Same but different :-) I will have a better look tomorrow.
    Cheers


  6. #106
    Newbie
    Join Date
    Jul 2007
    Posts
    5
    hi all and first of all thank you all for the great work !!!

    I think I found a problem with the HQCT-eA and the dll. Whenever I shut down my computer into hibernation and than recover from this, it reports that it can not connect to the device.
    So what I need to do right now is shut down the program before I put my carputer into hibernation, is this normal procedure of maybe a bug?
    greetings,
    PsyCorps

  7. #107
    Maximum Bitrate bes51659's Avatar
    Join Date
    Sep 2005
    Location
    Vasastaden, Stockholms Län, Sweden, Sweden
    Posts
    852
    I've posted a message for you P

    From what I understand CPCTuner does find the HQCT but for some reason the protocol is incompatible?

    cheers, B-O

    Ps. You've got nothing to thank me for.

  8. #108
    Constant Bitrate Putput's Avatar
    Join Date
    Sep 2005
    Location
    Belgium
    Posts
    181
    Updated the latest build again, please give it another try. It works on my car-pc system with both -i and -eA versions. I'm sure now that the bug is related to a timing problem in the connection phase. What happens is that the communications thread is trying to find the module while the HQCT component thread is waiting for the comm thread to finish or to fail. To prevent an endless loop the main thread stops listening after a while and decides that the communication has failed and kills all active threads and exits the program. This timing was too critical, (I think). What hardware are you using? (Just fast, as in dual processor, or slow, as in VIA ITX will do as an answer )

    About the thanks; it's positive to know that people use my software and want to help to make it better program. I just appreciate your help (and the fact that you use CPCTuner )

    CU,
    Putput

  9. #109
    Newbie
    Join Date
    Jul 2007
    Posts
    5
    Well I am really greatfull for all the hard work that people put into projects making all these nice hardware things work like a charm
    I am using a SP13000 for carputer, and I will try to update the program tomorrow, maybe its allready fixed!

    again, thank you!

  10. #110
    Constant Bitrate Putput's Avatar
    Join Date
    Sep 2005
    Location
    Belgium
    Posts
    181
    Quote Originally Posted by PsyCorps View Post
    hi all and first of all thank you all for the great work !!!

    I think I found a problem with the HQCT-eA and the dll. Whenever I shut down my computer into hibernation and than recover from this, it reports that it can not connect to the device.
    So what I need to do right now is shut down the program before I put my carputer into hibernation, is this normal procedure of maybe a bug?
    greetings,
    PsyCorps
    Hi Psy,
    Thanks for the credit, I'm doing the best I can

    I just uploaded a new version of the DLL with eA support. Before anything else, make a copy of the DLL that you are using right now and of the ini file. Then copy the new DLL into the correct folder and start the program. Give it a try, this version should be able to handle hibernation. Be carefull, very beta ...
    Just a question, are you writing your own software? If so you can download a description of the new functions in this DLL here.

    Regards,
    Putput

Similar Threads

  1. CarPal Bluetooth Module & Digimoto Software....A Very Good Combo..
    By jmciver in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 6
    Last Post: 06-16-2006, 04:08 PM
  2. Replies: 2
    Last Post: 11-15-2005, 01:38 PM
  3. MSDXM.OCX - Why oh why don't you fix that NOW?!
    By Zippy1970 in forum Media Engine
    Replies: 18
    Last Post: 02-28-2005, 04:36 PM
  4. Software solution for gLCD-based car-mp3
    By Novgorod in forum Software & Software Development
    Replies: 1
    Last Post: 07-01-2004, 07:59 PM
  5. My numpad controlled custom MP3Car software - need your opinions
    By PorscheMP3 in forum Software & Software Development
    Replies: 7
    Last Post: 04-11-2002, 10:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •