Page 17 of 18 FirstFirst ... 789101112131415161718 LastLast
Results 161 to 170 of 180

Thread: HQCT software development

  1. #161
    Constant Bitrate
    Join Date
    May 2006
    Posts
    116
    There are several issues and price/cost is clearly one.

    I have not installed my HQCT in the car yet for several reasons Windows Vista and looking at a Linux alternative has consumed lots of time.

    The HD Radio alternative sounds like it could be cost efficient (and maybe time efficient).

    I hate to change direction away from HQCT, but I don't want to be blind. I do like the small size.

    Is HD Radio on the HQCT out of the question?

  2. #162
    Newbie
    Join Date
    Nov 2006
    Location
    Cambridge, UK
    Posts
    14

    Running SiLABS radio and HQCT together

    Quote Originally Posted by Putput View Post
    Hello Paul,

    Long time no see!

    I just did a test and both HQCT-eA and Silabs are working perfectly together on my developer PC without any problems, even when plugged in into the same USB hub. Only thing is that the Silabs dongle has a lag of a second or something and when both are tuned to the same station you can hear some sort of echo, strange effect I must say ;-).

    Regards,
    Luc
    Hi Luc,

    Good to hear from you too - and thanks for the reply. Strange that you have no problems with the HQCT and Silabs together - on my system both the USB devices stop working. Maybe I should try with CPCTuner? BTW - the last time I tried my HQCT-eA with CPC, it resulted in the system initialising at *FULL VOLUME*!! Is this something that's resolved in the latest build?

    Regards,

    Paul

  3. #163
    Maximum Bitrate
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Posts
    570
    Gday Luc,

    Don't suppost you can add to use AUS instead of just EU or USA :-) (AUS=Australia) mate!

    I've managed to get my HQCT-e working via the CTCSuite and through CF but not yet on FI. I get mixed results between CF and CTC software especially with RDS & reception, but I am only using a screw driver for an antenna

    Thanks
    New Car PC Build list in progress

  4. #164
    Constant Bitrate Putput's Avatar
    Join Date
    Sep 2005
    Location
    Belgium
    Posts
    181
    Quote Originally Posted by Kosti View Post
    Gday Luc,

    Don't suppost you can add to use AUS instead of just EU or USA :-) (AUS=Australia) mate!

    I've managed to get my HQCT-e working via the CTCSuite and through CF but not yet on FI. I get mixed results between CF and CTC software especially with RDS & reception, but I am only using a screw driver for an antenna

    Thanks
    Hi Kosti,
    Buy me a ticket to visit you someday 'on the other side' and I'll make you a fully personalised version (background picture included) of CPCTuner on your doorstep!
    A screwdriver ? You mean something to drive screws into materials like wood and stuff?? I can hear Alex think 'AAAHH'!
    And if you can receive any RDS text whatsoever with that you've got a great screwdriver!
    Forgive me for my ignorance but what is FI? I can come up with a lot of things but I'm almost sure that none of them will match.

    Greetz
    Luc

    PS I can add AUS to the list if you want, if you can tell me what settings you use (USA or EU).

  5. #165
    Maximum Bitrate
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Posts
    570
    Gday Champ,

    YEP a screwdriver LOL, it was the only thing I had avail to plug into the HQCT for reception, sad I know but it was enough to test the unit.

    I'm using the Continent=EU and Freq FM 87-108, AM 520-1720 for OZ land mate.

    FI=FreeIce, I know a lot of people don't like it but I am trying different FEnds.

    As for a ticket to DOWNUNDER, well that depends cause I just bought a lottery ticket worth 50Mil, so fingers cross!!

    Cheers
    Kosti
    New Car PC Build list in progress

  6. #166
    Constant Bitrate
    Join Date
    Jun 2006
    Posts
    188
    Hi Putput,

    Just to report back, I was getting a similar error to the one that BES reported using a HQCT-i. On your latest version i got the error "CPCtuner could not connect to HQCT module". however your last version 1.1.52 works fine no problems.

    if you want me to do some more testing let me know.

  7. #167
    Newbie Glitchinthesyst's Avatar
    Join Date
    Jan 2008
    Location
    SouthWest England
    Posts
    13
    Luc,

    In your latest HQCT DLL (which I belive is used by Flux Media for Centrafuse) you refer to the "Select the sound source for the audio output, 0=Tuner, 1=CD, 2=Phone, 3=Navigation"

    Could you confirm that the "1=CD" is the "Aux 1 I/P" and the "Aux2 I/P" is the "2=Phone" on the HQCt-eA please ?

    Regards Glitch
    There are many paths to the top of the mountain.
    But once there the view is always the same.

    Enter the Dragon @ http://www.sportagedragon.co.uk

  8. #168
    Constant Bitrate Putput's Avatar
    Join Date
    Sep 2005
    Location
    Belgium
    Posts
    181
    Quote Originally Posted by Glitchinthesyst View Post
    Luc,

    In your latest HQCT DLL (which I belive is used by Flux Media for Centrafuse) you refer to the "Select the sound source for the audio output, 0=Tuner, 1=CD, 2=Phone, 3=Navigation"

    Could you confirm that the "1=CD" is the "Aux 1 I/P" and the "Aux2 I/P" is the "2=Phone" on the HQCt-eA please ?

    Regards Glitch
    Hi Glitch,

    This is part of the routine that sends the soundsource to the module:

    Code:
    procedure THQCTuner.SetSoundSource(TheSoundSource : TSoundSource);
    begin
       case TheSoundSource of
          TunerSrc:
             begin
             end;
          CDSrc:
             begin
             end;
          AUXSrc:
             begin
             end;
          PhoneSrc:
             begin
             end;
          NaviSrc:
             begin
             end;
       end;
    end;
    TunerSrc starts at 0, so you can see that CD = 1, AUX = 2, ...

    Luc

  9. #169
    Newbie Glitchinthesyst's Avatar
    Join Date
    Jan 2008
    Location
    SouthWest England
    Posts
    13
    Luc,

    Sorry I did not word my original question ciorrectly as I am now very confused?

    What I'm trying to find out is that in your CPCTuner program you have the sound souces "Tuner, CD, Navigator & Phone" labelled. However on the HQCT-eA there is no physical "CD" RCA I/P only "Aux1" & "Aux2" according to the wiring diagrams.

    So in CPCTuner if "CD" is selected as the sound source is this "Aux1 or Aux2"?

    What I am trying to do is write a small program using VB/Delphi to switch the sound source to "Aux1", thats all I want it to do.

    However having not done any programming for over 27 years and even then that was in BASIC, I am trying to learn VB/Delphi and give it a go.

    I'm having to do this as Centerfuse does not support the HQCT-eA properly and enable sound source switching.

    regards Glitch
    There are many paths to the top of the mountain.
    But once there the view is always the same.

    Enter the Dragon @ http://www.sportagedragon.co.uk

  10. #170
    Constant Bitrate Putput's Avatar
    Join Date
    Sep 2005
    Location
    Belgium
    Posts
    181
    Hi Glitch,

    Sorry for confusing you, you are correct about the difference between my code and what is in CPCTuner. I've checked the code from CPCTuner and it appears that my info is not complete.
    In CPCTuner you cannot select the AUX input, this is still something I need to change/add, however you can select it using the DLL and I believe that this is what you want to do. Here's how:
    Call HQCTSetSoundSource with following parameter:
    0 for Tuner source
    1 for CD source
    2 for Phone source
    3 for Navigation source
    4 for AUX source
    Hopefully this can help you out.

    I know that eA support in Centrafuse is not entirely finished, I'm sure David & Co are working on it but IMHO it's not an easy thing to add. Centrafuse sees the HQCT software as a radio plugin that is activated when the user wants to play radio, once you switch source in Centrafuse it needs to change the in-output in HQCT to get sound when the eA is used and also has to set different volume levels to the correct output. As a temporary solution you could write a little application in VB to set the correct in/out, it's possible that more then 1 application uses the DLL to control an HQCT module at the same time.
    Let me know if your solution works, perhaps there are others who want to you use it as well. You can post it in here if you like.

    Success!
    Luc

Similar Threads

  1. CarPal Bluetooth Module & Digimoto Software....A Very Good Combo..
    By jmciver in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 6
    Last Post: 06-16-2006, 04:08 PM
  2. Replies: 2
    Last Post: 11-15-2005, 01:38 PM
  3. MSDXM.OCX - Why oh why don't you fix that NOW?!
    By Zippy1970 in forum Media Engine
    Replies: 18
    Last Post: 02-28-2005, 04:36 PM
  4. Software solution for gLCD-based car-mp3
    By Novgorod in forum Software & Software Development
    Replies: 1
    Last Post: 07-01-2004, 07:59 PM
  5. My numpad controlled custom MP3Car software - need your opinions
    By PorscheMP3 in forum Software & Software Development
    Replies: 7
    Last Post: 04-11-2002, 10:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •