Results 1 to 7 of 7

Thread: Webcam brightness issue!

  1. #1
    Constant Bitrate
    Join Date
    Sep 2006
    Location
    Cornwall, England
    Posts
    161

    Webcam brightness issue!

    I am going to use a USB webcam for a reversing camera, but when I put the USB webcam outside the van, all I can see on the screen in white. If I put a sunglass lens over the webcam, i get a picture on my screen.

    At night though, with the sunglass lens infront of it, i get a black picture. I have written my front-end in VB.NET, is there a way setting white balance on a webcam through VB?
    ViVE - Volkswagen In Van Entertainment:

    VoomPC 2, VIA C7 2GHz
    7" Lilliput
    120Gb Sata drive
    1GB RAM


    [||||||||||] 100% - Planning
    [||||||||||] 100% - Software coding
    [||||||||||] 100% - Built

    (Always tweaking!)

  2. #2
    Constant Bitrate
    Join Date
    Sep 2006
    Location
    Cornwall, England
    Posts
    161
    Been looking around on ebay for web cams and I saw a few that say...


    --- Automatic brightness adjustment and color compensation ---


    Do you think one of these would give me what I need?
    ViVE - Volkswagen In Van Entertainment:

    VoomPC 2, VIA C7 2GHz
    7" Lilliput
    120Gb Sata drive
    1GB RAM


    [||||||||||] 100% - Planning
    [||||||||||] 100% - Software coding
    [||||||||||] 100% - Built

    (Always tweaking!)

  3. #3
    Low Bitrate
    Join Date
    Nov 2006
    Location
    Isle of Orkney. UK
    Posts
    100
    Auto adjustment should be sufficient. It should work.

    But what is more important is the angle of view. I think that the normal web cam is too narrow. Also does it have to be USB ?

    I bought a wide angle (108 degree) car reversing camera off the bay. It is surrounded by
    10 LED's. It cost 1p with 12. 99p postage. They are still advertised at that. I wasn't expecting much for that but is brilliant. It will flare if sun hits the lens directly, it is colour during the day and switches to mono at night with the infra-red. Thoroughly recommend it

  4. #4
    Constant Bitrate
    Join Date
    Sep 2006
    Location
    Cornwall, England
    Posts
    161
    I was thinking of mounting it facing down where the back door handle is so I can see the rear bumper at the bottom of the screen and whatever is behind the van at the top.

    I'll check out the camera you are talking about

    cheers
    ViVE - Volkswagen In Van Entertainment:

    VoomPC 2, VIA C7 2GHz
    7" Lilliput
    120Gb Sata drive
    1GB RAM


    [||||||||||] 100% - Planning
    [||||||||||] 100% - Software coding
    [||||||||||] 100% - Built

    (Always tweaking!)

  5. #5
    Constant Bitrate
    Join Date
    Sep 2006
    Location
    Cornwall, England
    Posts
    161
    I've looked at some cameras, but they are all composite outputs and I'm using a VoomPC 2 enclosure with a VIA cn700 motherboard. This doesn't have 'composite in', so I think I'll have to use a webcam, unless I can get a composite to USB device.
    ViVE - Volkswagen In Van Entertainment:

    VoomPC 2, VIA C7 2GHz
    7" Lilliput
    120Gb Sata drive
    1GB RAM


    [||||||||||] 100% - Planning
    [||||||||||] 100% - Software coding
    [||||||||||] 100% - Built

    (Always tweaking!)

  6. #6
    Low Bitrate
    Join Date
    Nov 2006
    Location
    Isle of Orkney. UK
    Posts
    100
    What screen are you using? I got mine from CarTFT. It has separate inputs and also reverses the picture. The camera is wired directly to it

  7. #7
    Constant Bitrate
    Join Date
    Sep 2006
    Location
    Cornwall, England
    Posts
    161
    I have the Lilliput 2008 model. It has direct input on it, but I would like to software code it so my front-end automatically switches to the reverse screen, which would still allow me to use the volume and other features in the front-end.

    I have emailed a few people about various web cams and some of them have auto brightness etc. so I think I will give one a go.


    ViVE - Volkswagen In Van Entertainment:

    VoomPC 2, VIA C7 2GHz
    7" Lilliput
    120Gb Sata drive
    1GB RAM


    [||||||||||] 100% - Planning
    [||||||||||] 100% - Software coding
    [||||||||||] 100% - Built

    (Always tweaking!)

Similar Threads

  1. Another Lilliput issue, Maybe
    By djmickyg in forum LCD/Display
    Replies: 15
    Last Post: 05-04-2008, 06:29 AM
  2. .M3U issue "Play all" issue
    By Kimota in forum StreetDeck
    Replies: 0
    Last Post: 12-12-2007, 10:34 AM
  3. setting screen brightness and contrast permanently
    By G35Pimp in forum LCD/Display
    Replies: 7
    Last Post: 07-27-2007, 09:54 PM
  4. Boot issue
    By Slippin3 in forum Power Supplies
    Replies: 7
    Last Post: 02-07-2006, 02:19 PM
  5. Brightness Console 1.0
    By OvernightTech in forum Software & Software Development
    Replies: 0
    Last Post: 02-14-2004, 08:19 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •