Results 1 to 6 of 6

Thread: No music after resume from hibernation until user input

  1. #1
    BGH
    BGH is offline
    Low Bitrate
    Join Date
    May 2006
    Location
    Melbourne, Australia
    Posts
    109

    No music after resume from hibernation until user input

    I have a problem whereby after resuming from hibernation the system doesn't start responding until after there is input from the user such as mouse movement or a key press. To say it is frustrating is a bit of an understatement.

    Originally I thought it was a bug with the front end I use Centrafuse so I created a thread.

    http://www.mp3car.com/vbulletin/cent...hibernate.html

    After a bit more investigation it seems as though there are other threads with exactly the same problem in other front end sections

    RESUME after hibernate frodoplayer paused until user input

    http://www.mp3car.com/vbulletin/road...ight=hibernate

    So I thought that I would create a more generic thread in this section so that it gets a bit more exposure and hopefully someone can help come up with a resolution.

    Can anyone think why the system would just hang after resume and then just spring to life perfectly as soon as a small mouse movement is made?

  2. #2
    BGH
    BGH is offline
    Low Bitrate
    Join Date
    May 2006
    Location
    Melbourne, Australia
    Posts
    109
    I should probably mention my hardware I suppose, I am using a mac mini core solo that boots directly into Windows XP

  3. #3
    North of the land of Hey Huns
    Auto Apps:loading...

    Join Date
    Jun 2004
    Location
    Westminster, MD
    Posts
    2,127
    It seems that possibly whatever those players are using to know that you have resumed from hibernation isnt triggering until you move the mouse/provide some kind of input to the operating system. This afternoon I'll play around with some WS_SHELL hooks and see if it's possibly one of them. It'd be interesting to find out of there are any similarities in how the effected different frontends detect going in, and coming out of hibernation.

  4. #4
    FLAC Machinehead's Avatar
    Join Date
    Jun 2007
    Location
    hijacks small portable city
    Posts
    1,381
    Quote Originally Posted by BGH View Post
    I should probably mention my hardware I suppose, I am using a mac mini core solo that boots directly into Windows XP
    I have the same issue with Mac Mini core duo. Never figured out a way around it either.

  5. #5
    Low Bitrate
    Join Date
    Jun 2007
    Posts
    77
    I had that exact issue on my old setup (gateway M405 laptop w/WinXP Home). I swapped out the laptop for a mini-ITX solution, reinstall of XP Home and that issue is now gone. I think the problem was a hardware driver not resuming from hibernation until user input occurred...

  6. #6
    BGH
    BGH is offline
    Low Bitrate
    Join Date
    May 2006
    Location
    Melbourne, Australia
    Posts
    109
    What is frustrating is that if I use a different mp3 player it resumes from hibernation fine and continues playing. But when using Centrafuse it doesn't. Like malcom2073 said, it's like all the frontends are using a similar method for their resume process that isn't quite working.

Similar Threads

  1. Requests
    By CdRsKuLL in forum FreeDrive
    Replies: 118
    Last Post: 08-11-2006, 06:09 AM
  2. Replies: 22
    Last Post: 08-06-2006, 04:57 PM
  3. Resume after hibernate scrutinized
    By ldave in forum PowerVoice
    Replies: 6
    Last Post: 02-10-2006, 12:04 AM
  4. No music returning from hibernation
    By RoyN in forum Road Runner
    Replies: 15
    Last Post: 06-16-2005, 01:55 AM
  5. Replies: 23
    Last Post: 05-27-2005, 04:46 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •