Results 1 to 4 of 4

Thread: To mute or not to mute... Okay but how ?

  1. #1
    Maximum Bitrate DeltaFX's Avatar
    Join Date
    Sep 2004
    Location
    France
    Posts
    499

    To mute or not to mute... Okay but how ?

    Hi,

    Here's the problem : I'm coding the (n+1)th beta version of my frontend (in delphi 7) and I still can't see how to mute the Audioplayer when the GPS part(sygic) needs to talk.

    Do I need sygic's SDK ?
    Now Galileo is real. Muhahahahaha :p

  2. #2
    Vendor - Qube colin's Avatar
    Join Date
    Dec 2006
    Posts
    796
    You're coding in Delphi 7?

    Thats incredible, how far along are you? Im coding in CodeGear 2007 but technically it's almost the same thing. Perhaps we could share some code to make it easier on both of us?

    Sorry, I don't know the answer to your question though. You would probably need the SDK of the GPS program you're using. Either that, or the GPS will already have an option to mute everything while it's speaking...

  3. #3
    Maximum Bitrate DeltaFX's Avatar
    Join Date
    Sep 2004
    Location
    France
    Posts
    499
    That is the question, I don't know if sygic has such an option. I use the 7.0 version.

    Yep, delphi7. Actually, the thing is working quite fine but I'm rewritin' it because the last version had forms partially overlapping each other as I wanted the screen to replace the windshild internal mirror, so rear cam had to always be visible (and cropped).

    I use bass.dll for audio playback, videocapx for webcam / video playback. The prog currently support only the velleman K8055 for hardware monitoring, speedfan,and eventually i'll add support for USB-1wire temp sensors. it's dev'd on a win98se setup and has already been tested on :

    My old P233 : win95(SR2) it works (sort of) but no webcam, no video playback

    UglyBox : K6 II 450 MHz, 256 mo, win2k SP4, ancient UDMA-2 hdd : not fully tested but only use 45% with an USB1.1 quickamPRO 4000, video/dvd playback is choppy, unusable.

    BigBox : the main rig, XP 2500+ @ 2 GHz (12*166) 512 mo TI4800 SE : everything fine. With all function used it take 28 % cpu.

    The future-carputer-without-name-yet : Asrock K7S41GX, GeodeNX 1.4 Ghz, 1Go ram, win 2k SP4 : Everything is perfect.

    But this frontend will probably never hit the "Release Canditate" state.
    Now Galileo is real. Muhahahahaha :p

  4. #4
    Vendor - Qube colin's Avatar
    Join Date
    Dec 2006
    Posts
    796
    With some quick Googling, it appears that people wrote a patch for Centrafuse to mute music while Sygic was talking. You could hack around that if you wanted to.

    So your system is very very customized to only work with your hardware then. Well if you ever need code shoot me a message because Ive got a fair bit working. Mines very customized as well though, but my DVD playback uses VLC media player and is never choppy...

Similar Threads

  1. Messed up mute button?
    By VPrime in forum Road Runner
    Replies: 1
    Last Post: 03-15-2007, 01:27 AM
  2. Mute Button / Flashing light
    By Ghost70 in forum RR Bug Tracker
    Replies: 1
    Last Post: 02-14-2007, 11:59 PM
  3. Problem with Audio Mute in MM/Road Runner
    By wizz in forum Map Monkey
    Replies: 5
    Last Post: 04-21-2005, 09:13 PM
  4. Line In Mute problem with Radio...
    By ShawJohn in forum MediaCar
    Replies: 1
    Last Post: 08-20-2004, 05:21 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •