Results 1 to 9 of 9

Thread: Windows 7, Garmin, Overlay...MADNESS!

  1. #1
    Maximum Bitrate
    Join Date
    Jun 2007
    Location
    St. Louis
    Posts
    631

    Windows 7, Garmin, Overlay...MADNESS!

    Wasn't sure where to post this and I didn't find anything on the search so here's the situation....

    Just reloaded EVERYTHING on my carpc. Clean install of Win7 home premium....riderunner, a couple skins, Garmin, and iGuidance, and winamp....

    it boots fast. Very responsive...but when go to the Garmin screen....it will load and then the overlay disappears and just shows garmin. To get the overlay back, I minimize garmin and the overlay comes back and re-sizes Garmin. Then when I add the destination and garmin switches to the map, it disappears back to no overlay and the navigation loading screen. Touch the screen and Garmin comes back....but no overlay. And the process repeats.

    Wife stole my car so I don't have it here to mess with...but is this something that's an "easy" fix? something which doesn't require re-installing everything?

    It seems that each time I try windows 7, something goes wonky and end up going back to xp. I was hoping I could keep 7 on here this time since it boots really fast without any tweaking.

    I'll keep searching in the meantime. Thanks.

  2. #2
    Maximum Bitrate
    Join Date
    Jun 2007
    Location
    St. Louis
    Posts
    631
    Am I the only person with this issue? I may set all the relating executables to run in xp compatibility mode....short of that working I guess I'll go back to XP + ewf/fbwf.

    I might re-install w7 again...but that's getting old.

  3. #3
    Newbie hannes's Avatar
    Join Date
    Feb 2007
    Location
    South Africa
    Posts
    2
    Hi Nst6563,

    I don't feel so alone anymore!
    I am having the same problem. Also running Win7. I have done the following: Reinstalled Win7, reinstalled Garmin MobilePC. Same problem.

    I would be so greatfull if someone could help.

    I will let you know if I find a fix.

    Regards
    Hannes

  4. #4
    Newbie
    Join Date
    Aug 2010
    Location
    San Antonio
    Posts
    48
    Quote Originally Posted by hannes View Post
    Hi Nst6563,

    I don't feel so alone anymore!
    I am having the same problem. Also running Win7. I have done the following: Reinstalled Win7, reinstalled Garmin MobilePC. Same problem.

    I would be so greatfull if someone could help.

    I will let you know if I find a fix.

    Regards
    Hannes
    With 13 years experience in PC Repair/IT, it sounds like you both need to update your Video Drivers. Let me know if that works. Make sure they are NOT the windows drivers, but the ones from the manufacturer (Nvidia/ATI)

  5. #5
    Maximum Bitrate
    Join Date
    Jun 2007
    Location
    St. Louis
    Posts
    631
    I've got more than 13yrs and it's not the video drivers. I've tried driver versions from the 180's to the 260's (all nvidia). In fact, the newest versions of the nvidia drivers on my system interfere with the touchscreen causing the screen to flash on and off and the system to repeatedly re-detect the touchscreen. I had just built the setup with win7 and put it in the car...then that started happening. Thought one of the usb cables was loose and messed with that, even ran new cabling. Same result. The issue only went away when I uninstalled the nvidia 260 series driver and went back to 195.

    The overlay issue exists whether I use the default windows driver, or if I use the nvidia driver. Thought it was a win7 compatibility issue (and still think it is) so I set it to run in Windows XP sp3 and run with admin rights - no change. Disabled desktop composition, no change. Un-installed and re-installed RR, no change. Tried all RR graphics mode options - no change. Set Garmin as embedded app - no change.

    I'm going to try a re-install this afternoon if I have time to see if that fixes it.

  6. #6
    Constant Bitrate
    Join Date
    Sep 2008
    Location
    Western Australia
    Posts
    169
    Similar problem after changing to Win7 from XP. I ended up just putting button in the skin to bring Garmin back into focus when it disappears :/

  7. #7
    Maximum Bitrate
    Join Date
    Jun 2007
    Location
    St. Louis
    Posts
    631
    I did 4 re-installs yesterday after pulling the different editions from MSDN. Started with what I was using, Windows Starter. Same problem - even with the compatibility options checked. Next I moved to Home Premium- same results. Then Professional, same result. And finally installed ultimate. All had the same problem with the elcosmenu disappearing, and then Garmin disappearing.
    Drivers don't make any difference either. The problem occurs on windows drivers or nvidia. Even tried with nothing else but Riderunner and Garmin installed. Same problem.

    working on something else now... since windows settings don't seem to help, possibly trying to keep elcosemenu on top when RR doesn't have focus will work.

  8. #8
    Maximum Bitrate
    Join Date
    Jun 2007
    Location
    St. Louis
    Posts
    631
    fyi - loading Garmin on system start seems to help matters. It still acts a little wonky though and Garmin disappears altogether leaving the plain blue "loading navigation screen".

  9. #9
    Maximum Bitrate
    Join Date
    Jun 2007
    Location
    St. Louis
    Posts
    631
    ditched the whole overlay...it was cool and all...but the tablet pc input was a much better option on win7. Simply make/edit a skin for gmpc, run tabtip.exe on system start. It docks itself to the left (if you chose to), and to input you can switch from keyboard to free-hand input and write the letters out, click insert and it pops it into gmpc.

    or do something like in the overlay thread where they created their own skin and used free virtual keyboard with an autoit script.

    Unless someone comes up with a better overlay...it looks like the original is mostly un-usable on w7.

    at least you can "skin" gmpc with girsplit and make some of the boarders smaller.

Similar Threads

  1. Windows 7, Garmin Mobile PC, and ultra-low volume
    By nst6563 in forum Software & Software Development
    Replies: 13
    Last Post: 08-01-2010, 08:17 PM
  2. MS is planning a Windows Store for Win 8!
    By RipplingHurst in forum Software & Software Development
    Replies: 9
    Last Post: 07-09-2010, 09:47 AM
  3. StreetDeck Functions
    By god_of_cpu in forum DigitalMods (Scripts / API)
    Replies: 22
    Last Post: 01-15-2008, 10:44 PM
  4. A few observations in OS and why I'm now using Windows 2003...
    By Mastiff in forum Software & Software Development
    Replies: 12
    Last Post: 01-21-2004, 09:11 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •