Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: A few observations in OS and why I'm now using Windows 2003...

  1. #1
    Constant Bitrate
    Join Date
    Apr 2003
    Location
    Norway
    Posts
    136

    A few observations in OS and why I'm now using Windows 2003...

    My car system has undergone a major change the last week after a lot of experimenting. The main reason is ease of use and reliability. I have now a 100 % reliable setup in my house, with two computers running a multi-zone sound system and a home theater. Everything is so easy to use and so reliable that my eight year old son can use it. He still asks me before he uses the home theater, but one of these days I'm sure I'll find him down there watching Star Wars or Jurassic Park without us knowing it... It took two years before I got my wife to use the system regularly, mainly because the two first years I used one zone with Media Center (then Media Jukebox 8) and two zones with Winamp, probably the most unreliable piece of software I have ever seen! It has a very bad habit of changing what sound card it has playback on every time you change the default sound card (and my play list selecter system in Girder relies heavily on changing default sound card for each button pressed for audible feedback (you'll hear "one" in Norwegian when the system has sensed a button press of 1 on an IR remote)). So now that this works perfectly (you can see it on my homepage, btw) the time had come to the around 80 % reliable car system. For the WAF (wife acceptancy factor) that score's exactly 20 % too low. And that is the main reason for my week of "play".

    I have now started using Windows workstation 2003 (which is basically the standard version of the Windows 2003 Server with a bunch of changes and tweaks). I believe I have found the perfect answer for my system. You may have other requirements (in fact if you're a small footprint fan you might as well go on to the next message - there's nothing for you here), but there may be something interesting for some of the rest here.

    I have had a carputer for a few years now, started up with old trash (Celeron 450 with Windows 98SE) and then bought my current system in the fall of 2002, I believe. With a few changes and modifications it now looks like this, in my 1995 Chevrolet Suburban 1500 5,7 4x4:

    Plywood tool suitcase with diamond patterned aluminum foil outside
    MSI M2M Combo socket A mobo (can take both SDRAM and DDR)
    AMD XP1800 with Igloo Silent Breeze cooler
    2 x 128 meg 133 SDRAM
    2 Soundblaster Live! 5.1 with kX drivers (lets you address each output plug as separate sound cards)
    Trendnet 54 mbit PCI WLAN card
    IBM 120 gig harddrive
    Maxtor 160 gig harddrive
    Cheap *** powersupply with fan mod (pretty silent)
    Papst 120 mm case fan in top, run at 7 V in the summertime, with a rheostat that's turned for even quieter operation the rest of the year

    300 watts inverter controlled with relays in this fashion: The 12 V output on one of the harddrive connectors keeps the relay open so power comes to the inverter when the computer is running. When the computer shuts down or hibernates the power is cut after about 3 seconds and the inverter shuts down. To start the inverter I have a push button jumpstart on the dashboard. I press it for about one second, which is enough for the computer to start booting (of course it's set to fire up when the PSU gets power). Also there's a second button on the dash which is used to send the computer into hibernation (it's just an extension of the regular ATX power button with the OS set to go into hibernation when the power button is pressed) or in extreme cases (which I hope I'll avoid from now on) to turn it off brutally by holding it in for three seconds. The next time power is applied the computer will do a full boot.

    The most important parts of my current software setup are:
    OS: Windows 2003 Server set up as workstation
    Audio Player: J.River's Media Center 9.1 version 313 witgh multi-zone capabilities used to give one zone to the car audio system and two zones to the two kids in the back seat with very nice JVC old school big headphones - they block almost all the sound from the car and the car audio system, so they won't have to turn the volume up all that much to be able to hear their own stuff
    Video/DVD Player: ZoomPlayer with WinDVD Platinum 5 video filter, AC3 filter audio filter and ffdshow for added extras (this is not yet in use in the car since I haven't got a monitor yet - I'm still wondering if I should build a CRT monitor into the mid console between the front seats or get a used LCD, hack it up and put it on a hinge from the roof)
    FileSync 2.18 for keeping the collection up to date (the car system is basically the backup I need for my home system - I don't want to loose 40 000 tagged and treated mp3 tracks and a bunch of digital photos because of a power spike or something, so I had to have a full backup anyway)
    Girder - the glue that keeps it all together

    The control is done in three ways:
    1. NetRemote with my Ipaq 5450, PocketLoox 600 or SIMpad via WLAN
    2. Two IR remotes for the kids in the back seat
    3. An ATI Remote Wonder RF remote in the front of the car that can control both the zone that goes to the car audio system and the kids' zones (nice to be able to pause them and tell them something they need to hear)

    Car audio system:
    Midrange Pioneer headunit with AUX box for the carputer
    Alpine DDDrive speakers in the front doors driven by a 2x50 watt speaker
    Magnat 16x9 speakers in the rear doors driven by the headunit
    Custom built approximately 140 litre bass reflex subwoofer behind the back seat with two JL Audio 12" subs driven by a Soundstream Li'l Wonder (but believe me, the sound is huge!)

    So this last week I have experimented while on the job (I'm a selfemployed translator and can work while the computer is installing and rebooting, and it only takes a little input to do all this testing) and I have found a few very surprising conclusions (at least to me). The result is that I'm using Windows 2003 server set up as workstation. Let's first have a look at my main gripes with XP:

    1. A few days ago I asked about hibernation times, and I got a few answers. But not the ones I wanted. It seemed that most people were satisfied with a return from hibernation between 20 and 30 seconds.

    2. A year ago (maybe) I asked about Windows XPs biggest problem when it comes to automation in automobiles: If you start a return from hibernation and something happens (like my wife often does - press the pc start button on the dash first and then turning the iginition key) you'll get a screen that tells you that the pc had a problem returning from hibernation, and do you want to delete the hibernation data and do a normal boot. This is of course very difficult to see without a monitor and it's one of those things that does not help the WAF of the system!

    3. I measure a reboot from the moment I press "restart" to the second the music starts playing on MC9, not a boot since when I'm not resuming from hibernation a reeboot is more common than a regular boot. With the original XP carputer system I had a boot time on around one minute and six seconds. That was on a heavily tweaked system with all unnecessary services disabled, heavy use of bootvis and all the boot speading tips I could find here.

    So first of all I tried a fresh install of XP, with no services disabled, no tweaks at all except for my little bootvis, and I got a boot time of...one minute and six seconds! And the old system was not weighted down with anything special. So obviously that was the time I could expect on this motherboard and with these sound cards, harddisks and the wireless network card. And maybe a lot of the disabling of services and other tricks really doesn't do all that much?

    Then, in the beginning of this week while reading an OS thread here in the forum, I saw a guy recommending Windows Server 2003. No reason, no answers to later questions. Only those three words, I believe. Since I had it laying around (sometimes you get fringe benefits from being in business for yourself) I decided to try it. So in with the OS, and with a few PowerQuest Drive Image images on crucial points (to avoid a full re-install if something messed it up) I had it up and running in a couple of days (remember this was done while working full days translating, so we're not talking many hours of effective installation here). The first snag was that the old bootvis.exe did not work, but I managed to find an msi installation package that works on XP and 2003.

    And after a few turns of that the reboot time was...40 seconds! We're talking a 26 second difference, with everything else exactly the same. The same hardware, the same software installed with the same settings. The time to hibernate has gone down from 6 seconds to 4, and a resume is now down to 15-16 seconds (from I press the power button to MC starts playing), with 256 meg ram, while it used to be closer to 20 with 128 meg ram! So there is no doubt that the OS is faster in those respects. A slightly weird thing is that if I do a hibernation trace and then optimize it, the hibernation times will increase, but if I then do a boot+driver delays trace and optimize, the times will decrease to the original times again. Go figure!

    Finally, and what really makes me choose this setup, of course besides the fact that Micro$oft's server systems always has been so stable that you'll need to shoot them to make them crash if you don't do something totally idiotic (like putting them in a car, maybe? ) is that Windows 2003 will always resume from hibernation without prompts no matter how many times you pull the plug in the middle of a hibernation! So mission seems to be accomplished - I believe I have found the system that works perfectly for me. And if even one person bothered to read all this (which I'm going to use as a basis for a homepage about my car audio system some time this spring) I would really like to know!
    Tor - The MediaSUV

  2. #2
    Variable Bitrate MeanGT's Avatar
    Join Date
    Jul 2003
    Location
    Melbourne, Florida
    Posts
    378
    Quote Originally Posted by Mastiff
    And if even one person bothered to read all this I would really like to know!

    I read about 2/3's of it, ,, I have a relay setup similar to yours, except I have a second relay that turns the whole thing on when I turn the key forward
    My OLD Carputer: http://www.mp3car.com/vbulletin/showthread.php?t=17412
    Currently, Don't have a carputer :( I sold my lincoln and bought a '93 Acura Vigor, plan on putting a carputer in it one of these days. You can see my vigor at: This Site

  3. #3
    Variable Bitrate AlienEclipse's Avatar
    Join Date
    Jul 2003
    Location
    Dunedin - New Zealand
    Posts
    424
    Very interesting read. I would much love to see some pics of this setup. I might grab a copy of Win2003 from work and try it for myself.

    Is your website up and running already? what is the URL?

    EDIT: Don't worry i found your site - it needs work (no offence)
    We are, will have and forever will be...
    But not tommorrow!

  4. #4
    Constant Bitrate
    Join Date
    Apr 2003
    Location
    Norway
    Posts
    136
    I will take some pics one of these days. But I actually take offense, at least a little. Mainly because I don't think you have read the disclaimer:

    Oh, if you find this website's style boring, you're probably right. I'm not creative in the web design, just like with my audio and video I prefer functionality and simplicity.
    I have no knowlegde aboug or even interest in webdesign. I like to show people what's possible to create without spending all that much money and your comment is the first about the design that I've had in the close to one year I've had the site up. Everybody else has raved about the info and the system.
    Tor - The MediaSUV

  5. #5
    Variable Bitrate AlienEclipse's Avatar
    Join Date
    Jul 2003
    Location
    Dunedin - New Zealand
    Posts
    424
    Quote Originally Posted by Mastiff
    I will take some pics one of these days. But I actually take offense, at least a little. Mainly because I don't think you have read the disclaimer:

    I have no knowlegde aboug or even interest in webdesign. I like to show people what's possible to create without spending all that much money and your comment is the first about the design that I've had in the close to one year I've had the site up. Everybody else has raved about the info and the system.
    Don't get me wrong. I hadn't actually looked through your site before i wrote my last post (first impressions last). After Reading through the entire site, i must say extremely impressed. I say you've spent a lot of man hours on this setup - great job.
    I try not to offen when commenting about someones site, i'm not worlds best web designer or graphic artist myself. I'm just the sort of person who worries about the look rather than the content.
    We are, will have and forever will be...
    But not tommorrow!

  6. #6
    Constant Bitrate
    Join Date
    Apr 2003
    Location
    Norway
    Posts
    136
    Thanks! That's more like the comments I get. I don't really worry about the looks of my webpage, but I do worry about the looks of my system. Which is why I for instance spent five hours in the bedroom when we put up new wallpaper and a new carpet, building all cables into the wall and floor. I have 7 or 8 cables running half the length of the room, and they're all invisible. And then of course with all the stuff I do, and something that's supposed to be a regular social life and famliy life for a guy at almost 40, with two kids, there's not much time left for web designing. So I spend the time I have available for projects like that on the actual projects not the website look. But if anybody wants to make my site look better (for free, of course...) I'd be all ears!
    Tor - The MediaSUV

  7. #7
    Maximum Bitrate none's Avatar
    Join Date
    Sep 2003
    Posts
    586
    Good god! What a complex system! Very impressive. I myself have found Winamp to be very stable, but then I have a boring single soundcard setup, as I think most people do. I doubt many programs are developed with multiple soundcards in mind.

    Thanks for the tip on win2003. If I had read this 6 months ago I would definitely have given it a try, but my system is now in the car and rock-stable with win2000 (hate XP,) so i won't be messing with it. Maybe on the next go-round

  8. #8
    Newbie
    Join Date
    Feb 2002
    Posts
    50
    I read it all.
    Pretty interesting, altho only a little on the xp vs 2k3 issue.
    Nice multiroom/zone setup, i was going to do that at home but then realised i didnt have much use for it.!

  9. #9
    Raw Wave Defiler's Avatar
    Join Date
    Jan 2002
    Location
    Temple Terrace, Fl.
    Posts
    2,647
    Holy long posts Batman!!!

    Good read. I have a copy of 2003 lying around...Maybe in the future I will try this but not right now. Good luck with the set up.
    Aura MR62 (F and R)
    My Current MP3s
    IamDefiler.com

  10. #10
    mst
    mst is offline
    Constant Bitrate mst's Avatar
    Join Date
    Nov 2003
    Location
    France
    Posts
    139
    Hi Mastiff
    Thank you for a very interesting post and website.Just a small question,if I change from XP to Server 2003,will I have any problems with hardware or drivers,all that works under XP will work under Server 2003?
    My system is not yet installed,but I will need the pc to start before the car so I need something there can boot quickly(from closed or hib or sb).

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •