Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: BMW iBus problem - Not detecting Button Pressed

  1. #1
    Constant Bitrate captain_jim1's Avatar
    Join Date
    Nov 2002
    Location
    New Jersey
    Posts
    192

    BMW iBus problem - Not detecting Button Pressed

    So I Bought Rolf's iBus interface .. it's the Serial v4 (4 prong). I hook up the Cd-Changer iBus connector to the adapter (I'm assuming the brown wire is the ground).

    The problem is .. "simulating" button presses through iBus Analyser doesnt do anything. It says the action has been simulated, but nothing happens. Now, when I press the NEXT or PREV track button on the STEERING WHEEL it shows up in the iBus Analyser log. However, no other button presses appear in the log.

    What's the deal? I would love to get this thing working completely in both directions, but right now all I have are responses that those 2 buttons are being pressed,

    Any help would be greatly appreciated.
    -Brad
    83 mp320i
    99 mp323i
    _________

    7" Lilliput w/Touch, 150 W Opus, 2.4ghz P4 533fsb, 512 DDR 333mhz, GPS, WiFi Inet, 40g Maxtor 7200rpm, Laptop DVD/CD-RW w/USB2.0 Bridge, WinXP Pro.

  2. #2
    Constant Bitrate captain_jim1's Avatar
    Join Date
    Nov 2002
    Location
    New Jersey
    Posts
    192
    Come on somebody!
    -Brad
    83 mp320i
    99 mp323i
    _________

    7" Lilliput w/Touch, 150 W Opus, 2.4ghz P4 533fsb, 512 DDR 333mhz, GPS, WiFi Inet, 40g Maxtor 7200rpm, Laptop DVD/CD-RW w/USB2.0 Bridge, WinXP Pro.

  3. #3
    Constant Bitrate
    Join Date
    Feb 2006
    Location
    NWI USA
    Posts
    133
    I'll keep an eye out here as I am about to put one in my 5 series- I recall someone else saying something about hte 3 series and steering wheel buttons, maybe they will be along...

  4. #4
    Variable Bitrate Hark's Avatar
    Join Date
    Feb 2005
    Location
    Atlanta, GA USA
    Posts
    440
    How about posting up the .ini you're using?

  5. #5
    Constant Bitrate captain_jim1's Avatar
    Join Date
    Nov 2002
    Location
    New Jersey
    Posts
    192
    Quote Originally Posted by Hark
    How about posting up the .ini you're using?
    I'll have to grab it from my car .. but I didnt modify it from the original install. I think it's odd it picks up the steering wheel's NEXT TRACK button and only that one.
    -Brad
    83 mp320i
    99 mp323i
    _________

    7" Lilliput w/Touch, 150 W Opus, 2.4ghz P4 533fsb, 512 DDR 333mhz, GPS, WiFi Inet, 40g Maxtor 7200rpm, Laptop DVD/CD-RW w/USB2.0 Bridge, WinXP Pro.

  6. #6
    Constant Bitrate captain_jim1's Avatar
    Join Date
    Nov 2002
    Location
    New Jersey
    Posts
    192
    UPDATE: Loaded up mediaEngine and was messing around in the settings and noticed you could turn on IRMAN in the Remote Config tab. When I enabled this, all the IBUS commands started showing up in the log. I was able to very quickly train mediaEngine to respond to my steering wheel controls.

    I then made a splitter for my IBUS cable in the trunk (since the only oneback there is used for my BlitzSafe Aux-Input)... tada .. everything's up and running!
    -Brad
    83 mp320i
    99 mp323i
    _________

    7" Lilliput w/Touch, 150 W Opus, 2.4ghz P4 533fsb, 512 DDR 333mhz, GPS, WiFi Inet, 40g Maxtor 7200rpm, Laptop DVD/CD-RW w/USB2.0 Bridge, WinXP Pro.

  7. #7
    Variable Bitrate redbullah's Avatar
    Join Date
    Mar 2006
    Location
    Belgium
    Posts
    273
    i am having the same problem right now
    i'll try media engine tomorrow

  8. #8
    Variable Bitrate redbullah's Avatar
    Join Date
    Mar 2006
    Location
    Belgium
    Posts
    273
    Quote Originally Posted by captain_jim1
    UPDATE: Loaded up mediaEngine and was messing around in the settings and noticed you could turn on IRMAN in the Remote Config tab. When I enabled this, all the IBUS commands started showing up in the log. I was able to very quickly train mediaEngine to respond to my steering wheel controls.

    I then made a splitter for my IBUS cable in the trunk (since the only oneback there is used for my BlitzSafe Aux-Input)... tada .. everything's up and running!
    Alltough ibuscomm says that a keep alive signal has been sended, sometimes my amp strangely start with radio and keeps playing it untill i switch to cd. I have to remove the screen and re-attach the hu's controlplate which contains also handy mode button.

  9. #9
    Variable Bitrate redbullah's Avatar
    Join Date
    Mar 2006
    Location
    Belgium
    Posts
    273
    i've installed mediaengine and windows went mad.
    i don't get that installing a front-end can solve an ibus problem since captain jim doesn't say much about it. XPlite or nlite version causes mediaengine crash due the missing activex control.

  10. #10
    Registered User
    Join Date
    Aug 2004
    Posts
    93
    Still working on getting this to work. So far, i am down to the assumption that it could be the scripting in the .ini file if you have tested and know for sure that you are getting signal from your steering wheel by using iBUS analyser.

    The wierd thing tho....it works on my laptop, but not on my Carputer.
    My laptop has a different XP version of windows (came from factory-toshiba) while my carputer is running off an OLD XP version with updates from windows (via internet) SP2. My carputer worked before my formatting, but now its no good i am once stuck again...dont know what to do now

Page 1 of 2 12 LastLast

Similar Threads

  1. BMW 540 Touchscreen Complete!
    By sajid753 in forum Show off your project
    Replies: 58
    Last Post: 04-23-2007, 05:52 AM
  2. Replies: 2
    Last Post: 04-04-2005, 04:45 PM
  3. Replies: 6
    Last Post: 03-02-2005, 09:47 AM
  4. Lilliput Powering On/Off problem
    By masch in forum LCD/Display
    Replies: 0
    Last Post: 05-09-2004, 12:55 PM
  5. PC power button problem
    By BMp3W in forum Power Supplies
    Replies: 4
    Last Post: 10-12-2002, 03:36 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •