Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Streetdeck pauses for long periods of time on startup

  1. #1
    Low Bitrate EvilLawnGnome's Avatar
    Join Date
    Feb 2006
    Location
    Louisville, KY
    Posts
    107

    Streetdeck pauses for long periods of time on startup

    What version of StreetDeck is this bug report for?

    1.0.8.1


    Please give a basic description of the issue here.

    Streetdeck pauses for long periods of time on startup


    Is the systemt that is listed in your CarPC specs under your user name the same system where you encountered this bug?

    yes


    If no, please describe your system here.




    Please provide any relevent information regarding the issue you have encountered.

    This only happens every four or five times I resume from hibernation. Streetdeck will just show up as a black screen when Windows resumes, and will stay like that for about 45 to 60 seconds. I think I may have figured out the problem though, and I'm sure it wouldn't be to hard to fix with a quick update. I noticed that every time this happens, the songs in the queue get multiplied a few times. After restarting one or two more times, the growth is exponential and causes the system to hang for long periods. I'm not really sure what could be causing this in SD, but it could have something to do with the randomization algorithem, since it namely happens with random turned on. I'll get a report in next time it happens.
    Build Two:
    Planning: [==========]100%
    Purchasing: [=====---------]50% (Car just got broken into)
    Design: [=======-----]70% (Building a false panel to cover up my goodies)
    Install: [======--------]600% (Need to replace screen and beisel)

  2. #2
    Newbie SpottedBeaver's Avatar
    Join Date
    Mar 2007
    Location
    Allen, TX
    Posts
    43
    I am reporting that I also encounter this issue.

    This is also for 1.0.8.1 and my system is listed in my profile.

    I found that every time I resume from sleep, the queue is multiplied. If I have nine songs when I go into sleep there will be 18 when I resume, all double of the original 9. The next time it will be 36 and exponentially larger. When that queue contains several thousand of the same 9 songs, the startup is very slow.

    I do not have repeat or random play turned on.

  3. #3
    Low Bitrate
    Join Date
    Jan 2007
    Location
    In a house
    Posts
    96

    Queued music gets re-added after resume from hibernation

    What version of StreetDeck is this bug report for?

    1.081


    Please give a basic description of the issue here.

    Queued music gets re-added after resume from hibernation


    Is the systemt that is listed in your CarPC specs under your user name the same system where you encountered this bug?

    yes


    If no, please describe your system here.




    Please provide any relevent information regarding the issue you have encountered.

    It isn't EVERY time, but it is pretty frequent. Let's say I have 11 songs in my queue. If I hibernate, then resume, it has 22 songs (the same 11 put in the queue again). It seems to be when I leave the song playing during hibernation. The last time I paused playback prior to hibernation it did NOT do it.

  4. #4
    Constant Bitrate jsdr78's Avatar
    Join Date
    May 2006
    Posts
    151
    Quote Originally Posted by pickupthepace View Post
    What version of StreetDeck is this bug report for?

    1.081


    Please give a basic description of the issue here.

    Queued music gets re-added after resume from hibernation


    Is the systemt that is listed in your CarPC specs under your user name the same system where you encountered this bug?

    yes


    If no, please describe your system here.




    Please provide any relevent information regarding the issue you have encountered.

    It isn't EVERY time, but it is pretty frequent. Let's say I have 11 songs in my queue. If I hibernate, then resume, it has 22 songs (the same 11 put in the queue again). It seems to be when I leave the song playing during hibernation. The last time I paused playback prior to hibernation it did NOT do it.
    I am also having the same issue. queue music list readd after hibernation too. making it double, tripple etc

  5. #5
    Maximum Bitrate S4Per's Avatar
    Join Date
    Jan 2004
    Location
    Seattle, WA
    Posts
    782
    third.

  6. #6
    Maximum Bitrate S4Per's Avatar
    Join Date
    Jan 2004
    Location
    Seattle, WA
    Posts
    782
    a different twist on this: I see SD taking a long time (10-20 seconds) at various times when I hit the music button on the main screen, click the album art in the queue view, click artists from the music selection screen, and other music related things.

    I've only recognized it in the music modules, but perhaps it occurs elsewhere also. I do not see CPU spike with it, and once it happens, if I then repeat the same functions/actions, it goes quickly as usual. I use the -nodelaycomp and -nodelayload switches every time I run SD.

    I have not noticed whether this is related to a large queue or not.

  7. #7
    Newbie natho's Avatar
    Join Date
    Jul 2005
    Location
    Adelaide, South Australia
    Posts
    3
    me also

  8. #8
    Raw Wave god_of_cpu's Avatar
    Join Date
    Jan 2004
    Location
    SilverSpring Maryland
    Posts
    2,960
    Should be fixed in the next patch.
    StreetDeck.com Developer (I am Chuck)
    Get StreetDeck at http://www.streetdeck.com
    The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

  9. #9
    Low Bitrate
    Join Date
    Jan 2007
    Location
    In a house
    Posts
    96
    Quote Originally Posted by god_of_cpu View Post
    Should be fixed in the next patch.
    Thanks Chuck.

    Ryan

  10. #10
    Newbie SpottedBeaver's Avatar
    Join Date
    Mar 2007
    Location
    Allen, TX
    Posts
    43
    Quote Originally Posted by god_of_cpu View Post
    Should be fixed in the next patch.
    Great!

    I believe that this is the same issue that was posted to and I added to here: http://www.mp3car.com/vbulletin/stre...e-startup.html

    Thanks Chuck.

Page 1 of 2 12 LastLast

Similar Threads

  1. Survey: Startup times and methods
    By gnomad in forum General MP3Car Discussion
    Replies: 56
    Last Post: 01-02-2007, 11:55 AM
  2. Replies: 5
    Last Post: 05-25-2006, 09:54 PM
  3. Startup Time Question
    By damato300 in forum StreetDeck
    Replies: 2
    Last Post: 05-12-2006, 09:08 PM
  4. Download StreetDeck Trial Version!
    By god_of_cpu in forum StreetDeck
    Replies: 43
    Last Post: 05-04-2006, 10:46 PM
  5. Boot Re-Ordering to Decrease FrontEnd Startup Time
    By DaRacerz in forum WinNT Based
    Replies: 4
    Last Post: 04-06-2005, 10:25 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •