Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28

Thread: resuming from hibernation in test mode, the Testmode confirmation dialog - 1.0.9.8

  1. #11
    Variable Bitrate
    Join Date
    Jul 2006
    Location
    Baltimore
    Posts
    313
    This is streetdeck operating as designed. When coming out of hibernation the focus is taken from SD. The first push is to select the window. The second is to select the option.

  2. #12
    Constant Bitrate
    Join Date
    Apr 2007
    Posts
    114
    Quote Originally Posted by StreetDeckAce View Post
    This is streetdeck operating as designed. When coming out of hibernation the focus is taken from SD. The first push is to select the window. The second is to select the option.
    Is there a way to make it where the window is automatically selected when resuming from hibernation so that we only have to click it once? It's quite annoying. I don't even really understand why there has to be a warning at all when resuming from hibernation because when the program first starts you see the dialog and have to acknowledge it. That itself should be enough to take liability away from the SD developers. Not to mention that to run it in testmode you have to add the testmode parameter to the shortcut, so obviously the user had to know he was doing that. I don't see how it popping up after every hibernate helps take anymore safety liability away from the developers.
    - Mike

  3. #13
    FLAC is for flaccid parksgm's Avatar
    Join Date
    Dec 2005
    Location
    Dallas, Texas
    Posts
    1,119
    Quote Originally Posted by StreetDeckAce View Post
    This is streetdeck operating as designed. When coming out of hibernation the focus is taken from SD. The first push is to select the window. The second is to select the option.
    That's not what happens on my system...it seems there are actually two seperate confirmation dialogs. When I dismiss the first, the screen displays the SD logo very briefly, fades to black, and then fades back into a screen with another confirmation dialog on it. When that confirmation dialog is accepted, the screen again displays the SD logo before fading to black and then back to the main SD screen.

    Is that expected behavior?

  4. #14
    Variable Bitrate
    Join Date
    Jun 2006
    Posts
    262
    Likewise i get this warning several times after a resume. Ive taken to closing SD and letting the laptop hibernate itself. That way when i restart and select SD i only have to cancel the warning once!

  5. #15
    Constant Bitrate
    Join Date
    Apr 2007
    Posts
    114
    I think I am going to try to find some mouse simulator software that can simulate clicking the dialog twice after resume to fix this problem for me. Ill let you guys know if i figure anything out
    - Mike

  6. #16
    Variable Bitrate
    Join Date
    Jul 2006
    Location
    Baltimore
    Posts
    313
    I am unable to recreate the issue of fading to black on my testing system. I will test on my car and laptop and report back. Until then if you could make a video, submit the logs or screen shots to show the issue that would be great.

  7. #17
    FLAC is for flaccid parksgm's Avatar
    Join Date
    Dec 2005
    Location
    Dallas, Texas
    Posts
    1,119
    Quote Originally Posted by StreetDeckAce View Post
    I am unable to recreate the issue of fading to black on my testing system. I will test on my car and laptop and report back. Until then if you could make a video, submit the logs or screen shots to show the issue that would be great.
    I'll post the logs as soon as I can...no good way to make a video at the moment though (other than a cell phone...or do you mean via screen capture software? If so, any recommendations?).

    I did confirm that touching the screen outside of the confirmation dialog after resuming from hibernation does not change the behavior...I still have to dismiss two dialogs before SD resumes even after an intial touch to bring SD into focus.

  8. #18
    FLAC is for flaccid parksgm's Avatar
    Join Date
    Dec 2005
    Location
    Dallas, Texas
    Posts
    1,119
    Quote Originally Posted by thepunkerguy View Post
    I think I am going to try to find some mouse simulator software that can simulate clicking the dialog twice after resume to fix this problem for me. Ill let you guys know if i figure anything out
    - Mike
    Try AutoIT...it's free, can replicate mouse movements and clicks, keypresses, etc, is easy to use, and is very scriptable. Google it.

  9. #19
    Constant Bitrate
    Join Date
    Apr 2007
    Posts
    114
    Alright, well I made myself a fix for this, figured i would share it just in case someone else wants it..

    Basically i just made a little program that, when ran, will click the mouse twice in the area of the screen where the "yes" button is for the testmode confirmation dialog on resume from hibernation. This ones i made only works with 800x600 and 800x480 screen resolution.. i could easily make it work with others.

    To make it work you need 2 things.
    1. My Program
    -----> 800x600 http://www.minitruckinguy.com/testmodebypass.exe
    -----> 800x480 http://www.minitruckinguy.com/testmodebypass800x480.exe
    2. Hibernate Trigger http://www.rpi.edu/~desimn/suspendtrigger/

    Just use hibernate trigger to run my .exe program each time the computer resumes and all should work out well. At least it does for me! Although, it did take a little playing with to get hibernatetrigger to work right for me.

    note: If they fix the bug where it requires us to click once, i will modify the program so it only clicks once instead of twice, that way we can still use it :-)

    (BTW: I assume no responsibility for how you use this information / program or the outcome. Use at your own risk!)

    - Mike

  10. #20
    Variable Bitrate
    Join Date
    Jul 2006
    Location
    Baltimore
    Posts
    313
    I am still trying to get the screen to go blank before I hit yes. Is there any thing else you are using that could cause this?

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Quest for 800x480
    By ptk in forum LCD/Display
    Replies: 451
    Last Post: 01-04-2010, 11:42 AM
  2. Static noise in music after hibernation - 1.0.9.8
    By MikeD610 in forum StreetDeck Bug Reports
    Replies: 10
    Last Post: 08-07-2007, 11:06 AM
  3. Problems resuming from Hibernation - 1.0.9.8
    By MikeD610 in forum StreetDeck Bug Reports
    Replies: 9
    Last Post: 07-26-2007, 04:01 PM
  4. Night Mode Issue - 1.0.9.8
    By Sinabl in forum StreetDeck Bug Reports
    Replies: 32
    Last Post: 07-18-2007, 10:43 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •