Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: SD Won't run with voice - 1.0.9.8

  1. #1
    Constant Bitrate
    Join Date
    Sep 2005
    Location
    Redmond, WA
    Posts
    188

    SD Won't run with voice - 1.0.9.8

    What version of StreetDeck is this bug report for?

    1.0.9.8


    Please give a basic description of the issue here.

    SD Won't run with voice


    Is the system that is listed in your CarPC specs under your user name the same system where you encountered this bug?

    Yes

    If no, please describe your system here.


    Are you able to reproduce this bug at will?

    Yes

    Please list the steps required to recreate the issue you are reporting.

    Simply run SD without "-novoice"
    Please provide any relevent information regarding the issue you have encountered.

    So it appears that SD just hangs while applying settings to the CVoiceInputModule. If I run with -novoice everything is fine, but I miss Heather

    Anyway, I rolled back to my DVD version (1.0.6.x, I believe) then ran the *online* update and it was working fine. Then I applied the 1.0.9.8 and kaboom - it hangs.

    I tried reinstalling SAPI (and then Acappela package) to no avail.

    Also, after it hangs it appears to completely lock the SAPI engine as no other apps are able to produce any voice after that point in time - a reboot is needed.

    Attached is a verbose log from such a run...
    Attached Files Attached Files

  2. #2
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    Chuck/Adam - updates?
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  3. #3
    Variable Bitrate
    Join Date
    Jul 2006
    Location
    Baltimore
    Posts
    313
    Can you play the voices in the control panel?

  4. #4
    Constant Bitrate
    Join Date
    Sep 2005
    Location
    Redmond, WA
    Posts
    188

    Yes and no...

    So the TTS control panel does not speak, but the TTSDemo app from SAPI DOES but only with Microsoft supplied voices.

    I also tried the Acappela voice test and it speaks just fine.

    Something must've gone whack with my SAPI installation though I am not sure what since I reinstalled it. Another interesting tidbit is that SD of prior version (1.0.6.3, I believe is the one I tried) works just fine.

    Mark

  5. #5
    Variable Bitrate
    Join Date
    Jul 2006
    Location
    Baltimore
    Posts
    313
    Are you using an external sound card? If so please check the audio output devices selected. Also try the Microsoft voices in SD and let me know if that works.

  6. #6
    Constant Bitrate
    Join Date
    Sep 2005
    Location
    Redmond, WA
    Posts
    188

    Yes, but...

    Yes, I am using an external sound card (always was). I would love to try with some other voice, but StreetDeck won't run so I can't get to the screen where I can change the voice. If I run with "-novoice" I can get to the screen but I can't save changes as I get an error message "An invalid argument was specified". Note that this is a regular Win32 message box, not skinned like rest of StreetDeck.

    Acapella voice test works fine and so do previous versions of StreetDeck. I tried another reinstall without any luck. I also did some selected cleaning of various class id and COM registrations in the registry and reinstalled SAPI without success. I will have a little bit of time tonight and will reformat the PC just for kicks - hopefully it makes the problem go away - I really miss SD.

  7. #7
    Variable Bitrate
    Join Date
    Jul 2006
    Location
    Baltimore
    Posts
    313
    Can you send a log in -verbose command line?

  8. #8
    Constant Bitrate
    Join Date
    Sep 2005
    Location
    Redmond, WA
    Posts
    188

    See first post

    I attached the log to the original post. That's all I got...

  9. #9
    Constant Bitrate
    Join Date
    Sep 2005
    Location
    Redmond, WA
    Posts
    188

    Question

    Is there any progress on this?

    I understand you guys are busy, which is why I think it would be very useful if you provided public symbols for SD (Public symbols?) so that those of us who have the skills can help you diagnose and fix the problems faster. You can create theses public (aka stripped symbol files) with BinPlace.exe available with Windows DDK (http://msdn2.microsoft.com/en-us/library/ms789520.aspx)

    Mark

    p.s. I am not trying to be pushy, just trying to help - I love SD and want to resume using it.

  10. #10
    Variable Bitrate
    Join Date
    Jul 2006
    Location
    Baltimore
    Posts
    313
    The original post says 1098 update. Try 1099?

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 38
    Last Post: 11-30-2010, 06:04 AM
  2. TTS voice volume
    By tooby in forum General MP3Car Discussion
    Replies: 4
    Last Post: 02-10-2007, 02:32 AM
  3. MapPoint 2006 Voice Prompts
    By CSharper in forum Road Runner
    Replies: 6
    Last Post: 10-28-2006, 02:39 PM
  4. Voice recognition problems. WinXP/Navivoice.
    By mikebaz in forum Software & Software Development
    Replies: 5
    Last Post: 08-07-2005, 04:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •