Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Song counter in playlist overlay doesnt't work - 1.0.6.3 - 1.1.0.0

  1. #1
    Constant Bitrate rxh81's Avatar
    Join Date
    Dec 2006
    Location
    Europe/Austria/Graz
    Posts
    162

    Song counter in playlist overlay doesnt't work - 1.0.6.3 - 1.1.1.0

    What version of StreetDeck is this bug report for?

    1.0.6.3 - 1.1.1.0


    Please give a basic description of the issue here.

    The song counter on the bottom left in the playlist overlay (e.g. "5 of 1156") doesn't work right. Most of the time it stops at 7. That means, if I have a queue of 500 songs and start scrolling down with the arrow button, the counter stops at "7 of 500", even if I play song 200. If I scroll back to song 3 it works again, but as I come over 7 again it stops by 7.
    Also sometimes it stops at an other position and rarely it works.

    Is the system that is listed in your CarPC specs under your user name the same system where you encountered this bug?

    Yes

    If no, please describe your system here.


    Are you able to reproduce this bug at will?

    I have the issue in my car and on my home PC, but it's not 100% reproduceable. Although I have the problem in 90% of the time, but not always in the same way.

    Please list the steps required to recreate the issue you are reporting.

    Just add something to the queue ;-).
    Mostly it occurs, if I go to "play all" or add an "auto playlist" to the queue.

    If you need further information on this, please tell me.

    Roland

  2. #2
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    I am still not able to reproduce this problem in my car or on my laptop.

    The next time it happens, please grab the log file and post it up here for us.
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  3. #3
    Constant Bitrate rxh81's Avatar
    Join Date
    Dec 2006
    Location
    Europe/Austria/Graz
    Posts
    162
    Hi Jan,

    first I have to mention that I remember, that this problem occurs first with 1.0.6.3 on my pc. (I have updated the report.)

    Here are two log files in verbose mode:
    1.) 2007-09-07 14_20.txt
    Program starting, load "Play all" in music module, scroll down and play another song, close program. The counter stucks at "7 of 1168", but works below 7.
    2.) 2007-09-07 14_21.txt
    Program starting, load "Play all" in music module, scroll down and play another song >>problem occurs 7 of 1168"<< clear playlist and add an autoplaylist to the queue >>problem occurs only "1 of 100" displaying<<, clear queue and add one artist with 15 songs to the queue >> no problem <<.

    I also added a video of the problem.
    Sorry for the blur, my handy cam doesn't have autofocus.
    The vertical lines on the right of the TFT is my brocken TFT *cry*.

    Roland
    Attached Files Attached Files

  4. #4
    Variable Bitrate
    Join Date
    Jun 2006
    Location
    Ventura County
    Posts
    323
    I see the same problem on mine.

  5. #5
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    I have actually just recently reinstalled Windows in my car and thus StreetDeck as well...I've noticed this same behavior now as well... strange.
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  6. #6
    FLAC strohj's Avatar
    Join Date
    Aug 2004
    Location
    Pearland
    Posts
    1,345
    I have this same problem...
    Pentium 4m 1.5GHz|MB896|Roadie Extreme|XM-Direct|Rikaline 6010|T-View 7"|Streetdeck|160gb Western Digital|1Gb DDR2-533 Ram

  7. #7
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    Please retest with the latest release and report back with your findings: Download StreetDeck Updates
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  8. #8
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    Please retest with the latest release (1.1.1.0) and report back with your findings.
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  9. #9
    Constant Bitrate rxh81's Avatar
    Join Date
    Dec 2006
    Location
    Europe/Austria/Graz
    Posts
    162
    Unfortunately no improvement :-(
    Same issues with 1.1.1.0.

    As you said, you also have this problem.
    Is it solved on your computer with this update?
    Why is this so hard to solve?

    Roland

  10. #10
    Raw Wave god_of_cpu's Avatar
    Join Date
    Jan 2004
    Location
    SilverSpring Maryland
    Posts
    2,960
    The problem is probably related to your music content. THe playlist in StreetDeck is a virtual list, meaning its not completely loaded until you scroll to it. Sometimes the list size can change if you scroll over items that aren't actually music or for some reason should not be visible in the list.

    In any case, its confirmed it is a bug, but its not easily reporducible, its not trivial to fix, and its not critical. It will be fixed, probably not for a while yet though.
    StreetDeck.com Developer (I am Chuck)
    Get StreetDeck at http://www.streetdeck.com
    The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

Page 1 of 2 12 LastLast

Similar Threads

  1. How About...A Virtual CD Changer
    By chuckster in forum Road Runner
    Replies: 33
    Last Post: 09-23-2011, 03:03 PM
  2. Replies: 16
    Last Post: 07-29-2007, 03:57 PM
  3. search playlist for specific song using keypad and char display
    By cheesyhoward in forum Software & Software Development
    Replies: 2
    Last Post: 05-12-2003, 07:34 AM
  4. duplicate song names in playlist?
    By ch0g in forum ME Archive
    Replies: 0
    Last Post: 03-13-2003, 06:22 AM
  5. Will this touchscreen overlay work?
    By tf82 in forum LCD/Display
    Replies: 1
    Last Post: 10-21-2002, 12:43 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •