Results 1 to 4 of 4

Thread: USB devices not working

  1. #1
    Newbie
    Join Date
    Jan 2008
    Location
    CT
    Posts
    6

    USB devices not working

    I recently upgraded my hardware to improve the performance of streetdeck. Aside from being slow, my previous install ran flawlessly, Navigation and XM worked without a hitch.

    Background:
    MP3Car USB XM
    GPS (generic bought on MP3Car.com a while back)
    Xenarc 700TSV (older model)
    DSATX Automotive PS
    All devices connected directly to motherboard (no hubs).

    I have the computer in a rough working state but have been unable to get consistent functionality. For example, the touchscreen portion of my touchscreen stops working at random intervals and it is difficult to recreate. Sometimes it might take several minutes after not pressing the screen, sometimes more. It always results in the screen not responding, however. I have done the registry fix for the touchscreen to keep it from shutting off after a certain idle time, but this has not fixed the problem.

    Likewise, I can't seem to get XM working again. I have FrodoSat Alpha 3 installed like some of the other posts suggest. It just sits there and says "Connecting".

    The navigation is probably the most confusing. I can get my computer to recognize the GPS receiver on COM3 (using "GPS info" program) and I get output from it. It can lock on to satellites in the program. However, Streetdeck never seems to be able to lock on to a satellite.

    Any suggestions before I do a fresh install of windows XP and/or streetdeck?

  2. #2
    Newbie
    Join Date
    Sep 2007
    Location
    Corona, Ca.
    Posts
    47
    I've got the same problem.

    After installing the drivers for MP3Car XM USB adapter, things seem to be much worse, although it did happen intermittently before that. My Wireless keyboard and touch screen just quit working whenever they feel like it. Sometimes, before they quit working, I hear the XP chime for a USB device being disconnected several times in a row and sometimes I here nothing at all. They just quit working.

    Sure would like some input on this one too.
    Getting quality goods and service is like buying oats. If you would like clean, fresh oats you must pay a fair price. If you would like oats that have already been through the horse, those are a little cheaper.

  3. #3
    Newbie
    Join Date
    Sep 2007
    Location
    Corona, Ca.
    Posts
    47
    Ok, my problem appears not to be StreetDeck related. I took my touchscreen and wireless keyboard off of my USB hub and plugged them in directly to the pc. So far they have worked without fail. It must have been coincidence that it got worse after install the XM Direct drivers.

    Does anyone have problems with their USB hubs loosing interest in working with their pc?

    I had two 4 port hubs (from MP3Car). One had only the IR touchscreen plugged in and it was powered. That hub was on a 10 ft extension cable. The other had a wireless keyboard dongle, a bluetooth dongle and a BU353 GPS (not powered) plugged directly into the pc. Both hubs had problems.

    Any thoughts?
    Getting quality goods and service is like buying oats. If you would like clean, fresh oats you must pay a fair price. If you would like oats that have already been through the horse, those are a little cheaper.

  4. #4
    Newbie
    Join Date
    Jan 2008
    Location
    CT
    Posts
    6

    Problem solved...sort of

    The solution I came to was to reinstall everything. I think after doing a lot of shuffling and deleting of programs some key files were missing. After I reinstalled windows everything started working again.

Similar Threads

  1. More USB Devices = Longer time to resume from hibernation?
    By nobb in forum General Hardware Discussion
    Replies: 3
    Last Post: 01-18-2008, 05:16 PM
  2. Problem with ITPS / hibernation and External USB HD
    By veetid in forum Power Supplies
    Replies: 5
    Last Post: 01-02-2006, 08:35 PM
  3. USB devices die off in 20 min. HELP ?
    By anik321 in forum General Hardware Discussion
    Replies: 5
    Last Post: 08-04-2005, 09:01 AM
  4. USB Radio - Radiator Extreme(5.1 surround) Semi Working!!
    By ChrisDunn in forum Software & Software Development
    Replies: 0
    Last Post: 08-02-2005, 10:20 PM
  5. How many devices on a USB 2.0 hub?
    By sohr in forum General Hardware Discussion
    Replies: 10
    Last Post: 06-04-2004, 06:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •