Results 1 to 10 of 10

Thread: XM radio woes

  1. #1
    Low Bitrate
    Join Date
    Nov 2006
    Posts
    75

    XM radio woes

    Well, I just built a new carpc for my 2009 Saturn Vue, and I'm using Streetdeck2. I never had this issue with my old carpc, but here goes:

    When I am listening to mp3's and switch to XM radio, the software works perfectly. It stops the Mp3 and switches to the line in for XM.

    When I switch from XM radio to Music/mp3's, the mp3 starts playing and the XM radio continues to play. The only way to stop the XM radio is to minimize streetdeck and mute the line in channel.

    I'm using Win7. Everything else seems to be working pretty well. I wonder how difficult it would be to add a button in streetdeck that mutes the line in?

    If I switch to Roadrunner, I do not have this problem.

    Also, I'm thinking about reverting back to XP to see if the issues are there as well.

    Here is my hardware:
    Asus Atom dual 1.6Ghz AT3GC motherboard
    PCI 7.1 Soundcard (Startech)

  2. #2
    Low Bitrate
    Join Date
    Sep 2007
    Location
    Raleigh, NC
    Posts
    106
    I have been a SD1 user for quite a while. Over the weekend I finally found the time to upgrade to SD2. Everything went smooth except for the satelite radio issue. The issue is that SD will not let you choose the sound card and line in for the radio. Without this, the program doesnt know which line to mute when switching back to other media.

    After fighting for hours I stumbled upon a solution (Dont ask me why it works, all I know is that it does). First, I completely uninstalled and reinstalled SD2. I then replaced the config directory (My Documents/Streetdeck/Config) with a backup copy from my install of SD1. After that the sound card and line in were no longer grayed out in the configuration menu.

    The only other note is not to install the new update. Once I did that, it stopped working. I attempted to replace the config directory again, but that no longer fixed the issue.

  3. #3
    Low Bitrate
    Join Date
    Nov 2006
    Posts
    75
    Hmmm, i wonder if there is something we could manually adjust in the config folder that would update the soundcard option?? I'll try to take a look at that folder tonight after work and see if I can track down where the sound card settings are stored.

  4. #4
    Maximum Bitrate jmullan99's Avatar
    Join Date
    Feb 2009
    Location
    Niagara Falls, Ontario
    Posts
    560
    I had similar issues with the voice guidance not muting, and playing media would not allow a volume adjustment (volume control -> more).

    I think it is related. Find and download a utility that re-registers Media Player DLLs. Won't hurt anything, and may fix your problem.

    I think the new StreetDeck somehow messes with the registration. I now leave a desktop icon shortcut to this utility for when I need it.

  5. #5
    Low Bitrate
    Join Date
    Sep 2007
    Location
    Raleigh, NC
    Posts
    106
    What is the name of the utility you use? Couldnt I just re-register them manually? Ill try it out later this week and see what happens.

  6. #6
    Maximum Bitrate jmullan99's Avatar
    Join Date
    Feb 2009
    Location
    Niagara Falls, Ontario
    Posts
    560
    Hmmm. Yes, you could re-register them yourself. Although I couldn't tell you which ones.

    Search for and download "Fix WMP Utility". It claims to re-register up to 40 DLLs. I cannot verify the actual count. It goes very quick though. Maybe 5 seconds. I exit SD (if it didn't crash) then run the utility from the shortcut, then start/re-start SD.

    Good luck and let us know how it went.

    John

  7. #7
    Low Bitrate
    Join Date
    Nov 2006
    Posts
    75
    Ahh, thanks for pointing me in the right direction. I'll try this when I get home this afternoon.

    -Troy.

  8. #8
    Low Bitrate
    Join Date
    Nov 2006
    Posts
    75
    Well I finally had a chance to try this out. I downloaded the application called FixWMP. I installed a fresh version of Windows7 and current chipset and audio drivers. Then installed Streetdeck2. Everything works fine, but I'm still having the same issue! When I switch from XM radio to MP3, it still does not mute the line in so that both songs play at once.

    Does anyone else have an idea??

    -Troy

  9. #9
    Maximum Bitrate jmullan99's Avatar
    Join Date
    Feb 2009
    Location
    Niagara Falls, Ontario
    Posts
    560
    Quote Originally Posted by tmproff View Post
    Well I finally had a chance to try this out. I downloaded the application called FixWMP. I installed a fresh version of Windows7 and current chipset and audio drivers. Then installed Streetdeck2. Everything works fine, but I'm still having the same issue! When I switch from XM radio to MP3, it still does not mute the line in so that both songs play at once.

    Does anyone else have an idea??

    -Troy
    Sorry it didn't help. Worked for me with media issues I mentioned. I wish you luck in finding a solution.

    John

  10. #10
    Low Bitrate
    Join Date
    Nov 2006
    Posts
    75
    Well, I think I have found a fairly painless solution to this. I have controls on my steering wheel that I haven't gotten around to wiring up, so I ordered the Joycon EX USB module. I am going to use the mute button on my steering wheel to toggle the line in mute. Thankfully the Joycon software is pretty robust and should have no problems setting this up. I'll be sure to post back when I have this installed.
    -Troy

Similar Threads

  1. Replies: 6
    Last Post: 08-30-2009, 11:31 PM
  2. Make RR go straight to the XM radio screen on startup
    By hailrazer in forum Road Runner
    Replies: 2
    Last Post: 08-28-2009, 10:00 AM
  3. anything wrong with hooking up xm AND radio to same line-in?
    By Sonicxtacy02 in forum General Hardware Discussion
    Replies: 47
    Last Post: 01-22-2008, 07:04 PM
  4. XM Radio in Car HELP!!!
    By CyberLogic in forum Software & Software Development
    Replies: 15
    Last Post: 07-19-2006, 08:44 PM
  5. Got XM to work, then it took a dump
    By DuDs in forum StreetDeck
    Replies: 3
    Last Post: 05-06-2006, 05:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •