Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: 1.0.4.3 all sorts of SAT radio problems

  1. #1
    Variable Bitrate rcdash's Avatar
    Join Date
    Dec 2004
    Posts
    236

    1.0.4.3 all sorts of SAT radio problems

    I have gone back to 1.0.4.2.

    Try switching to music after playing SAT - the SAT won't turn off. Can't turn SAT from playing no matter what I tried. Most of the problems occurred the 1st time I resumed from standby.

    SD crashed about 3 times. One of those times it hard locked going into standby the 2nd time.

    It was cool how it asked if it should restart the other 2 times, but still...

    It got frozen once just changing stations on SAT radio using touchscreen. Music mode and Navigation worked just fine. Only SAT radio seems really buggy in 1.0.4.3.

    Back to 1.0.4.2 and it all seems to be back working.

  2. #2
    Raw Wave god_of_cpu's Avatar
    Join Date
    Jan 2004
    Location
    SilverSpring Maryland
    Posts
    2,960
    Do you have your audio line input set and your XM radio going through the computer? It no longer sends the mute command to the radio device, just mutes the audio input line.

    I'll look into the other lockups.
    StreetDeck.com Developer (I am Chuck)
    Get StreetDeck at http://www.streetdeck.com
    The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

  3. #3
    Maximum Bitrate srcstc's Avatar
    Join Date
    Dec 2003
    Location
    New Jersey
    Posts
    572
    1.0.4.3 actually resolved some issues I was having with XM. I'd press a preset or a station and it wouldn't do anything. Now it's great.

  4. #4
    Variable Bitrate rcdash's Avatar
    Join Date
    Dec 2004
    Posts
    236
    Hmmm. I guess I can try it again - I ran into so many issues right in a row right after the update that I didn't investigate too much. Maybe something else was causing problems/lock ups? I switched back to 1.0.4.2 and I immediately got no more lock ups going into and out of standby so I am hesitant to try again.

    God_of_CPU: this is a a problem I've had all along with the Extigy. I know you've tried this and it works fine, but I've tried two different motherboards (first MB870, now MB896F) and installed the Extigy drivers and each time the SPDIF input is not available as a possible line choice. My XM outputs a coaxial SPDIF output right into the Extigy. (My Bose/Clarion HU feeds the analog line input). I can see the SPDIF playback volume on the volume mixer and in girder and in that debugging program you sent to me that enumerates the sound card functionality, but it is not an option in streetdeck. I can try reinstalling drivers from creative's website.

    I think its a bad idea to get rid of the mute radio device functionality altogether because in the future I can envision the output of the XM Direct going right into a preprocessor/line mixer that is carPC independent. Perhaps this can be an option for muting?

  5. #5
    Maximum Bitrate srcstc's Avatar
    Join Date
    Dec 2003
    Location
    New Jersey
    Posts
    572
    Quote Originally Posted by rcdash
    My XM outputs a coaxial SPDIF...
    What XM unit are you using?

  6. #6
    Raw Wave god_of_cpu's Avatar
    Join Date
    Jan 2004
    Location
    SilverSpring Maryland
    Posts
    2,960
    The lockups are coming from a new shutdown bug, it only happens if the "shutdown immediatly..." shutdown option is selected and only when the shutdown comes from the power button, not from shutting down in streetdeck.

    A patch should be released soon.
    StreetDeck.com Developer (I am Chuck)
    Get StreetDeck at http://www.streetdeck.com
    The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

  7. #7
    Variable Bitrate rcdash's Avatar
    Join Date
    Dec 2004
    Posts
    236
    Hmmm, I don't think I fall into that category. I had a 3 sec delay and went into standby mode using the power button.

    I reapplied the 1.0.4.3 update. I got SD to hang again, just pushing SAT radio stations. I had recording disabled, but I did have an input line selected for volume as well as for recording. I found that turning off / disabling the volume control as well as the recording line seemed to stop it from hanging (I changed stations about 20 times with no hangs). I also tested going into and out of standby and it works fine.

    I think my problem stems from using the Extigy (which I understand is not std hardware). I will try to figure out if I can fool SD into picking the right audio input line. Is there a registry entry that SD uses to determine which audio line is assigned to SAT radio for playback volume and recording?

  8. #8
    Variable Bitrate rcdash's Avatar
    Join Date
    Dec 2004
    Posts
    236
    SD is able to enumerate ALL of the lines of the onboard audio (even ones that don't exist - like SPDIF input, of which there is none on the MB896).

    I am completely perplexed why it enumerates some (always the same subset) of audio inputs / outputs on the Extigy, but skips others (like the SPDIF, which IS definitely present on the windows audio mixer etc).

  9. #9
    Raw Wave god_of_cpu's Avatar
    Join Date
    Jan 2004
    Location
    SilverSpring Maryland
    Posts
    2,960
    StreetDeck uses mixerGetLineInfo(hMixer, &Line, MIXER_GETLINEINFOF_SOURCE ) to get each recording line of the audio device. In theory, it should be the same thing that the windows mixer does to enumerate the input lines. It works fine on my SB Audigy and I don't know of any other way to enumerate them that could solve this problem.
    StreetDeck.com Developer (I am Chuck)
    Get StreetDeck at http://www.streetdeck.com
    The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

  10. #10
    Variable Bitrate rcdash's Avatar
    Join Date
    Dec 2004
    Posts
    236
    Quote Originally Posted by srcstc
    What XM unit are you using?
    XMDirect.

    With the help of another board member. See this link, I don't know if he sells this upgrade any longer as I did not see it on his site. Perhaps XM did not like it??? I think this is how I actually found out about mp3car.com - I was disappointed with the audio analog quality and was looking for digital output and came across this...

    XMDirect Dual Optical & Coax is here!

Page 1 of 3 123 LastLast

Similar Threads

  1. Stock Radio won't kick on?
    By IntellaWorks in forum Car Audio
    Replies: 38
    Last Post: 11-03-2005, 01:36 PM
  2. Feedback Please - Thoughts on hacking my radio
    By Dluvr22 in forum General MP3Car Discussion
    Replies: 2
    Last Post: 10-17-2005, 10:40 PM
  3. Radio problems sony xplode 8500 UK
    By brm in forum Car Audio
    Replies: 0
    Last Post: 08-20-2005, 02:12 PM
  4. DWW-700M/MTS12000 Motorized In Dash LCD Problems
    By techy101 in forum LCD/Display
    Replies: 17
    Last Post: 06-29-2005, 08:12 PM
  5. exiting CF in radio mode..
    By Frankino in forum Centrafuse
    Replies: 4
    Last Post: 02-08-2005, 12:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •