Results 1 to 10 of 10

Thread: Navigation always pointing North

  1. #1
    Low Bitrate gosmondson's Avatar
    Join Date
    Jun 2006
    Location
    Fresno,CA
    Posts
    85

    Thumbs up Navigation always pointing North

    Even when changing the settings for navigation, the map is always drawn with north up.. It also does not seem to be getting speed data, almost as the gps stream is corrupted. Using other gps programs the gps seems to function ok, but is a crap Pharos bluetooth gps.. Any ideas??

    Com = 7
    Hardware = HP Tc1000

    Using microsoft bluetooth stack to pair and setup comport for gps.

    Everything else on Streetdeck kicks ***, UI runs great and looks very smooth at ~24fps...

  2. #2
    Neither darque nor pervert DarquePervert's Avatar
    Join Date
    Apr 2004
    Location
    Elsewhere
    Posts
    13,948
    Have you verified the GPS datastream using some other app like GPSinfo or something to make certain the data isn't corrupted.
    Have you looked in the FAQ yet?
    How about the Wiki?



    Under normal circumstances, a signature would go here.

  3. #3
    Low Bitrate gosmondson's Avatar
    Join Date
    Jun 2006
    Location
    Fresno,CA
    Posts
    85
    I have in the past (when playing with FD and such other apps).. I did notice a previous post about an issue with Pharos gps, but it appears to have been fixed in 1.0.4.5.. I will try this tonight and see what comes out of the gps..

  4. #4
    Raw Wave god_of_cpu's Avatar
    Join Date
    Jan 2004
    Location
    SilverSpring Maryland
    Posts
    2,960
    Quote Originally Posted by gosmondson
    Even when changing the settings for navigation, the map is always drawn with north up.. It also does not seem to be getting speed data, almost as the gps stream is corrupted. Using other gps programs the gps seems to function ok, but is a crap Pharos bluetooth gps.. Any ideas??

    Com = 7
    Hardware = HP Tc1000

    Using microsoft bluetooth stack to pair and setup comport for gps.

    Everything else on Streetdeck kicks ***, UI runs great and looks very smooth at ~24fps...
    This is a known issue that should be fixed in 1.0.4.7.

    It seems to apply only to the newest version of the Pharos GPS. It doesn't send the same NMEA strings as most other GPSes.
    StreetDeck.com Developer (I am Chuck)
    Get StreetDeck at http://www.streetdeck.com
    The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

  5. #5
    Low Bitrate gosmondson's Avatar
    Join Date
    Jun 2006
    Location
    Fresno,CA
    Posts
    85
    thanks for the update, i was thinking about getting a cabled gps anyhow.. Ive always been bitten by BT (and pharos) in the past...

  6. #6
    is back. FKA Robert Wray
    Auto Apps:loading...
    Fiberoptic's Avatar
    Join Date
    Jul 1978
    Location
    Baltimore, MD
    Posts
    1,418
    Blog Entries
    143
    what problem did you have with the pharos? We were thinking about putting those on the store.

  7. #7
    Low Bitrate gosmondson's Avatar
    Join Date
    Jun 2006
    Location
    Fresno,CA
    Posts
    85
    Originally i had an igps180 (or 160??, its the cabled one for pocketpc's), their support was bad, they were also very very unresponsive.. I have not had to deal with them in 2~ years or so, so I can not comment on the current support levels.. Overall good hardware, I still have my old gps, still works great, just slower then the newer ones..

    As for Bluetooth, its just one of those quirky things, sometimes its flawless, makes everything look good and wireless (and blue. Other times you boot up and everything goes to hell, and you want to toss the blue out the window...

  8. #8
    Low Bitrate gosmondson's Avatar
    Join Date
    Jun 2006
    Location
    Fresno,CA
    Posts
    85
    I am going to try using GpsGate, it has a filter to block some NEMA strings..

  9. #9
    Low Bitrate gosmondson's Avatar
    Join Date
    Jun 2006
    Location
    Fresno,CA
    Posts
    85

    Talking Update!

    While GpsGate was great at splitting up the com port, it was not able to correct the NMEA problem with the Pharos.. The good news, I recieved my cabled GPS today and it works great..



  10. #10
    Low Bitrate gosmondson's Avatar
    Join Date
    Jun 2006
    Location
    Fresno,CA
    Posts
    85

    Update

    Using the newest software 1.0.4.7 the Pharos GPS works fine.. Keep up the good work!

Similar Threads

  1. Infiniti/Nissan OEM Navigation help
    By normandie in forum GPS
    Replies: 7
    Last Post: 02-12-2014, 01:58 PM
  2. 2002 Toyota Camry with Navigation Reuse Screen
    By PowerRock in forum LCD/Display
    Replies: 1
    Last Post: 02-10-2006, 08:38 PM
  3. Replies: 38
    Last Post: 12-31-2005, 05:39 PM
  4. Replies: 1
    Last Post: 10-18-2005, 10:24 PM
  5. BMW pre-installed system - TFT ?
    By tsingsu in forum LCD/Display
    Replies: 11
    Last Post: 08-05-2002, 02:16 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •