Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Skinning Issues 1.0.4.7

  1. #1
    StreetDeck Skinning Master 06TC_OWNER's Avatar
    Join Date
    Mar 2006
    Location
    Fort Collins
    Posts
    363

    Skinning Issues 1.0.4.7

    Skinning seems to be coming a little bit of a burden here. I can't modify anything within certain screens (i.e. nav) because it tells me "navigation failed to initialize properly. Is the navigation data properly installed?" Also, XM gives me access denied - why does the -testmode -d feature for the skinning environment not seem to work properly anymore?

    Is this a new bug with the 4.7 or what? Was testmode for skinning purposes eliminated?

  2. #2
    Raw Wave god_of_cpu's Avatar
    Join Date
    Jan 2004
    Location
    SilverSpring Maryland
    Posts
    2,960
    The navigation is probably a new bug.

    Do you have navigation installed on your dev box and XM radio?
    StreetDeck.com Developer (I am Chuck)
    Get StreetDeck at http://www.streetdeck.com
    The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

  3. #3
    StreetDeck Skinning Master 06TC_OWNER's Avatar
    Join Date
    Mar 2006
    Location
    Fort Collins
    Posts
    363
    I don't have the navigation installed or an xm radio - I do have an extra navigation antenna, but I don't have an extra xm radio lying around. I thought in demo/skinning mode, all of these things were supposed to have dummy data? Why was I able to skin these things before, but not now? Why does it block me now?

    Also, the skinning environment has become highly unstable. It would appear that every time I try to do something it crashes with no error messages. (Actually it says streetdeck has hung would you like to restart). And as a feature request, it would be really nice to be able to seperate the up/down arrows from the lists to move them around so I don't have to move the entire list around - the resize would work as well, but it only goes from small to too large...

    It is obviously going to be impossible to skin for now (which sucks, because we have a 4 day weekend to play). The grids keep disappearing while moving between screens, the environment keeps crashing, certain screens keep blocking me... and if I can figure this out, what are templates and how can I use them to streamline development? Is it possible to move the home and back buttons to a certain location in a template and have it populate across an entire section (i.e. nav)?

    Ok, here is what is happening: When a dialog pops up, it causes the grids for aligning items to disappear (until you restart the skinning environment). I think what needs to happen here is that every dialog needs to be disabled while skinning and we need full control over every screen whether those items are installed or not. How are you supposed to skin for ODBII interface, vehicle settings, xm, navigation, etc from inside your house? It isn't practical to setup an entire virtual car pc environment from inside your home just to create a skin (And I don't park my car in my living room, nor will I skin from my garage)!


  4. #4
    StreetDeck Skinning Master 06TC_OWNER's Avatar
    Join Date
    Mar 2006
    Location
    Fort Collins
    Posts
    363
    GOC? Any fix? I mean I know there are not that many people skinning right now, but this is what puts the personality in the engine...

  5. #5
    Raw Wave god_of_cpu's Avatar
    Join Date
    Jan 2004
    Location
    SilverSpring Maryland
    Posts
    2,960
    You should already be able to skin most screens without having any hardware installed. I was just asking to find out ehere the error was coming from.

    TestMode shouldn't do anything unless you have a GPSSim.txt in place or have a GPS hooked up. Nothing was changed for it in this release. What is the exact nature of the problem you are having with it?

    Also, what is the exact XM error you get?

    I'm working on an update that should be out in the next couple of days that will fix some other problems that are probably the cause of the general instabiliity.
    StreetDeck.com Developer (I am Chuck)
    Get StreetDeck at http://www.streetdeck.com
    The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

  6. #6
    StreetDeck Skinning Master 06TC_OWNER's Avatar
    Join Date
    Mar 2006
    Location
    Fort Collins
    Posts
    363
    "No comm port has been specified for the radio" If I specify a port, "Failed to open port on comm <port>."

    TestMode shouldn't do anything unless you have a GPSSim.txt in place or have a GPS hooked up. Nothing was changed for it in this release. What is the exact nature of the problem you are having with it?
    So how do I skin for the screens I can't access? More specifically, if I don't have the hardware installed, how am I supposed to access those screens without it erroring out on me? I don't mind fighting the constant crashes (although it is a pain in the butt), but I need access to EVERY screen.

  7. #7
    StreetDeck Skinning Master 06TC_OWNER's Avatar
    Join Date
    Mar 2006
    Location
    Fort Collins
    Posts
    363
    Is opening up these screens in testmode (or a skin mode) in mind for the next release?

  8. #8
    Raw Wave god_of_cpu's Avatar
    Join Date
    Jan 2004
    Location
    SilverSpring Maryland
    Posts
    2,960
    XM Radio and navigation will be editable without hardware
    StreetDeck.com Developer (I am Chuck)
    Get StreetDeck at http://www.streetdeck.com
    The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

  9. #9
    StreetDeck Skinning Master 06TC_OWNER's Avatar
    Join Date
    Mar 2006
    Location
    Fort Collins
    Posts
    363
    Ok, OBDII should probably be included as well.

    Thx

  10. #10
    Raw Wave god_of_cpu's Avatar
    Join Date
    Jan 2004
    Location
    SilverSpring Maryland
    Posts
    2,960
    Quote Originally Posted by 06TC_OWNER
    Ok, OBDII should probably be included as well.

    Thx
    OBDII will work too.
    StreetDeck.com Developer (I am Chuck)
    Get StreetDeck at http://www.streetdeck.com
    The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

Page 1 of 2 12 LastLast

Similar Threads

  1. Verizon Novatel 620 issues
    By MobiTekLink in forum Wireless Communications
    Replies: 30
    Last Post: 12-02-2005, 04:35 PM
  2. Having instability issues with your M7NCG 400 and/or XP install?
    By wallaceacura in forum General Hardware Discussion
    Replies: 0
    Last Post: 07-20-2005, 02:29 AM
  3. Power issues in 03 Mustang
    By tj!2k4 in forum Power Supplies
    Replies: 17
    Last Post: 12-22-2004, 02:16 PM
  4. Is skinning FP as easy as Winamp ??
    By Don 944 LA in forum FrodoPlayer
    Replies: 3
    Last Post: 09-27-2004, 10:52 AM
  5. Lilliput 7" VGA and EPIA M9000 issues...
    By heat in forum LCD/Display
    Replies: 9
    Last Post: 01-15-2004, 04:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •