Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: StreetDeck and minlogon

  1. #1
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500

    StreetDeck and minlogon

    MinLogon

    does not play well with SD for some reason.

    I was able to disable MinLogon and log in just as admin and I'm able to set up SD.

    Anyone have any ideas?
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  2. #2
    Low Bitrate McFreak's Avatar
    Join Date
    Mar 2005
    Location
    McKinney, TX
    Posts
    110
    Does it just bomb? I would think it has something to do with permissions. Doesn't minilogon "login" as system?

    I'll test it on my dev machine and see what it does...
    CarPC v2: Infiniti G35 Coupe 6MT, DW Housing, IBM R40, GPS, XM, StreetDeck

  3. #3
    Neither darque nor pervert DarquePervert's Avatar
    Join Date
    Apr 2004
    Location
    Elsewhere
    Posts
    13,950
    No, it's not permissions.
    We fogured out why it doesn't work w/ Minlogon.
    Basically, Minlogon logs you into the machine as SYSTEM. Streetdeck requires the user directory to exist. SYSTEM uses the Default User directory, and when you're logged in as SYSTEM that way, it has no idea to use what's in the Default User directory.

    I don't know if there's a way around this, though.
    Have you looked in the FAQ yet?
    How about the Wiki?



    Under normal circumstances, a signature would go here.

  4. #4
    Low Bitrate McFreak's Avatar
    Join Date
    Mar 2005
    Location
    McKinney, TX
    Posts
    110
    I got it working. It looks like the install missed some of the skin files in "Default User" I copied the Default folder from another location over the top of the one in "C:\Documents and Settings\Default User\My Documents\StreetDeck\UI\Skins" and SD comes up just fine.
    CarPC v2: Infiniti G35 Coupe 6MT, DW Housing, IBM R40, GPS, XM, StreetDeck

  5. #5
    Neither darque nor pervert DarquePervert's Avatar
    Join Date
    Apr 2004
    Location
    Elsewhere
    Posts
    13,950
    Well, I guess there is a way.
    Have you looked in the FAQ yet?
    How about the Wiki?



    Under normal circumstances, a signature would go here.

  6. #6
    Raw Wave god_of_cpu's Avatar
    Join Date
    Jan 2004
    Location
    SilverSpring Maryland
    Posts
    2,960
    Alternatively, you can just use the Edit Media Paths tool and manually remap the application data directory to the location of where your My Documents\StreetDeck folder was installed. If a path is not set, it will look in the My Documents directory of the current logged in user.
    StreetDeck.com Developer (I am Chuck)
    Get StreetDeck at http://www.streetdeck.com
    The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

  7. #7
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    so wait a second....I'm a bit confused (naturally)

    Here's what I've done so far:

    Initially installed SD under minlogon (Default User)

    Wouldn't run.

    Reverted back to the normal windows log on, logging in as Administrator.

    Copied the StreetDeck folder from: C:\Documents and Settings\Default User\My Documents\StreetDeck\

    And then ran StreetDeck.exe

    It started up fine.

    Now, I'm back in as Default User under minlogon, and I've copied the folder from: C:\Documents and Settings\Administrator\My Documents\StreetDeck\ back under Default User.

    Still the same thing, just an hour glass then nothing happens.
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  8. #8
    Low Bitrate McFreak's Avatar
    Join Date
    Mar 2005
    Location
    McKinney, TX
    Posts
    110
    Quote Originally Posted by RedGTiVR6 View Post
    so wait a second....I'm a bit confused (naturally)

    Here's what I've done so far:

    Initially installed SD under minlogon (Default User)

    Wouldn't run.

    Reverted back to the normal windows log on, logging in as Administrator.

    Copied the StreetDeck folder from: C:\Documents and Settings\Default User\My Documents\StreetDeck\

    And then ran StreetDeck.exe

    It started up fine.

    Now, I'm back in as Default User under minlogon, and I've copied the folder from: C:\Documents and Settings\Administrator\My Documents\StreetDeck\ back under Default User.

    Still the same thing, just an hour glass then nothing happens.
    Did you follow all the steps on that thread for EMF or did you just do the minlogon.exe replacement?

    Try starting StreetDeck with -info or -Verbose
    CarPC v2: Infiniti G35 Coupe 6MT, DW Housing, IBM R40, GPS, XM, StreetDeck

  9. #9
    Low Bitrate McFreak's Avatar
    Join Date
    Mar 2005
    Location
    McKinney, TX
    Posts
    110
    Also look here "C:\Documents and Settings\Default User\My Documents\StreetDeck\Log" and see what it's getting stuck on.
    CarPC v2: Infiniti G35 Coupe 6MT, DW Housing, IBM R40, GPS, XM, StreetDeck

  10. #10
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    OK - somehow I got it working.

    Editing the paths wasn't working for some reason.

    Between manually copying in the update and copying the folder over from Administrator (after having successfully installed SD) to Default User, things seem to work now.

    Just need the activation codes and I'm good to go!

    Thanks for the help all, it's greatly appreciated!

    The log didn't give me anything, just that it started then stopped.

    I think this had something to do with the updater, which Chuck said he's working on. Some issues with some computers and not with others.
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

Page 1 of 2 12 LastLast

Similar Threads

  1. Streetdeck wont load after installing Minlogon
    By tn6478 in forum StreetDeck
    Replies: 5
    Last Post: 08-14-2006, 08:55 AM
  2. Cannot load streetdeck after Minlogon
    By tn6478 in forum Operating System Optimization
    Replies: 0
    Last Post: 08-08-2006, 04:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •