Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 43

Thread: FAQ: XM Cable/XMD1000 Debugging FAQ (test program included)

  1. #21
    FLAC freeflashstuff's Avatar
    Join Date
    May 2008
    Location
    Socorro, New Mexico, United States
    Posts
    1,141
    For some reason i can't get any data from my XM Direct (xmd1000) box. I even tested the cable and everything is fine. I can't get any data reply out of my box. Maybe a bad serial port?
    Any suggestions?
    I have bad luck with vehicles...

  2. #22
    Who am I? HiJackZX1's Avatar
    Join Date
    Jul 2007
    Location
    Miami
    Posts
    6,557
    Quote Originally Posted by freeflashstuff View Post
    For some reason i can't get any data from my XM Direct (xmd1000) box. I even tested the cable and everything is fine. I can't get any data reply out of my box. Maybe a bad serial port?
    Any suggestions?
    Did you make sure it didnt install as a serial mouse? Go to device managaer and if you see serial mouse under mouse, then disable it and restart.
    Nirwana Project, the Android/Win 7 hybrid system!

    1X Ainol Novo Flame Tab
    4X MK808b
    3x Perixx Touchpads
    3x 7 inch Screens
    1X 7 inch motorized Screen
    1x Win 7 PC

  3. #23
    FLAC freeflashstuff's Avatar
    Join Date
    May 2008
    Location
    Socorro, New Mexico, United States
    Posts
    1,141
    When I do that, it never shows back up or gets recognized. Or it comes up as a serial mouse on the wrong com port.
    I have bad luck with vehicles...

  4. #24
    FLAC freeflashstuff's Avatar
    Join Date
    May 2008
    Location
    Socorro, New Mexico, United States
    Posts
    1,141
    ok, I was using the serial port monitor and I got a reply from the box. But it was the same thing that was sent. Is that a good sign?
    I have bad luck with vehicles...

  5. #25
    Constant Bitrate digeratix's Avatar
    Join Date
    Sep 2007
    Posts
    185
    I made a cable that I used with my carputer, from xm to the com port (serial port1) on my carputer. I sold all my stuff and have this left over.

    It's for sale and will save you time and frustration.

    Contact me


  6. #26
    Newbie
    Join Date
    Aug 2007
    Posts
    8
    Hey guys i am so stumped. I have my xm direct plugged in to the computer, and i can see read and writes with the serial port monitor software (when i am running roadrunner and make a change channel command) however... the road runner interface does not show signal strength or any channel data at all! just the list of channels!

    I tried to run the qbasic program but it said file not found in the program that runs the script i guess..

    anyone please help!!! i know my xm direct is not dead, but i cant get it to respond in any other program than roadrunner... and the only responses i can see are in the serial port monitoring software... not by any roadrunner response!

    thanks,
    Cody

  7. #27
    Who am I? HiJackZX1's Avatar
    Join Date
    Jul 2007
    Location
    Miami
    Posts
    6,557
    Quote Originally Posted by frozenbinary View Post
    Hey guys i am so stumped. I have my xm direct plugged in to the computer, and i can see read and writes with the serial port monitor software (when i am running roadrunner and make a change channel command) however... the road runner interface does not show signal strength or any channel data at all! just the list of channels!

    I tried to run the qbasic program but it said file not found in the program that runs the script i guess..

    anyone please help!!! i know my xm direct is not dead, but i cant get it to respond in any other program than roadrunner... and the only responses i can see are in the serial port monitoring software... not by any roadrunner response!

    thanks,
    Cody
    Maybe the XM Direct needs to update. Sirius XM just consolidated and rearranged alot of channels. They are basically merging everything togther. I use SiriusWM5 and it does not work correctly. I also have an XM Direct, but my PC is under repair so I cant confirm its that..... Have you tried Mitch's stand alone application? Here is a link to it. http://www.rush2112.net/index.php?in...y_view&iden=16 unzip it then double click the xm logo in the folder. A app should open up. On it a little green box will turn green if it detects the XM direct, you then see the song list start to load. If not then it doesnt see the XM Direct, and it could be a Com port issue, or Windows has installed it as a serial mouse. Go to device manager and look under mouse or mice. If you see serial mouse in the list, right click it and disable it, then restart your PC and try Xm Direct again. If you still have a issue then its either the cable or the xm direct.

    PS: just read your thread better.... try restarting and using the other software first. Maybe RR is holding onto the com port causing the other programs to not see it. Have you tried using hyper terminal to see if XM Direct is spitting out data?
    Nirwana Project, the Android/Win 7 hybrid system!

    1X Ainol Novo Flame Tab
    4X MK808b
    3x Perixx Touchpads
    3x 7 inch Screens
    1X 7 inch motorized Screen
    1x Win 7 PC

  8. #28
    Newbie
    Join Date
    Aug 2007
    Posts
    8
    i am running the program you told me to, and it says " initializing ". i open debug and it keeps sending the on command to the xm direct, and xm direct keeps spitting the same string back over and over and over

  9. #29
    Admin. Linux loser.
    Auto Apps:loading...
    Bugbyte's Avatar
    Join Date
    Sep 2004
    Location
    Corning, NY
    Posts
    7,359
    Blog Entries
    2
    Is your antenna plugged in and in full view of the sky?
    Quote Originally Posted by ghettocruzer View Post
    I was gung ho on building a PC [until] just recently. However, between my new phone having internet and GPS and all...and this kit...Im starting to have trouble justfiying it haha.
    Want to:
    -Find out about the new iBug iPad install?
    -Find out about carPC's in just 5 minutes? View the Car PC 101 video

  10. #30
    Newbie
    Join Date
    Aug 2007
    Posts
    8
    my antenna is hooked up, and i have it in a good spot,
    i am going to try an antenna from another xm radio i have lying around and see if it works... i let it go with roadrunner in the XM page all the way to work, and the xm page didnt load anything the whole way.

Page 3 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. FAQ: Installing XM Radio on Your Carputer, a Tutorial
    By Bugbyte in forum The FAQ Emporium
    Replies: 8
    Last Post: 03-14-2008, 12:36 AM
  2. XM Satellite Radio to Unveil XM Advanced Services at 2006 Consumer
    By Will Albers in forum General MP3Car Discussion
    Replies: 2
    Last Post: 03-27-2006, 08:49 PM
  3. XM Test Program
    By Viscouse in forum General Hardware Discussion
    Replies: 5
    Last Post: 08-28-2005, 04:15 PM
  4. XM Test Program
    By Viscouse in forum Newbie
    Replies: 0
    Last Post: 08-23-2005, 07:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •