Results 1 to 2 of 2

Thread: Review: Kenwood KDC-W6527 Head Unit

  1. #1
    Constant Bitrate chewiee's Avatar
    Join Date
    Apr 2004
    Location
    Kent, UK
    Posts
    128

    Review: Kenwood KDC-W6527 Head Unit

    OK, so I mentioned that I had managed to get my grubby little claws on the Kenwood KDC-W6527 for a steal at 150.00 (UKPounds).

    Well I have now installed it into my current car a Rover 216 Cabriolet and all seems quite good. I cannot for some reason get the amp to work, but I put this down to either a blown fuse or a setting not configured on the head unit yet!

    Installation was simple, everything came with it including the ISO plug. My Rover had one already fitted, by a mate who I bought the car off of.

    Once connected the sound quality is as can be expected for a Kenwood head unit that retails for around 300.00

    The front face folds down out of the way to insert a disc full of MP3's and as I currently have completed about as much of my carputer as Bush has made the world a better place I can only say that the iPod that I have connected to the Aux-In sounds pretty good.

    The front face can be angled at three different positions, and when the ignition is turned off, it closes itself back up against the unit, which is a nice touch.

    It has one of those poncy animated screens, which look great in demo mode, but it does seem to react the the tunes, so a little kudos there Kenwood.

    The display itself has two main knobs on it. The one on the left handles volume and telephone mute by being pushed it, whilst the one on the right gives the user access to the skip tracks, folders, cd bootloader, now if I could hook my carputer to this... I'd be happy

    Once my camera has charged, I'll take a few pictures to show how it looks installed.

    One thing though, there is a menu option to turn on the Aux-In or Line-In as some people call it. You have to make sure that it is enabled before you can select it from the source.

    The menu configuration on the head unit is superb, allowing a different source to be playing in the rear of the vehicle to the front, no use in a 2 door soft top, but I can see this being usefull in a Voyager or LWB 4x4 like a Vauxhall Frontera (which is where it will be going next, depending on if I keep the Rover for more than the summer)!

    The unit comes with a remote control, which is yet again redundant, but a nice added feature. Its got a few buttons, but nothing to write home about, as all the functions seem doable from the main unit.

    The unit can connect to DAB, and an additional component can be purchased to allow it to be controlled from steering controls if your car has them. It also has an adapter to connect to dash displays, allowing all the tune info etc to be displayed on the greenscreen lcd's that so many new cars now have.

    Overall score out of 10: 7

    Weaknesses:
    * It would be cool to choose what angle the facia is displayed at.
    * Control buttons feel a little soft and fiddly, I like a little amount of
    solidness, and I cant help but feel that they'll be ripped off by my
    delicate paws

    Strengths:
    * Looks very nice, better than the online pictures, it looks like its made
    of blue and white crystal. If that makes sense!
    * Has four channel amp out, and the internal amp can be turned off to allow
    a cleaner sound to be transferred to separate amp(s). This may be why
    the amp is not working for me yet.
    * Nice sound, but noticed that 128kbps mp3s sounded wishy washy
    * Plays WMA and MP3 (although I don't have one WMA)
    * RRP was a little steep, when all I wanted was a line in, but the
    additional functionality more than make up for it. Now if I could just
    sort out the damn amp!

    VW Mk2 Golf GTI 16V:
    Kenwood KDC-W6527 HU
    Silver Travla C134, Slot Loading DVD/CDRW,
    256MB, VIA Epia MII 12000, Carnetix 60W, Xenarc VGA/Composite TS and a GPS Mouse

  2. #2
    Constant Bitrate chewiee's Avatar
    Join Date
    Apr 2004
    Location
    Kent, UK
    Posts
    128

    Amp Not Playing

    The reason the amp was not making any noise is becase I had not connected the remote power to the rear of the Kenwood... monkey boy here really shouldn't be in charge of a pair of plyers, let alone shoes!!!

    Chewiee

    VW Mk2 Golf GTI 16V:
    Kenwood KDC-W6527 HU
    Silver Travla C134, Slot Loading DVD/CDRW,
    256MB, VIA Epia MII 12000, Carnetix 60W, Xenarc VGA/Composite TS and a GPS Mouse

Similar Threads

  1. Can a car-computer replace a stereo head unit?
    By CA 3000GT in forum General Hardware Discussion
    Replies: 22
    Last Post: 11-13-2006, 10:24 PM
  2. FS: Kenwood Aux In Stereo Head Unit adapter. $12.50 shipped to US.
    By LESLIEx317537 in forum Classified Archive
    Replies: 1
    Last Post: 04-27-2004, 09:14 AM
  3. EBAY: BRAND NEW Kenwood KDC-MPV8025 Head Unit
    By DarrylR in forum Classified Archive
    Replies: 0
    Last Post: 04-07-2004, 09:30 PM
  4. Connecting to a Kenwood Head unit
    By Twostep in forum General Hardware Discussion
    Replies: 26
    Last Post: 03-05-2001, 02:14 PM
  5. car head unit
    By BoneMan in forum General Hardware Discussion
    Replies: 1
    Last Post: 07-29-1999, 10:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •