Page 16 of 56 FirstFirst ... 67891011121314151617181920212223242526 ... LastLast
Results 151 to 160 of 558

Thread: HVAC Control on Car PC through Serial Port.

  1. #151
    Variable Bitrate markland556's Avatar
    Join Date
    Jun 2005
    Location
    Bellevue, WA
    Posts
    225
    Someone help him!! LOL
    my carputer project is on hold untill this is released because i was thinking i could incoperate some other features. Such as the rear head rest lower switch. and the little switch with the circle of arrows (no clue what it does). Just need to learn some VB first. LOL
    96' Mercedes Benz C36 -Matte Black-
    Status..::... {##------}25%~~ back to planning

  2. #152
    FLAC Mastero's Avatar
    Join Date
    Aug 2001
    Location
    India
    Posts
    1,640
    Thanks everyone for offering help..

    This is the part of the software where i have problem ...

    how it works ... when the software sends a T1 command to the PIC it returns "WAIT" and then reads the outside temp sensor and then the inside temp sensor and the sends "SEND" to the PC ..

    The problem is when i dont use the T1 command the command button when pressed will promtly send the "41p" to the PIC but when using the T1 command its like after the temp readings is done you cant immediately send any command to the PIC the port looks like its in input mode.......

    Hope someone can help..

    Thanx

    Mastero
    Attached Files Attached Files

  3. #153
    Variable Bitrate
    Join Date
    Jun 2005
    Location
    Michigan
    Posts
    311
    Im not 100% clear on the problem definition. The code seems simple enough, but Im just not clear on a) what the expected behavior is, and b) what the VB code is doing wrong.

    It looks as if the program sends "T1" every 1000ms and waits for the PIC to report temperatures. The command button sends "41p" immediately, IF the port is ready. Are you saying when you press the button, "41p" does NOT go out like it should because the comm is busy?

    About how long does it take for the PIC to finish sending its temperature data from the time it receives T1?

  4. #154
    Jesus Freak antimatter's Avatar
    Join Date
    Jan 2004
    Location
    California
    Posts
    4,545
    It looks like what he is saying is when he isn't utilizing the T1 command, after the tempature readings are done the PIC wont recieve any commands and the it appears to be in input mode.

    Mastero please clarify
    -Jesus- King of Kings Lord of Lords

  5. #155
    FLAC Mastero's Avatar
    Join Date
    Aug 2001
    Location
    India
    Posts
    1,640
    Quote Originally Posted by rsd212
    Im not 100% clear on the problem definition. The code seems simple enough, but Im just not clear on a) what the expected behavior is, and b) what the VB code is doing wrong.

    It looks as if the program sends "T1" every 1000ms and waits for the PIC to report temperatures. The command button sends "41p" immediately, IF the port is ready. Are you saying when you press the button, "41p" does NOT go out like it should because the comm is busy?

    About how long does it take for the PIC to finish sending its temperature data from the time it receives T1?
    see what happens is when T1 is sent the pic sends back the temp details max of 4 sec for both the temp sensor ... then the pic is ready to receive the next command but at this time when you press the command button the "41p" does not go through immediatly .. say after 10 sec .. its like the com is still in the input mode ..

    Pic is fine works from hyper terminal perfectly send T1 receives temp then send 41p works ...

    Its some how the com port is not ready to send the command immidiately after receiving the temp. i have even tried to put a "send" command in the pic when its ready to receive so the com know when to send .. but still there is a delay ..

    Mastero

  6. #156
    Newbie Zenith_Warrior's Avatar
    Join Date
    Mar 2005
    Location
    UK
    Posts
    47
    Code reads fine. I don't use the comm control much though, so forgive me if I'm wrong.

    Not sure I fully understand but it could be the comms buffer is getting filled and taking a while to read, you could try reducing the input buffer size (InBufferSize or InputLen?) from 1024 to 10 or something suitable.
    It may also be worth putting in a delay (4 seconds worth?) between these lines
    MSComm1.Output = "T1"
    NewTemp = MSComm1.Input

    to give the pic some time to send the temp details and then the program can read the results.

    like a "doEvents()" or put that in a for loop with 1000 iterations just to test to see if it helps.

    If the pic takes 4 seconds to retrieve a reading from the sensors then it maybe worth trying to increase the timer from 1000ms to 5000ms to see if that helps.

  7. #157
    FLAC Mastero's Avatar
    Join Date
    Aug 2001
    Location
    India
    Posts
    1,640
    Forget it tried eveything i could think off .. it just wont work ..

    This is the new working layout and the project is complete

    Shall post the price and the pics of the hardware and shall have a site for all the details.. This wont be a DIY project. There are a lot of calibrations required for it to work perfectly with the software ..

    Shall be sold in ready to use ...

    Cheers
    Mastero
    Attached Images Attached Images  

  8. #158
    Variable Bitrate markland556's Avatar
    Join Date
    Jun 2005
    Location
    Bellevue, WA
    Posts
    225
    just hope its not gunna cost too much
    is there any chance of me being able to add in my own things, because i really want to control like my rear headrests with this thing too. Can there be like a few extra channels that just give some signal that i can work with when the hardware gets a command from the comp??
    96' Mercedes Benz C36 -Matte Black-
    Status..::... {##------}25%~~ back to planning

  9. #159
    FLAC mauri's Avatar
    Join Date
    Jan 2004
    Posts
    1,039
    A note:
    is it possible to skinning the display area with 3 options color to like in the future release type my attached and 800 x 600 ?

    Mauri
    Attached Images Attached Images    

  10. #160
    Variable Bitrate markland556's Avatar
    Join Date
    Jun 2005
    Location
    Bellevue, WA
    Posts
    225
    just a question, is the source going to be released for the software. Because i would relly like to skin it a little more. Just so i can match it with the rest of my dash.
    96' Mercedes Benz C36 -Matte Black-
    Status..::... {##------}25%~~ back to planning

Similar Threads

  1. Using PC to control lighting.
    By gguy in forum General Hardware Discussion
    Replies: 7
    Last Post: 10-16-2007, 07:11 PM
  2. Kenwood In-dash Monitors to control pc?
    By DrBuzzo in forum LCD/Display
    Replies: 4
    Last Post: 12-08-2004, 07:21 AM
  3. cd changer control to control the pc
    By babas151 in forum General Hardware Discussion
    Replies: 6
    Last Post: 10-25-2004, 11:21 PM
  4. software to control pc from ipaq
    By spud42 in forum Software & Software Development
    Replies: 3
    Last Post: 11-13-2001, 12:56 AM
  5. Using a pda to control a normal PC
    By All4Norway in forum General Hardware Discussion
    Replies: 0
    Last Post: 08-27-2000, 07:52 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •