Page 2 of 5 FirstFirst 12345 LastLast
Results 11 to 20 of 42

Thread: zilla's 1995 Accord (Aus represent!)

  1. #11
    Variable Bitrate
    Join Date
    Jan 2006
    Posts
    348
    Damn! Those connections were so dodgy, even dodgy would call them dodgy. I'm glad you managed to sort it all out yourself.

    Interior looks neat too.

  2. #12
    Constant Bitrate
    Join Date
    Sep 2008
    Location
    Western Australia
    Posts
    169
    Tools and stuff
    Thought I'd list out the main stuff that have come in handy so far:

    Sandpaper + Swiss army knife (never found it so useful :P)


    Steel wool:


    Rubbing alcohol. Very handy for cleaning surfaces before epoxy/filler/etc. Even on some electrical contacts:


    Epoxy.. good stuff, forgot to check the temperature range before I used it but I checked it out after and it will be fine in the car even on a very hot day:


    Body filler


    Ze soldering iron. Oh she's misused so badly


    And of course the electrical tape:

  3. #13
    Constant Bitrate
    Join Date
    Sep 2008
    Location
    Western Australia
    Posts
    169
    Quote Originally Posted by corvettecrazy View Post
    That starter ground looks horrid. It also looks like it must have fallen out of its ring terminal and instead of fixing it properly they just twisted the wires and bolted it back on. YIKES!!
    I know! I can't believe I've been driving around with it like that. I thought I had fixed all the dodgy wiring from the previous owner but they were obviously more retarded than I give them credit for. I mean the other ones were just corroded/etc but this was something else :O

  4. #14
    Variable Bitrate bemenaker's Avatar
    Join Date
    Nov 2008
    Posts
    240
    Looking good.

  5. #15
    Constant Bitrate
    Join Date
    Sep 2008
    Location
    Western Australia
    Posts
    169
    I sorta didn't really take many more pictures since but the install is just about done. The screen is in, new power & speaker cables have been run, and the case is mounted in the boot. Only problem I've been having so far is a lot of noise on the front speakers... I'll post some pics later

  6. #16
    Variable Bitrate bemenaker's Avatar
    Join Date
    Nov 2008
    Posts
    240
    Hey Zill post some more pics man, I've been waiting to see how yours turned out. Can't wait to see it. Glad to hear you have it in now.

  7. #17
    Constant Bitrate
    Join Date
    Sep 2008
    Location
    Western Australia
    Posts
    169
    Damn I haven't actually gotten around to doing this yet. I have my dash out at the moment spraying it back to black and converting all the interior lights (bar the cluster) to red. The A/C controls are proving to be very annoying.

    Anyway I might be able to finish tomorrow and post some pics :P

  8. #18
    Variable Bitrate
    Join Date
    May 2008
    Posts
    237
    Don't forget the pics!

  9. #19
    Newbie bigdakota98's Avatar
    Join Date
    Jun 2008
    Location
    Beaverdam, Virginia, United States
    Posts
    50
    Looking Good!

  10. #20
    Constant Bitrate
    Join Date
    Sep 2008
    Location
    Western Australia
    Posts
    169
    Crap, falling behind schedule. Will try tomorrow

Page 2 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. 1995 Accord Aero Deck install
    By 273BeLow in forum Worklogs
    Replies: 1
    Last Post: 01-10-2008, 02:01 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •