Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: 05 Pontiac Grand-AM - AMD X2 250 AM3 CarPC

  1. #1
    Low Bitrate eigenVector's Avatar
    Join Date
    Apr 2009
    Posts
    80

    05 Pontiac Grand-AM - AMD X2 250 AM3 CarPC

    So here's my official work log for my carPC

    Vehicle: 2005 Pontiac Grand-AM SE1

    Motherboard: Asus M4A88T-I Deluxe mini-ITX (Installed 2010-09-09)
    CPU: AMD Athlon II X2 250 Regor 3.0GHz 2 x 1MB L2 Cache Socket AM3 65W Dual-Core (Installed 2010-04-21)
    Memory: 1x4Gb G.SKILL SoDIMM DDR2 1066Mhz PC3 8500 RAM (@1066Mhz) (Installed 2010-09-09)
    Case: Silverstone Sugo SG05-B Mini-ITX Tower
    Hard drive: 1x OCZ Summit 120 GB MLC SSD
    Power supply: Opus 360W Intelligent DC-DC PSU
    Monitor: Lilliput 669GL HDMI High Brightness +5 Wire Touch (Installed 2010-09-09) (Thanks mp3car.com!)
    Keyboard: 1x Logitech Mini Dinovo Bluetooth Mini Keyboard

    Front End: Custom .NET +WPF Application (MediaElement for Audio/Video playback +Gps Tracking +GreatMaps .NET)


    Archived Items:
    Motherboard: Zotac GeForce 8200 mini-ITX (Removed 2010-09-09)
    CPU: AMD Athlon II 7850 BE Kuma 2.8Ghz Dual Core 95W (Removed 2010-04-21)
    Memory: 2x2Gb G.SKILL DDR2 1066Mhz PC2 8500 RAM (@800Mhz) (Removed 2010-09-09)
    Monitor: Lilliput EBY-701 (Removed 2010-09-09)

  2. #2
    Low Bitrate eigenVector's Avatar
    Join Date
    Apr 2009
    Posts
    80
    Place Holder - The Issue Log

    Issue #1: I purchased a mo-co-so case, however I was unable to fit the planned OCZ HPC Reaper DDR2 memory modules into the case. These puppies are just too tall!
    Resolved: Put the HPC Reaper memory modules into my desktop to bring it back up to 8GB.


    Issue #2: I purchased a mo-co-so case, however I was unable to find a decent heat sink to fit the case.
    Resolved: Purchased the Silverstone Sugo mini-ITX Case


    Issue #3: I had originally installed a 125W AMD Phenom X4 9850BE Quad core CPU, however this puppy ran really hot on my afternoon commutes after a long day of sitting in direct sun light. Core temperatures ran into the mid 60C's when I decided to just turned it off.
    Resolved: My father was building a new computer, so I had him purchase me the AMD X2 7850 Black Edition CPU, and trade him the used Phenom.


    Issue #4: Nowhere to mount the monitor! The one place I can mount it, it leans forward causing the adhesive to unstick and the monitor to fall forward...
    Resolved: I hacked a really nasty looking rig that adds pressure to the mount from the windshield. It's not pretty, but it works.


    Issue #5: Sleep issues with the Zotac board. So aparantly my zotac board won't wake up from sleep mode correctly with windows x64.
    Resolved: For the time being, I reverted to Windows 7 x86 edition. This bandaid'ed the issue.


    Issue #6: Deluo GPS went out... Wow the battery just started growing and I think it'll explode sometime soon if I keep it in here.
    Resolved: I replaced it with a nice QStarz BT-q890 MTX receiver. It listens on blueooth and works over usb, so I can have 2 comm ports to it without using a software com port multiplexer.


    Issue #7: So my factory battery has got to be replaced in my car. It's just not going to cut it with the amount of power I'm drawing.
    Resolved: Replaced with deep-discharging battery.


    Issue #3b: CPU Scaling isn't working on this board.
    Attempt: Purchase AM3 Athlon X2 250 3.0Ghz to see if it works. Benefits to this include lower TDP (65W vs 95W) as well as AM3 support for future update.
    Resolved: Eventually resolved when upgraded motherboard to the asus.

    Issue #5b: Attempting to see if Zotac ever came up with a solution to sleep/resume in windows 7 x64, reinstalled x64 windows (Would like to eventually upgrade to 8Gb). No, no updates fixed it. Still refused to resume from sleep.
    Resolved: Began looking for upgrade to carPC (Plan to move the zotac components inside for home theater use.) Purchased an Asus M4A88T-I Deluxe AM3 HDMI/DVI board, reusing the AM3 Athlon X2

    Issue #5c: The asus successfully resumes from sleep, however the monitor never gets a 'wake up' signal from the motherboard. The computer is on (music playing, remote desktop works) but monitor claims no input on the hdmi.
    Attempt: power cycle the monitor a couple of times. Result: Didn't fix it.
    Resolved: Updated BIOS to 0501.

  3. #3
    Low Bitrate eigenVector's Avatar
    Join Date
    Apr 2009
    Posts
    80
    Place Holder #3 - Development of the Front End

    Edit: With the purchase of the Lilliput Eby-701, the plans for this application have been scrapped.


    Device: AT&T Tilt
    Device OS: Windows Mobile 6.5 Professional
    CE OS: 5.2.21502
    Build: 21502.5.0.70
    ROM: HyperDragon IV

    I configured windows 7 RC1 to auto-login.
    I wrote a WPF app in C# 3.0 (.NET 3.5) that exposed a TCP Service for exchange of message to a Windows Mobile device that's connected to the network.
    I configured windows to automatically start the app on startup

    Functionality includes:
    - Sending screenshots of desktop to windows mobile device
    ---> Partial screenshots at multiple zoom levels and quality levels
    - Allowing sending of finger touches from the windows mobile device to provide mouse clicks to desktop
    - Playing of music and video by making use of Windows Media Player ActiveX control
    - Allowing the sending of play/pause/ff/rw/stop/next/prev commands to windows media player
    - Allowing sending of screenshots of WMP to windows mobile device for watching videos and music visualizations (Currently ~4fps)
    ---> Have plans to replace this with streaming the video content to a WMP Mobile active x control while still playing audio through the car stereo.
    ---> Haven't thought through this yes, since I know there will be delays between the audio and video
    ------> I may attempt to stream the file to the phone for complete playback on the phone, and having the phone send the audio back through the carPC, but this seems like a bit too much work.
    ------> I'm considering using UDP multicasting for transmission of video, since it supports dropping datagrams when there is no device present, and should automatically connect when I plug the phone in over activesync.
    - Added support for viewing video and desktop images in both portrait and landscape mode.
    - Allowing browsing of PC file system on windows mobile device for easy playing audio/video and enqueing files for playback.

    Planned functionality:
    - Currently I have a GPS Tracking application that I wrote running on my Windows Mobile phone. I plan to migrate this application to the CarPC for navigation enhancements.
    - Quick access to favorite news sites (DrudgeReport/Boortz) as morning headline viewing for my morning commute
    - Quick access to weather information based on GPS data

  4. #4
    Low Bitrate eigenVector's Avatar
    Join Date
    Apr 2009
    Posts
    80

    Pictures!

    2009-04-13: Zotac motherboard with original OCZ HPC Reaper memory chips and AMD Phenom 9850 Quad Core CPU:


    2009-04-26: Swapped out the OCZ Memory with the G.SKILL and installed Arctic Cooling Low Profile Heat sink:


    2009-05-14: Removed HS in preparation to replace AMD Phenom Quad Core with AMD X2 7850 Dual Core. I had to remove the motherboard from the case in order to get the heat sink off:


    2009-05-19: After installing new CPU, testing and configuring started putting the components back together. Installed 120mm panaflow fan at the top of the case. (Fit perfectly where the AC/DC PSU used to sit)


    2009-05-19: Reinstalled Opus DC-DC PSU into side of the case where a PCI card would normally sit:

  5. #5
    Low Bitrate skeet2331's Avatar
    Join Date
    Feb 2005
    Location
    Indiana
    Posts
    97
    Do you plan on hibernating the computer? With 4GB of ram i don't know what you will use it all for. 1GB is usually more than enough.
    Lilliput EBY701, M2-ATX, Intel 1.8 GHz, 1GB Ram, 160 GB 2.5 hard drive, Centrafuse, Garmin Mobile PC, GlobalSat BU-353.
    My 2000 Saturn SL2 Worklog

  6. #6
    Low Bitrate eigenVector's Avatar
    Join Date
    Apr 2009
    Posts
    80
    Quote Originally Posted by skeet2331 View Post
    Do you plan on hibernating the computer? With 4GB of ram i don't know what you will use it all for. 1GB is usually more than enough.
    I'm planning on using s3 sleep mode, however I can't get it to work correctly. Zotac claims it's a bug with vista and this specific nforce chipset. But right now it setup to hybernate.

    I'm gonna have a lot of background services collecting data from various peripherals over time, but right now it's only using about 150 mb or so. I've got SQL Server 2008 Express Edition installed, and it will be collecting most my OBD/GPS data whenever I port it over from my Windows Mobile device. So I'm sure I will make use of the 4gb eventually.

  7. #7
    Low Bitrate eigenVector's Avatar
    Join Date
    Apr 2009
    Posts
    80
    So I keep running into issues that's requiring me to use a monitor of some sort. (That is when windows fails to load successfully.) My most recent problem is windows is asking me to launch a recovery session due to a shutdown problem. For some reason windows is defaulting this option instead of "start windows normally" like one would normally see with a 30second time out. So since my remote session service doesn't get started I've got no way to interact with the PC.
    I've got a 19" 5ms LCD around the house that I could attempt to convert to DC power, but since I honestly have no idea about the ins and outs of electricity (other than what I learned in physics 1 and 2) I think I'll pass on this option.

    As a result, I just went ahead and purchased a Lilliput EBY701 from sharptron over at ebay. This will probably force me to rethink my entire plans. I guess I can create my own front end using WPF since I'll no longer be needing to use my windows mobile as a display.

  8. #8
    Low Bitrate eigenVector's Avatar
    Join Date
    Apr 2009
    Posts
    80
    So I purchased the Lilliput EBY-701.
    The VGA+USB cable supplied was not long enough, so I purchased a couple of 'extension' cables for vga and usb.

    Belkin 10' VGA Extension Cable
    Mediabridge 10' USB Extension Cable
    - Both cables run from the PC to the Lilliput custom cable

    I also purchased another USB Extension cable and a USB Hub to supply my peripherals.
    Tripp Lite 16' USB Extension Cable
    Targus Ultra Mini USB 2.0 4-Port Hub


    The lilliput itself works great. Picture is good, touchscreen is very responsive. It does have a bad glare when the sun is in certain places, or if the sun is shining on me when I'm wearing a brightly colored shirt, but most of the time it's very visable and readable.
    When I plugged it in for the first time I had problems with the calibration test. It told me to tap the little X until the progress bar reached 100%, but every time I tapped the x, the progress bar would reset back to 0, so I just tapped it about 30 times, then gave up and let it go on and reach 100% on it's own.
    Also, It seemed that it was sending my mouse position as if it were rotated onto a portrait screen. It wouldn't move the cursor where I clicked, but to a relative position rotated 90*.
    After restarting, it all of a sudden started to work perfectly; It started clicking where I selected.

    Now... I had to think carefully about where to mount the monitor. And to be honest, I'm still debating this.
    - I am not installing it where my stereo is because I do not have an amp, and it's the only thing powering my speakers.
    - I cannot mount it on the dash for a couple of reasons
    • 1) It would block my field of view
    • 2) The air conditioning vents on the 05 grandam are cylindrical so it has three bumps, and no flat surface.

    I decided to mount it infront of the center airconditioning vent. The problem here is I cannot find an adhesive tape that is strong enough to support the weight of the monitor. The surface where I'm mounting it is flat, but it has two different levels of flatness, one thats above the other, so it's leaning downwards. It was suggested to me to just drill a couple of holes into the casing, and that should take care of it, without destroying the dash itself. I was hoping to maybe find some clips that could fit between the dash and the casing instead but I'm not sure where to look.





    If you're curious about the little black thing hanging down from the windshield that looks like a goa'uld, It's a part of the mount I used for my windows mobile phone. I am thinking about making use of it to help stabilize the monitor and prevent it from falling forward, but so far I don't really have that figured out yet.

    The monitor in this position blocks my center airconditioning vent, but that's alright. I can aim it up to help air get into the back seating area, and the other two vents work fine to push air around the monitor.

  9. #9
    Low Bitrate eigenVector's Avatar
    Join Date
    Apr 2009
    Posts
    80
    After lots of searching, and lots of reading through varios input threads, I decided to purchase the Logitech Mini Dinovo bluetooth keyboard, and so far, I'm absolutely loving it. I was really looking for a good one handed thumb keyboard, but this one sold me with it's additional cursor touch pad. I thought about using gremote, but it required too many button presses to setup every time I want to use it. With this, I just flip it open, and it's ready to go. I'm also quite pleased that I can finally get into the bios without having to get out of my car and open the trunk. Great work on this one logitech!



  10. #10
    Low Bitrate eigenVector's Avatar
    Join Date
    Apr 2009
    Posts
    80
    Replacing my battery today... with an Excide Orbital (~1000CA/~800CCA) battery. Good bye factory battery!

    Updated pic from passenger seat:

Page 1 of 2 12 LastLast

Similar Threads

  1. How to: Change windows shell
    By IntellaWorks in forum WinNT Based
    Replies: 44
    Last Post: 04-12-2012, 08:29 PM
  2. Testers wanted for Palm/Windows Mobile front end
    By PDAKey in forum StreetDeck
    Replies: 32
    Last Post: 02-11-2008, 11:52 AM
  3. Indexing music in 1.0.9.8 Failed
    By hovalistic in forum StreetDeck
    Replies: 0
    Last Post: 07-07-2007, 12:19 PM
  4. CarPC Front End Looks on Mass Production Radios
    By lfilomeno in forum General MP3Car Discussion
    Replies: 2
    Last Post: 06-03-2007, 10:25 AM
  5. Telematics.net
    By IntellaWorks in forum Software & Software Development
    Replies: 40
    Last Post: 11-05-2004, 09:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •